Annoying noise from case after changing ram in Unibody MBP

Discussion in 'MacBook Pro' started by sn0warmy, Apr 21, 2009.

  1. sn0warmy macrumors 6502a

    sn0warmy

    Joined:
    Mar 26, 2009
    Location:
    Denver, CO
    #1
    EDIT: Solved in 3rd post!

    This is driving me INSANE!! I just bought my Unibody MBP a few weeks ago. I immediately upgraded the ram from 2gb to 4gb from newegg. Performance wise there is absolutely no issue. The issue I have now is really strange. The silver plate that covers the battery and harddrive makes a lot of "clunking" noise whenever I set the laptop down now. Even if I set it down as gentle as possible it sounds like I'm slamming it down. I've come to the conclusion that it's the clips that slide into the front, when reinserting the plate into position.

    Whenever I set the laptop down it clunks around like it's really loose. I have reinstalled it 5+ times and I am absolutely sure it is installed correctly. Has anyone else experienced this issue after installing ram in their new Unibody?

    This is a pic of the location of the plate I'm talking about (I've circled the areas where the clips go in and seem to be making noise):
    [​IMG]

    It's bothering me because now my $2,400 laptop sounds like a 10 year old piece of ****.
     
  2. sn0warmy thread starter macrumors 6502a

    sn0warmy

    Joined:
    Mar 26, 2009
    Location:
    Denver, CO
    #3

    It actually seems like the people in that thread are having a different issue than I am. They are saying it doesn't "sit right" and their pictures prove that their covers are bulging out. Mine, however, sits completely snug and aligned with the rest of the body. I actually figured out the clunking issue. The top left and right corners were barely taping the case. I put two tiny pieces of electrical tape on the bottom (non-visible) side of each corner and BAM problem solved.
     

Share This Page