Annoying problem in Pages - Please Help!

Discussion in 'Mac Basics and Help' started by emjaycee18, Jun 14, 2010.

  1. emjaycee18 macrumors regular

    Joined:
    Jun 14, 2010
    #1
    I'm new to Mac's, when I try to copy from a website into Pages, Pages inserts a Paragraph break at the end of each line. Is there an option to paste as plain text, or even better yet to turn off the Style Guide (I believe it's called that) all together.

    Any help given is greatly appreciated.
     
  2. PeggyD macrumors 6502a

    Joined:
    Jan 9, 2007
    Location:
    Covington, WA, USA
    #2
    That's not a Pages problem, it's the way the text is formatted on the web page.

    You could install WordService by Devon Technologies. One of the services it adds is removing line feeds. I've not been able to get it to work as I'd like, so I have an AppleScript that does it. Go to my iDisk & download Pages Unwrap Text.scpt & use that.
     
  3. mrbash macrumors 6502

    Joined:
    Aug 10, 2008
    #3
    There are two options;

    1. You can re-format the text style to remove the space after a paragraph break.
    2. You can first pate the text into a text window such as a console program, and then copy the text out of that to paste into Pages.
     
  4. yojitani macrumors 68000

    yojitani

    Joined:
    Apr 28, 2005
    Location:
    An octopus's garden
    #4
    I paste all text into textedit set to 'plain text only' then copy and paste from textedit. It's the best way to avoid picking up annoying formatting from webpages.
     
  5. shwc macrumors regular

    Joined:
    Jul 2, 2005
    #5
    There is no need to go through TextEdit (etc.) to get rid of formatting.

    Instead of using the "command + v" command when pasting, use the "command + option + shift + v" instead.
    The "command + option + shift + v" is the past and match style command.

    The past and match style command will not remove line breaks, but will fix most other formatting issues when copy-pasting between programs. The command works across all native osx applications.
     
  6. yojitani macrumors 68000

    yojitani

    Joined:
    Apr 28, 2005
    Location:
    An octopus's garden
    #6
    I didn't know that one. Nice!
     
  7. emjaycee18 thread starter macrumors regular

    Joined:
    Jun 14, 2010
  8. shwc macrumors regular

    Joined:
    Jul 2, 2005
    #8
    I too used to make the detour through textedit until I finally got frustrated one day, convinced that there must be a better way. It took a couple of hours of searching to find what was, after all, staring me in the face. The command was in the "edit" drop down menu, I just had never seen the command before (or understood what it did if I did see it).

    Glad the information was useful.
     

Share This Page