Annoying problem installing Ubuntu 8.04

Discussion in 'Windows, Linux & Others on the Mac' started by SriKrishna108, May 10, 2014.

  1. SriKrishna108, May 10, 2014
    Last edited: May 10, 2014

    SriKrishna108 macrumors newbie

    SriKrishna108

    Joined:
    Jan 4, 2014
    #1
    Hi,
    So I have been trying to dual-boot Ubuntu Linux 8.04 on my MacBook, but it just hangs on a plain black screen after I tell it to either try it before installing or just install it!:mad:
    I tried Safe Graphics Mode, didn't help. What gives, and how do I fix it??:confused:
    I hear it's a common problem with NVIDIA GPUs, which I have one (GeForce 9400M 256 MB).

    Thanks in advance.
     
  2. pedromcm.pm macrumors 6502

    Joined:
    Mar 23, 2014
    Location:
    Porto, Portugal
    #2
    Weren't those problems solved on recent Ubuntu releases?
     
  3. Henk Poley macrumors regular

    Joined:
    Sep 22, 2008
    #3
  4. Quackers macrumors 6502a

    Joined:
    Sep 18, 2013
    Location:
    Manchester, UK
    #4
    You may need a boot prompt such as nomodeset to get video working.
    Having said that Ubuntu 8-04 is old and consequently uses old kernels.
    As suggested above a newer version would have more support for more recent hardware. I would try something as late as 14-04, even.
     
  5. SriKrishna108 thread starter macrumors newbie

    SriKrishna108

    Joined:
    Jan 4, 2014
    #5
    Tried 14.04...

    I tried 14.04, and it's just giving me a whole new set of problems, even with nomodeset. It hangs on this purple screen with all these dots that cycle white and orange (perhaps a something scrambled?). What gives?!
     

Share This Page