Annoying Safari 9 sidebar popping up

Discussion in 'OS X El Capitan (10.11)' started by Aquamite, Oct 3, 2015.

  1. Aquamite macrumors regular

    Aquamite

    Joined:
    Oct 2, 2014
    #1
    Does anybody know how can I turn off the annoying reading list from popping up each time I place the cursor to the left side of the screen? It really bugs me! Thanks.
     
  2. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #2
    My sidebar shows and hides according to View > Show/Hide Sidebar. It never pops up when hidden.
     
  3. Aquamite thread starter macrumors regular

    Aquamite

    Joined:
    Oct 2, 2014
    #3
    On Safari 9 my side bar appears every time I take the cursor arrow to the left side of the screen WHEN Safari is on full screen mode. I forgot to point that out. It's REALLY ANNOYING. I can't cope with it anymore. I need help. How can I deactivate this? :(
     
  4. chabig macrumors 68040

    Joined:
    Sep 6, 2002
  5. Aquamite thread starter macrumors regular

    Aquamite

    Joined:
    Oct 2, 2014
    #5
    [​IMG]
     
  6. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #6
    I'm stumped. Mine doesn't pop up. Perhaps someone else will have an idea.
     
  7. Aquamite thread starter macrumors regular

    Aquamite

    Joined:
    Oct 2, 2014
    #7
    Have you tried on full-screen mode? This new feature of Safari was even showcased at the WWDC June event in a demo if I remember well and it should be the normal behaviour so I have no clue why it's not working the same way on your mac.
     
  8. LV426 macrumors 6502a

    Joined:
    Jan 22, 2013
    #8
    I find it's a useful feature. More convenient than clicking the 'Show sidebar' icon.
     
  9. Aquamite thread starter macrumors regular

    Aquamite

    Joined:
    Oct 2, 2014
    #9
    I'm so used to place the mouse on the left side so I don't click accidentally on some link I do it unconciously. Now every time I do that that annoying bar pops up. If I want it to pop up I'd rather press ctrl+cmd+2 I don't need this nonsense feature bothering me all the time.
     
  10. MacGizmo macrumors 6502a

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #10
    Perhaps you would be better served to stop doing your nonsense of clicking links you don't want to click instead—that way you don't have to worry about it.
     
  11. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #11
    Probably easier to adjust your behaviour. I’m currently running the latest beta of El Capitan 10.11.1 and it can’t be disabled here either.
     
  12. Aquamite thread starter macrumors regular

    Aquamite

    Joined:
    Oct 2, 2014
    #12
    Obviously, I don't do it on porpoise. My old trackpad click doesn't work so I changed its behavior so it works like a normal Windows trackpad where you make clicks by touching instead of pressing.

    I just tend to take the cursor to the side while I scroll so I don't make any accidental clicks while doing the scrolling gesture. And now that annoying bar pops up all the goddamn time.

    This change in Safari might be very useful for some but it makes no sense at all to have it on by default and not being able to turn it off. It's literally a huge "what the ****". It's so annoying I don't even know what to do. I can't change my 4 years adapted behavior in a few days. This is ********.
     

Share This Page