"Another device in the network is using your computer's IP address

Discussion in 'Mac Basics and Help' started by Sky3196, Aug 12, 2015.

  1. Sky3196 macrumors newbie

    Sky3196

    Joined:
    Aug 12, 2015
    #1
    Hi all, I know this has been posted about before many times, but my problem is I have tried all of the suggested solutions and none have worked for me. I am currently staying at a hotel, and I received this message the second day I was at the hotel. The first day I had excellent connection to the wifi with no problem. In order to try and solve the problem, I have changed my computers location, renewed the DHCP lease, set a manual IP address (originally it was listed under default "using DHCP option") and have restarted my computer many times. Since I am at a hotel and don't have access to the router, is there amything else I can do? Thanks!
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    That's a tough one. Macs sometimes like to stick with the same IP even though nothing is set that way. Static won't work due to the hotel's setup, most likely.

    Do you have a phone or tablet that's also connected?

    The things you've tried are good. Did you also delete the network from the preferred wifi network list?
     
  3. Sky3196 thread starter macrumors newbie

    Sky3196

    Joined:
    Aug 12, 2015
    #3
    I did also delete it from my preferred wifi list, but curiously I still do not have to re-enter my password. I have tried shutting down my computer at several of these points as well. The one other thing I tried was switching my computer to its window partition (it is dual platform), and I had no more success with that. I had an iPhone that was connected, but I immeadietly disconnected it this morning when the problem arose.
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    The password must be in your Keychain. I wouldn't think deleting it there, then reentering it on connect, would make any difference...but who knows?

    I don't know if there are any specific Terminal commands to force the Mac to get a different IP via DHCP but you might try researching that. Perhaps using Terminal just to renew the DHCP lease might yield better results than the Network settings.
     
  5. LOLobo macrumors member

    Joined:
    Nov 20, 2014
    #5
    Not sure if this suggestion is crap, but there are tutorials out there on changing or spoofing your MAC Address on your NIC card.

    It may be a long shot, but since you are having issues on both OS's, the router may be assigning your IP Address based on the MAC Address of your NIC.
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    I have been around a lot of hotels over the years. Some have wonderful networks. Others are - not quite so wonderful :p
    You won't have any control over the router in a hotel, and the hotel ultimately has complete control over whether you even get to connect.
    Often, your connection troubles will be the hotel's (weak) attempt at making a network that is reliable in all rooms (and not quite as successful as they want you to believe)
    When you are not using any particular IP address, then someone else new on the network will likely connect using that address.
    And, when you next choose to connect, that address may not be available (in use by another device), so a static address might work for one time, but is not likely to be useful on a continuing basis.
    You MIGHT be able to make arrangements with the hotel, where they could assign you a working static address... I bet that's a little unusual at a hotel.

    Why not just leave your network set to use the DHCP server? Restart your Mac each time that you connect to the hotel's network. It SHOULD work just to quit your browser, then relaunch, but not on some networks.
    That would automatically choose the next available address.
    If you always get that "another device is using the IP address), then you might have to click the "renew DHCP Lease" button in your Network pref pane each time you connect.

    A larger hotel might have a business center. There may be other options for a better connection in that location, if possible.
     

Share This Page