Resolved Another device on the network is using your computer's IP Address

Discussion in 'Mac Basics and Help' started by Gregger84, Jul 15, 2013.

  1. Gregger84, Jul 15, 2013
    Last edited: Jul 17, 2013

    Gregger84 macrumors newbie

    Jul 15, 2013
    Good evening everyone.

    I came home from work tonight and found the message in the above subject line (Another device on the network is using your computer's IP Address) on my computer, which scared the hell out of me. It I hasn't shown up after I clicked out of it, but I reset the router, rebooted my computer, and made sure that the network was using DHCP automatically. Still no Internet on any of my devices, even though the wifi seems to be connected fine. Any ideas about what I can do to solve this?
  2. BrianBaughn macrumors 603


    Feb 13, 2011
    Baltimore, Maryland
    What else is on the network?

    You can use some sort of network scanning software to see what's on it, just to be sure.

    I have the "Fing" app on my iPhone for that. Use it all the time for work.
  3. Gregger84 thread starter macrumors newbie

    Jul 15, 2013
    That would be my desktop, iPad, PS3, Galaxy S3, and my roomate's iPhone, laptop and a wireless printer. I'm pretty sure that's all. This is the first time this has happened, and we haven't added any new devices to the network in a long time.

    I just downloaded the Fing app, thanks for the recommendation. I will take a look at that when I get home from work tonight.
  4. benwiggy macrumors 68020

    Jun 15, 2012
    If the wireless printer (or one of the other device's) is set with a manual IP, then you might get into trouble if the DHCP also assigns that number.

    Netstat in Utilities > Network Utility will also reveal what's going on.

    You don't need to be scared by this. You want to be scared by the devices you don't get error messages about! :D
  5. WesCole macrumors 6502a

    Jul 1, 2010
    I used to have that issue with DHCP and multiple devices on my network. It would only happen when one of the devices was asleep for a while, then I guess something else woke up and took its IP address. I reserved a range for static IPs on DHCP and just assigned my main devices static IPs. I haven't had the problem since.
  6. FoxFifth macrumors 6502

    Oct 18, 2012
    I have had that message when a device was asleep when the router rebooted. What happens is that when the router reboots it doesn't see the sleeping device and it assigns another device the address of the sleeping device. When that device wakes up it finds that 2 devices have the same address. I solved it just by rebooting all of the connected devices.
  7. Gregger84 thread starter macrumors newbie

    Jul 15, 2013
    @FoxFifth: That makes sense, but I'm not getting internet on any of my devices, and I've rebooted most of them already, multiple times. Shouldn't that problem only effect the two devices sharing the IP?

    What you explained seems to be what happened, though. My roomate's girlfriend rebooted either the router or modem, I'm not sure which, while my computer was asleep on my desk, and when I woke it up that error message popped up. I just don't understand how it effects all of my devices.

    @WesCole: so if I wanted to assign static IP's, how do I set that up?

    @benwiggy: I only got freaked out because I originally thought someone from outside of my network was hacking in. I've never had this issue before, so it was alarming to see that message.

    Thanks for the suggestions, guys. I'm really anxious to get home now and hammer out a solution.
  8. WesCole macrumors 6502a

    Jul 1, 2010
    The static IP addresses are configured on each PC under Network Preferences. You can basically assign any IP address that is available...for example, if your router is at, you could make a range of for 100 devices. Reserving those addresses in DHCP varies depending on the router, but if you Google your router and info on reserving DHCP addresses, it should be fairly straightforward.
  9. FoxFifth macrumors 6502

    Oct 18, 2012
    Not sure why it would affect other devices. I would shut down all devices and the reboot the router while all devices are off (if you haven't tried that).
  10. Gregger84 thread starter macrumors newbie

    Jul 15, 2013
    So i got home, unplugged everything in my house, reset both the router and modem, and still am not getting service on any device. Wifi signal is still strong, but there's a disconnect somewhere and it's driving me nuts. I haven't set static IPs yet, is that my only option left?


    Forgot to also mention that I also just replaced the modem that was there yesterday in case there was something wrong with it but the problem still exists
  11. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    On you Mac go into System Preferences->Accounts (User & Groups in 10.8) and use the 'Location' pull-down and choose 'Edit'. Then use the + sign to create a new costumed named Location (calling it what ever you want) and don't forget to 'Apply' all the windows after the new location make to completely Save the new Location. Then rejoin your network.
  12. mgipe macrumors demi-god


    Oct 6, 2009
    This may be why you are not getting Internet service, especially if you are getting served by Cable and your provider has not reconfigured to use the new modem.

    As for the duplicate IP, do you by any chance have your Mac connected by Ethernet wire AND wifi? If so, you can get this error.
  13. Gregger84 thread starter macrumors newbie

    Jul 15, 2013
    Just wanted to thank everyone for helping out, I got the issue resolved. Once I replaced the modem and it still wasn't working, I got frustrated and posted that last message and left it alone for the night, completely forgetting to register it with optimum. This morning I checked out the thread and sure enough, that was the last thing I needed to do to get it going again.

    So I'm not sure what the original problem was but replacing the modem was the key to my particular issue. Thanks again guys, you all steered me in the right direction.

Share This Page