Another FCP General Error thread... but wait, there's more

Discussion in 'Digital Video' started by aemilianius, Aug 27, 2013.

  1. aemilianius macrumors newbie

    Joined:
    Aug 27, 2013
    #1
    Hi all,

    I've got a bit of a pickle that I can't quite wrap my head around. I'm hoping somebody on the forums here can help with my particular situation. And I know it's something that's been posted hundreds of times on forums all over the internet, but none of them can really answer my questions to the specificity that I'm really looking for. Here goes.

    I'm running a late 2008 Mac Pro with OSX 10.7.5 and a few weeks ago I had had enough of the myriad problems I was having with both Final Cut Pro 7 and Pro Tools 10. So I did a clean install of the same version of OSX, reinstalled everything, etc.

    Since then, I've been having a couple of problems that I think might be connected. The first, as you might guess, is the FCP general error. It happens after I've got FCP open for roughly 1.5 - 2 hours. Everything works fine up until around that same time frame, and then any saves and renders I try to do are interrupted by the general error.

    The second problem, which I actually noticed first, was that various different external hard drives would refuse to eject. First it happened with a USB 2.0 portable SSD, and then it happened with two of my G-Drives, both on Firewire 800. Again, I could work for a little while on these drives and eject as I pleased, but after a certain period of time they just refused to eject properly.

    As far as the standard fixes, I've tried deleting my render files and re-rendering the sequence, but that's it. Reason being, I don't think it's really an FCP issue. I think it's an OS issue.

    I'm editing on my main 4TB G-Drive, and to me it makes sense that if the OS can't eject the HD after a certain period of time, FCP can't edit from the HD after a certain period of time, the same issues happen across multiple HDs, and these issues have only been happening since I reinstalled my OS, then it has to be the OS that's the problem.

    So then, how can I fix the OS? It's frustrating enough working inside FCP to fix issues, but I have no knowledge of fixing such a strange problem inside OSX.

    Does anybody have any thoughts on what I'm describing? The simplest way to take on these problems may be to just reinstall the OS again, but that would require almost an entire day of no productivity on any of my projects, and I'd rather try to find more specific solutions before I take that route. I appreciate any ideas or thoughts on the issue, and I'll gladly provide more info as needed.

    Thanks! :)
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Since you can run Mac OS X 10.6 Snow Leopard, have you tried doing the same on a separate Mac OS X 10.6 Snow Leopard installation or is Mac OS X 10.7 Lion absolutely needed for your workflow?
    Or is it even possible to upgrade to OS X 10.8 Mountain Lion for you, HDD/SSD wise?
     
  3. aemilianius thread starter macrumors newbie

    Joined:
    Aug 27, 2013
    #3
    simsaladimbamba, I haven't tried the same things on 10.6, and I considered upgrading to 10.8 when I was reinstalling the OS, but for app compatibility reasons I decided to stick with 10.7. 10.7 isn't necessary for my workflow.
     
  4. daybreak macrumors 6502a

    Joined:
    Sep 4, 2009
    #4
    Are you editing on your main Hard Drive?. Do you see the beach ball at any time? Have you tried shut down and then restart instead of re stalling items.
    Are you using FCP-7 or X
     
  5. aemilianius thread starter macrumors newbie

    Joined:
    Aug 27, 2013
    #5
    daybreak, I'm editing on an external 7200 rpm firewire 800 drive, a 4TB G-Drive.
    I get the beach ball every once in a while when starting playback. Other than that, I just get the general error straightaway with no warning.
    Every time I get the general error or eject error, I have to restart the comp to get it to work, so I've done that many a time.
    I'm using FCP 7.
     
  6. aemilianius thread starter macrumors newbie

    Joined:
    Aug 27, 2013
    #6
    Bump? Still looking for solutions, if anybody has any more ideas. :)
     
  7. LethalWolfe macrumors G3

    LethalWolfe

    Joined:
    Jan 11, 2002
    Location:
    Los Angeles
    #7
    I don't know what to say about the drives not being ejectable, but many times FCP General Error problems are related to improper media in the timeline (H.264, very large image files, corrupt media, etc.,) or to the project file becoming too large (+90 megs).
     
  8. aemilianius thread starter macrumors newbie

    Joined:
    Aug 27, 2013
    #8
    LethalWolfe, I'm using ProRes 422, 72 dpi still images, and the project file is only 3.7 mbs. I'm pretty sure that there's no corrupted media, but I can check more. I'm still leaning on the idea that the whole file system is corrupted.
     
  9. mBox macrumors 68020

    Joined:
    Jun 26, 2002
    #9
    Wow blast from the past :)
    You might be right about a corrupt file system.
    It only takes one stupid file and be happy your not working with Avid's insane db structure :p
    The media eject problem, have you looked into an app that flushes RAM and unknown cpu usage?
    I know it smells of Windows but Ive had this issue where the drives get used by FCP (back in the day) even after you shut the app off for hours.
     

Share This Page