Another locked external HD+Time Machine problem

Discussion in 'macOS' started by dhd, Apr 6, 2008.

  1. dhd macrumors member

    dhd

    Joined:
    Dec 12, 2007
    Location:
    Hamster-Dam
    #1
    Hi there!

    I sent my mbp for repairs, and the logical board was replaced. To my surprise when I connencted my external HD TM started to make a fresh backup (my computer's name 2). Of course I wasn't aware of the MAC addresses and TM problems.
    Searching the forums I've found a partial solution: I can browse my old TM backup from the app interface, but can't resume the backups where they were left...still tries to make a new backup...
    Also the entire backup HD is now locked and it's impossible to move/rename/delete any file inside it even when the 'Get Info" menu says I have read/write access

    Has anyone any tip or idea on how to unlock my drive?

    Thanks!!!

    I've attached the info that terminal shows on the permissions (I guess the problem lies there...)
     

    Attached Files:

  2. benpatient macrumors 68000

    Joined:
    Nov 4, 2003
    #2
    I have a very similar problem.

    My brand new Mac Pro quit booting because something got corrupt (they say) in the catalog tree.

    None of the utility programs (DW, etc) worked to fix it, so my "only option" was to erase and re-install.

    I did that, and when prompted, I recovered my files from my Times Machine backup drive, which incidentally is an internal SATA drive in my machine.

    Well, the restore seemed to work OK, but when the machine came back to the desktop after the restore, almost none of my apps work. My Time Machine backup is in a continuous cycle of "finishing backup" but not doing anything. I noticed that the hard drive that I've designated for Time Machine no longer has the TM icon, just a regular hard drive icon—with one difference: a little lock.

    Now when I go to "get info" I see that my user (the admin) has "custom" access instead of read/write. So I click the orange lock and type in my admin password, and it unlocks. Then I change "custom" to "read/write" and click on the lock again...only the lock doesn't re-lock. Nothing happens. If I close out the "Get info" box and open it back up, the lock is re-locked and my user account still has "custom" access to the drive, and it is still "locked" on the desktop and if I try to write a file to it.

    My boot folder has also given me "custom" access all of the sudden (since the recovery) but there is no lock on the drive icon.

    It seems like I can write to SOME locations on my boot drive, at least.

    I can't run Onyx or Disk Utility on it, though. They both give "write permission" errors.

    I tried checking "ignore ownership on this volume" for the backup drive and nothing changed. Still locked.

    One other thing seems very strange...there is a user in my "get info" box list of users that I never put there called "wheel." It has the two-people icon instead of the single-head icon. I presume this denotes a user "group"?

    Someone help!
     
  3. KailuaFrog macrumors newbie

    Joined:
    May 20, 2008
    #3
    Same problem with lock on volume icons

    Experiencing the same problems.
    Could not boot from my normal boot partition.
    When booting from another drive, most the (int and ext) drives' icons had a little padlock on their left lower corner.
    Disk utility showed that EVERY file on the no longer booting volume had wrong permissions. I aborted Repair Permissions because the progress bar was barely reaching one third of its total length after three days and the estimated time to completion was over six days (and still growing in number)
    Result: a real :apple: WINDOWS EXPERIENCE :apple:!!! zapping the drives, re-intstalling apps,
    a not too pleasant couple of days.
    Today I noticed my iPod I had connected last night did not mount. I remove it and connect it again: It now mounts but has the padlock disease.

    Info shows two (me) users, one with custom (?) privileges and one with the normal Read & Write. Custom cannot be changed and the user cannot be removed. I had the same problem with all the padlocked drives

    I hope somebody has an idea of what is going on and a fix


    G5 2X2Ghz PPC
    6GB
     

    Attached Files:

  4. benpatient macrumors 68000

    Joined:
    Nov 4, 2003
    #4
    what's going on is that Apple tried to make Leopard smarter and ended up making it possible to completely fry your entire system with a single click and an admin password. The "get info" box is unsafe for anything other than checking the size of a file or folder. Do not ever click on the permissions stuff at the bottom of a "get info" box in Leopard, or you run the risk of killing your entire system.

    Some people have been successful changing their permissions globally in the terminal, but when I tried that, I ended up with a system drive that would not boot.

    Here's what I had to do:

    remove my data drives (my time machine drive and my data storage drive) and format/install the OS fresh on the system drive. Archive/install did not work.

    Then I had to format my time machine drive and, using my other mac (which is still using Tiger, thank goodness), I dumped all of the files from my data drive onto the now-formatted formerly time machine drive. That took several hours.

    When that was done, I formatted the data drive.

    Then I put both of the drives back into the mac pro and put time machine to work with the newly-formatted, formerly data drive. It took time machine 3 days to finish the first backup, and this is on an internal SATA drive with a read/write speed approaching 100MB/sec, and only about 500 gb worth of data. I'm no math major, but I think Time Machine has some issues that haven't been sorted out yet. Which makes me nervous.

    But anyway, that's what I had to do to get the locks to go away and stay gone. I had even tried going in as root user in the terminal and deleting all permissions that weren't "admin" or "wheel" (admin group in Leopard), or "everyone" and giving complete read-write permission of all files to everyone and everything. The lock disappeared after 2 hours of terminal going in and changing permissions on every file and folder on my system, but then 20 minutes later, I was trying to copy over a file and it said i didn't have permission to write to that folder, and I looked up and saw that the entire drive had locked again.

    piss poor.

    combine that with the now-broken spotlight searching and constant crashing of adobe apps, and let's just say that every time I see a Mac vs. PC commercial on TV making fun of Vista and talking about how great 10.5 is, I have to put down whatever is in my hands to avoid throwing it into my screen. piss poor.
     
  5. IEatApples macrumors 6502a

    IEatApples

    Joined:
    Jan 26, 2004
    Location:
    Northern Hemisphere (Norway)
    #5
    I'm currently having the EXACT same problem! And I've looked everywhere on the net and I can't find a solution! :( I even called Apple support & they had never heard of this problem before! :confused:

    Someone … ANYONE - PLEASE HELP! … pretty please? ;)
     
  6. benpatient macrumors 68000

    Joined:
    Nov 4, 2003
    #6
    There is no real help.

    My only advice to you is when you end up completely zeroing out your hard drives, don't try to copy files directly over from whatever backups you may have made into your new setup...it will spread the permissions bug around like a flu bug and screw up your fresh install just like your current one.

    I ended up moving all of my files to a Windows® based FTP and then copying them back over. I happened to have a PC at home that I could set up a free FTP host onto and then "push" all my files to it over my home network. This allowed the permissions to get completely reset when I copied everything back over to the Mac after a fresh install.

    To be specific, I'm not talking about copying Apps and settings to an FTP. Lots of those kinds of files will actually get messed up if you transfer them that way....file names may be too long, etc.

    Just copy all your media/documents and stuff like that to the FTP and then wipe your mac (zero out the drives). Install a fresh copy of OS X and then your applications. Make sure whatever you do that you don't attach a hard drive to your new install that has been interfacing with your messed up install, because the bug may have spread. Tiger is immune to this particular problem because the way it utilizes permissions is different. Leopard broke it. I honestly don't know if the most recent version of Leopard fixed it because I never want to see that problem again. I'm guessing you're on 10.5.6 and that the problem remains. Which means that Apple considers our mutual nightmare a "feature." I wonder if they counted it in the 300 new features in Leopard?

    Anyway, I guess you could also copy all of the files you want over to a Tiger-based Mac if you happen to have one still, and that would probably get rid of the bad vibes, too. I wasn't sure of this when I was fixing everything, so I went with the PC thing to try and be sure.

    I almost took my mac pro back to the store and got a refund at one point because it seemed like there was nothing I could do to stop it from happening.
     
  7. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #7
    Actually, Apple service providers and retail store locations have a 9-step process for resuming Time Machine backups after replacing the logic board. It's only viewable by representatives at such locations. If you bring your backup drive and the computer in, they will run some Terminal commands and get everything sorted.
     
  8. IEatApples macrumors 6502a

    IEatApples

    Joined:
    Jan 26, 2004
    Location:
    Northern Hemisphere (Norway)
    #8
    I called Apple and they gave me the solution :):

    http://discussions.apple.com/thread.jspa?messageID=9035132&#9035132

    but if your hard drives name includes a [space] like this: "My HD", then you must write the command like this:

    or like in my example:

    It saved both my drives! THANK YOU APPLE!!! :)
     
  9. benpatient macrumors 68000

    Joined:
    Nov 4, 2003
    #9
    wow. I was on the phone with them multiple times and every time the final recommended result was "delete and start over"

    I guess they have had to deal with this a few more times since last spring...I bet it happened to Steve Jobs and he made them figure it out.

    The fact that your permissions can get that messed up without you doing anything wrong at all is worrisome.

    I'm glad they got you sorted out.

    Not so glad that a week's worth of my time was wasted last year fixing something that needed 4 lines in terminal to fix.
     
  10. IEatApples macrumors 6502a

    IEatApples

    Joined:
    Jan 26, 2004
    Location:
    Northern Hemisphere (Norway)
    #10
    Yea, they first told me the same thing, and the guy I was talking to informed me that I was outside of my "phone support time", but as I continued to explain my problem, and how I had tried to fix it, he got interested! ;) So, he said that he would look into it (for free! :) … mostly to satisfy his own curiosity I think) and that I should call him back the next day. When I called back I was handed to another guy, and he found this solution for me! :)

    Goes to show - you should never give up! ;) :cool:
     
  11. Rampazzo macrumors newbie

    Joined:
    Aug 27, 2010
    #11
    Thanks.

    thanks a lot IEatApples, You really helpme full. thanls a lot ..
    hugs. from Brasil.
    :)
     

Share This Page