Another Problem: Mail keep fetching data while push is OFF

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Krafty, Jun 26, 2009.

  1. Krafty macrumors 601

    Krafty

    Joined:
    Dec 31, 2007
    Location:
    La La Land
    #1
    I realized that the battery draining problem was due to Push, which was on without my knowing or turning it on. So I turned it off and set fetch to manual. I noticed that when I connected to my Wifi, I heard the chime when I receive new mail, I have a 2G and my phone is jailbroken & unlocked, so when I checked the processes o n SBSettings, Mail was running.

    I checked the settings once again, and push is off along with fetch, so why is Mail running everytime i connect to my wireless?
     
  2. fixmdude macrumors member

    Joined:
    May 8, 2009
    #2

    Maybe because it's unlocked, it's free to do whatever the heck it chooses regardless of what you ask it to do... You let the dog off its leash.
     
  3. Krafty thread starter macrumors 601

    Krafty

    Joined:
    Dec 31, 2007
    Location:
    La La Land
    #3
    Uh, unlocked makes it so you can use any SIM carrier you want.....
    So far, my iPhone hasnt ran away form home yet..
     
  4. Rescuer macrumors member

    Joined:
    Jul 15, 2009
    Location:
    Bay Area, CA
    #4
    When I run the mail app to check my mail, then close it, it continues to run in the background processes still. I do not have backgrounder installed at all.

    I do have supreme preferences though, and saw a setting under the mail section to "prevent auto-launch", and have tried switching it on.

    The problem still exists.

    And if i run safari, then close it, it also continues to run in the processes until i manually kill the app in the process manager.

    push is off, fetch is manual

    Any suggestions on why it keeps doing this?

    Thanks all
     
  5. sepafe macrumors newbie

    Joined:
    Mar 23, 2010
    #5
    Hi there.
    Had this problem and made this to resolve:
    -settings-mail,contacts,calendars
    AT BOTTOM AT CALENDARS
    - turn off new invitations alerts
    - time zone support OFF

    And thats it.
     

Share This Page