Another Safari bug

Discussion in 'Mac Apps and Mac App Store' started by KingYaba, Apr 1, 2008.

  1. KingYaba macrumors 68040

    KingYaba

    Joined:
    Aug 7, 2005
    Location:
    Up the irons
    #1
    This issue only happens when I am running on battery power. :confused: I open up Safari and then, having the notebook on my lap, the machine gets a little warmer and a little warmer. I open up the Activity Monitor only to find (see attachment) my processor working a little too hard.

    This happens all the time. I have narrowed the cause: happens only on battery power. When the machine is plugged in Safari doesn't do this. This is a problem because it will eat my battery life say I continue to browse with Safari. Thankfully I have a backup in Camino.

    In this particular instance, I opened up Safari and typed google.com/news. No tabs no other windows open. No plugins installed either.

    Safari 3.1
     

    Attached Files:

  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    when this happends option click on Safari and force quit (if its not responding) or force quit it from Activity Monitor and re-open. does this help?
     
  3. KingYaba thread starter macrumors 68040

    KingYaba

    Joined:
    Aug 7, 2005
    Location:
    Up the irons
    #3
    richthomas I tried your advice but opening up Safari one minute ago it still shot my processor usage to 90%. It's not that Safari is failing to respond, just using 100% of my CPU when on battery power. :confused:
     

Share This Page