Any advice would be

Discussion in 'iMac' started by Loke2112, Oct 31, 2018.

  1. Loke2112, Oct 31, 2018
    Last edited: Oct 31, 2018

    Loke2112 macrumors regular

    Loke2112

    Joined:
    May 11, 2011
    Location:
    3 blocks off the Atlantic
    #1
    Much appreciated!!

    I am using a late 2012 iMac 21.5"

    2.9 GHz Intel Core i5

    8 GB 1600 MHz DDR3 ( Not up gradable :(

    Using a 250 GB External SSD Sandisk Using about 190 GB

    I run basic stuff Mac apps plus Spotify, AirFoil, VLC, Firefox, Safari, a VSP and maybe a few other things rarely all at once. Anyway when I first added the SSD it was like night and day but lately things have grinded to a halt way too often. I ran Malware Bites no issues there. I cant reallt think of anything I am doing differently except maybe using FF as my default browser. Can anyone recommend some steps? I want the Mac Mini oh so bad but have to save more cash first. Need to milk this puppy just a little longer. Thanks in advance!!
     
  2. mreg376 macrumors 65816

    mreg376

    Joined:
    Mar 23, 2008
    Location:
    Brooklyn, NY
    #2
    It's hard to give you advice, since you didn't say which size iMac you have, and you don't say how old the SSD is. So let's start there.
     
  3. Loke2112 thread starter macrumors regular

    Loke2112

    Joined:
    May 11, 2011
    Location:
    3 blocks off the Atlantic
    #3
    The SSD is only about 6 months old. The iMac is the 21.5” does that help?
     
  4. mreg376 macrumors 65816

    mreg376

    Joined:
    Mar 23, 2008
    Location:
    Brooklyn, NY
    #4
    Yes and no. :)

    Is this an internally installed SSD?
     
  5. ducknalddon macrumors newbie

    Joined:
    Aug 31, 2018
    #5
    You might want to install the Intel Power Gadget and see if the CPU is running hot, if it is it might be the fan is blocked or failing.
     
  6. Loke2112 thread starter macrumors regular

    Loke2112

    Joined:
    May 11, 2011
    Location:
    3 blocks off the Atlantic
    #6
    No it’s an external SSD
     
  7. Loke2112 thread starter macrumors regular

    Loke2112

    Joined:
    May 11, 2011
    Location:
    3 blocks off the Atlantic
    #7

    Thank you I did that. Followed the instructions to allow it in security and it still wont load no driver. Doesn't seem to accept that its been allowed.
     
  8. mikehalloran macrumors 65816

    Joined:
    Oct 14, 2018
    Location:
    The Sillie Con Valley
    #8
    Reset the NV RAM and SMC. Probably not the problem but start there.

    Get that HDD out of there. Install the SSD, enable TRIM and then test it properly. Even better, install a 500G or larger SSD.

    While in there, upgrade the RAM to 16G—it is upgradeable but you have to open it up.
    https://eshop.macsales.com/shop/memory/iMac/2012_21.5/DDR3L
     
  9. Loke2112 thread starter macrumors regular

    Loke2112

    Joined:
    May 11, 2011
    Location:
    3 blocks off the Atlantic
    #9

    Sounds like some great advice I will see if I can do it.
     

Share This Page

8 October 31, 2018