Any CrushFTP or SFTP pro's here? Keeps stopping/closing daemon

Discussion in 'macOS' started by lokiju, Aug 27, 2010.

  1. lokiju macrumors 6502

    Jun 10, 2008
    I started using CrushFTP as a way to set up a SFTP with accounts that have different default/home directories when they SFTP in.

    It works exactly how I want, when the app actually runs.

    I have created two different user accounts that have access to different directories and with different rights.

    When the app/gui is open I can SFTP in from an outside computer without issue.

    I can also set it to run as a daemon and close the gui out and still connect from the outside.

    The problem is that after leaving my "server" alone for 20 mins or so I can no longer SFTP in.

    I tested it with trying to just leaving the GUI open and not using the daemon and it still will close out of the GUI even if I leave it open and running.

    Like clock work it's about 15 or 20 mins after setting CrushFTP how I want, testing to confirm it works from a remote system and disconnecting from my home Mac, all the sudden I can no longer connect to it via SFTP.

    I also tried setting the daemon to run as a service and closing the GUI. When doing this I can connect right away after setting it to do so from a remote system. I'll then disconnect from my home Mac, can still connect fine but in 15 to 20 mins no dice.

    I've complete removed all the files I could find associated with CrushFTP and downloaded fresh from their site and started over but keep having the same result.

    Has anyone had a similar issue with CrushFTP or even a daemon quitting after a given amount of time over and over?

    I'm about ready to just go back to enabling SSH from sharing and SFTP'ing in that way but I just haven't been able to find a way to do that and set unique folders each user account see's with this method.

    If someone has a way to do this with whats built into OS X Snow Leopard 10.6, I'd love to hear it.

Share This Page