Any idea why VPN only works with Chrome?

Discussion in 'OS X El Capitan (10.11)' started by thadoggfather, Jun 10, 2015.

  1. thadoggfather Suspended

    thadoggfather

    Joined:
    Oct 1, 2007
    #1
    Torrent client and Safari/seemingly iCloud etc stop working with VPN enabled but Chrome works fine?

    Any idea what could be at play here when all worked well with VPN enabled?

    I know its beta, but still I'm trying to discover why.

    Even with VPN enabled, going to router console with 192.168.blah blah works
     
  2. legioxi macrumors 6502a

    Joined:
    Mar 2, 2013
    #2
    Are you using the built in VPN client? Or a third party? May be an issue with whatever client you're using. I know for Cisco AnyConnect SSL VPN I had to disable rootless, reboot, reinstall AnyConnect, enable rootless and reboot. Then it worked for me.
     
  3. thadoggfather, Jun 10, 2015
    Last edited: Jun 10, 2015

    thadoggfather thread starter Suspended

    thadoggfather

    Joined:
    Oct 1, 2007
    #3
    I disable rootless to be able to modify a display file and get resolutions that weren't supported out of the box.

    It's a 3rd party VPN client, how does one re-enable rootless?

    sudo nvram boot-args="kext-dev-mode=1 rootless=0"

    ^ that's the command I used to disable it, do I just change rootless=1

    I wonder why rootless being disable would affect VPN insofar as work with Chrome but nothing else.
     
  4. myname70 macrumors 6502a

    Joined:
    May 5, 2014
    #4
    The buildin VPN client connecting to Cisco company network - works perfectly without rootless workaround
     
  5. thadoggfather, Jun 10, 2015
    Last edited: Jun 10, 2015

    thadoggfather thread starter Suspended

    thadoggfather

    Joined:
    Oct 1, 2007
    #5
    running "sudo nvram -d boot-args" and rebooting OS X didn't seem to solve the problem.

    still only working with Chrome. so strange

    vpn is pia
     
  6. iCheddar macrumors 6502a

    iCheddar

    Joined:
    Apr 30, 2007
    Location:
    South Dakota
    #6
    You might just want to submit a ticket to PIA. The couple times I've worked with them, I've always gotten prompt responses.

    What happens if you turn on the internet kill switch in the client?

    I'd be curious if your Safari traffic is routed over the VPN, but perhaps there is a bug on Safari that exposes your home IP (I seem to remember Firefox having a vulnerability like that a while back).
     
  7. thadoggfather thread starter Suspended

    thadoggfather

    Joined:
    Oct 1, 2007
    #7
    Haven't tried internet kill switch yet,

    I don't think it's a bug specific to Safari, since iCloud and torrents seem to not work either with it on.

    i think it's more like nothing seems to work BUT chrome oddly enough

    Also I wonder how helpful they would be with ticketing on a new OS that is in DP phase and released days ago..
     
  8. iCheddar macrumors 6502a

    iCheddar

    Joined:
    Apr 30, 2007
    Location:
    South Dakota
    #8
    Are you not getting any network connectivity through Safari and your torrent client? Or are you just not sure they're routing through the VPN?
     
  9. thadoggfather thread starter Suspended

    thadoggfather

    Joined:
    Oct 1, 2007
    #9
    No connectivity, pages don't load at all they just get hung up, but as soon as I disconnect within the client or kill the app all together, the page request loads.

    Whats odd though is logging into my router dash does work within Safari, even with VPN enabled.
     
  10. XboxMySocks macrumors 68020

    XboxMySocks

    Joined:
    Oct 25, 2009
    #10
    My VPN works just fine with Rootless enabled.
     
  11. legioxi macrumors 6502a

    Joined:
    Mar 2, 2013
    #11
    I only mentioned reenabling rootless because out of the box, that is how the OS starts and my instructions gave a full start to finish so you end up where you started but with VPN. It wasn't required for AnyConnect to run... you just can't install the client with rootless enabled.
     
  12. thadoggfather thread starter Suspended

    thadoggfather

    Joined:
    Oct 1, 2007
    #12
    fixed it! had to use another VPN client.

    Tunnelblick with profile worked :D

    I was about to wipe and re-configure my machine, didnt want to out of laziness and because I'm already enjoying the butteryness of El Cap
     
  13. gødspeed macrumors regular

    gødspeed

    Joined:
    Jun 11, 2009
    Location:
    Oregon
    #13
    I'm not able to use Safari with Tunnelblick. Chrome and Transmission work fine, though.
     
  14. iCheddar macrumors 6502a

    iCheddar

    Joined:
    Apr 30, 2007
    Location:
    South Dakota

Share This Page