Any improvements for switching between android and iOS re: iMessage

Discussion in 'iPhone' started by noobinator, Dec 7, 2014.

  1. noobinator macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Pasadena, CA
    #1
    When I saw the tool at the url below launched I was thrilled because I like to switch between iOS and android and always have issues with not receiving messages because my contacts phones think I still have iMessage.

    https://selfsolve.apple.com/deregister-imessage

    Has anyone tried this out since it launched? I plan on switching back and forth weekly or even daily. Can I just use the link every time I put the sim in my android? Then when I put it back in my iPhone i just turn on iMessage and it will re-register me?
     
  2. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #2
    Signing out of iMessage before you switch will also do the trick.
     
  3. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Pasadena, CA
    #3
    Unfortunately that never worked for me in the past. You mean just turning off iMessage before taking the sim out?
     
  4. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #4
    Correct. It worked for me both times I switched to android from iOS.
     
  5. lordofthereef macrumors G5

    lordofthereef

    Joined:
    Nov 29, 2011
    Location:
    Boston, MA
    #5
    I insgibe it works the same way as signing out with your device does. I couldn't tell you if it works better or worse because I've never had issues signing out in my device.

    But really, if you're going back and forth daily, is it worth the hassle of activating and deactivating each time? I mean I guess it a since you plan to do that. What I am saying is it would be too big of s headache for me lol.
     
  6. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Pasadena, CA
    #6
    It'd most likely be weekly or even monthly but I'd like to know it's easy to do.
     
  7. Ladybug macrumors 65816

    Ladybug

    Joined:
    Apr 13, 2006
    #7
    I tried it once when I was testing an Android phone recently. I even signed out of iMessage on all of my devices and I couldn't get it to work. I followed Apples instructions but by the next day I decided to get another iPhone so I didn't worry about it anymore...You may have better luck with it.
     
  8. Stevessvt macrumors 6502

    Joined:
    Jul 2, 2010
    #8
    My brother just switched from an iPhone 4 to the Nexus 6, he used that link in the forst post and it seemed (so far) to have worked. He gets all sms messages that I and others have sent him.
     
  9. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Pasadena, CA
    #9
    Just to confirm, he is getting messages from iPhones?
     
  10. mattopotamus macrumors G5

    mattopotamus

    Joined:
    Jun 12, 2012
    #10
    This always works for me on a daily basis. Turn imessage off on all idevices you have (ipad, iphone, mac). The website is there in case you forget to turn imessage off on the actual device.

    In the past you had to call in to apple if you forgot to turn imessage off.
     
  11. lordofthereef macrumors G5

    lordofthereef

    Joined:
    Nov 29, 2011
    Location:
    Boston, MA
    #11
    I guess my point was , for me, I would just leave it in standard SMS and mms at all times. I feel like I gain very little from imessage, especially if I'm not always going to be in it anyway.
     
  12. Stevessvt macrumors 6502

    Joined:
    Jul 2, 2010
    #12
    Yep, as standard sms messages.
     
  13. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Pasadena, CA
    #13
    I tried switching to my new android phone tonight and this problem still persists.

    I went into iMessage turned it off and then powers down my iPhone. Then I took the sim out and put it in my android. Sent my android a text from my wife's iphone. Sent as iMessage. I never got it. I sent her a text. She got it. She replied. iMessage. I didn't get it.

    If she long holds the message and hits send as sms it goes thru but she shouldn't have to do this. In addition if she starts typing my name and picks it before the name is complete from the recents then it sends an iMessage. However if she types my full contact name and hits enter the. It will send as a text.

    I wonder if there is a way to delete all recents or not show recents. I even tried deleting me as a contact and re adding me with a different name and no luck. I tried using the link in my first post but I never got the confirmation messages they supposedly sent me so after five attempts they said sorry try again later.

    At this point I'd keep iMessage turned off but I can't even get it so my wife's messages come through as texts every time. Obviously this is still a problem and I'm being forced to keep using my iPhone or get a new number I guess.

    So the only way she can successfully send me a text and not iMessage is to type my full contact name and hit enter or send an iMessage the. Long hold it and select send as text. I'm supposed to make her do this? Not to mention getting all my other contacts with iPhones to do this.
     
  14. Stevessvt macrumors 6502

    Joined:
    Jul 2, 2010
    #14
    Have her (and anyone who has an iPhone you know if you want to make sure YOU get messages from them) go to settings, messages and make sure the option is on for 'Send as SMS', it will then try first as an iMessage, then when it fails it will resend as a standard SMS.
     
  15. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Pasadena, CA
    #15
    Her phone is set to this. It sends an iMessage only. That is never received by me.
     
  16. dsds2828 macrumors newbie

    Joined:
    Jan 4, 2015
    #16
    can't deactivate fully either

    Indeed, I'm having similar problems. I turned off iMessage on my old iPhone before I migrated the SIM card. I also used the Apple support tool to de-register my phone number just in case. It's been 6 days since I've done both of these steps. An Apple Support rep has today verified that my phone number is no longer registered to iMessage....

    but I'm still not getting SMS from many iPhone people. I've told people to delete our existing threads too, which seems to help, but I'm still missing messages.

    The Apple rep suggested that I make sure everyone has me in their contacts as "mobile" vs. iPhone in the 'type of phone number' field.

    I've already had to send a generic message to my contacts telling them to delete our threads, and saying that I'm not getting messages. I'm hesitant to send yet another message telling people to do something that may not actually work (and many of my contacts are not tech savvy enough to know what I'm talking about either, and I'm not about to send out a screenshot-ed how-to guide)

    Anything else I can try?
     

Share This Page