Any known issue about cheap Sammy mono laser printer?

Discussion in 'Mac Accessories' started by matrix07, Dec 22, 2011.

  1. matrix07 macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #1
    [​IMG]

    ML serie.
    The document said it supports 10.3-10.6. Don't know why it's so specific about version of OS. Anybody has this working with Lion?
     
  2. snorkelman macrumors 6502a

    snorkelman

    Joined:
    Oct 25, 2010
    #2
    got an ML1665 sitting here for rough drafts of PCB artwork that works fine under lion (all release versions .0 .1 and current .2) on 2011 mac mini

    Don't recall having to do anything tricky to get it up and running
     
  3. matrix07 thread starter macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #3
    Many thanks.
    It's strange though it is so specific on the version of OS. I would buy it yesterday if it just plainly said 10.3 up. :apple:
     
  4. snorkelman macrumors 6502a

    snorkelman

    Joined:
    Oct 25, 2010
    #4
    http://www.samsung.com/us/support/downloads/black-and-white-laser-printers/ML-1665/XAA

    lists the driver as 10.3 to 10.7, only the 'smart panel' is listed as 10.3 to 10.6

    its been a while since I installed it but I think all I installed was the driver, (IIRC the smart panel util didn't really add anything to functionality, just gave a guesstimate of current toner levels and a link to buying new toner online)

    I guess from Samsungs point of view saying '10.3 and up' is something they'd want to avoid. Holds true for now, but someone reading it two years time isnt going to be too pleased if they buy an ML to run under 10.8 or 10.9 etc and find its no longer true..
     
  5. matrix07 thread starter macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #5
    Wow, thank for the link. Yup, the driver is enough. I never want to install too many utilities in my system.
     

Share This Page