Any Tool or Code to Auto-Reconnect Dial-Up Modem?

Discussion in 'OS X Mountain Lion (10.8)' started by GreenYogi, Jan 29, 2013.

  1. GreenYogi macrumors newbie

    Jan 7, 2013

    I am using a ZTE MG880 usb modem on my windows laptop for 3 years and the GUI has an auto-reconnect option. Once checked, the network is really stable... otherwise it regularly loose the network (every 3-4 hours) and one would have to click on CONNECT each time again.
    On my MBPr with Mountain Lion... I get disconnected every 3-4 hours, every time and again.
    In Network Prefs under PPP i checked the "connect automatically when needed."
    But that has no effect.
    I wish some utility or piece of code would simply do the one click action needed to reconnect to the network when it jumps and then I can think of something else in my life. :(
    At worst, if a utility can do a sound when the network jumps, that would allow me to be alarmed. Rather than keeping an eye on my connection ALL THE TIME!
    Any tip very appreciated.
  2. The Bulge macrumors 6502

    Oct 27, 2012
    Up your ass.
    That should work. It works here just fine.
  3. GreenYogi, Jan 29, 2013
    Last edited: Jan 29, 2013

    GreenYogi thread starter macrumors newbie

    Jan 7, 2013
    ?????? What 'should work'...?
    If U mean the 'automatically reconnect' box I checked, no, it doesn't help. Loosing network every 3 to 4 hours anyway, i can be sure after 3 1/2 hours that it's about to jump. Frustrating.:eek:
    I am thinking, is there a proper way to install the ZTE software GUI on the mac (by installing the modem through wine, crossover or any such tool?), so that the mac would actually recognize the info and options selected in the GUI rather than OS X Network Prefs panel. Then I would have a stable auto-reconnect option, just as it is with windows.)

    When i tried with Parallels, I could connect in Windows 7 as usual, and have auto-reconnect on. But I was not able to use the connection established through Windows when shifting back to the Mac desktop. I then had to connect again which would cause the modem to disconnect on the Win7 platform, then only I would be able to connect in OS X. I may miss something as I am new to Parallels, but that's what I observed when I tried it.
  4. The Bulge macrumors 6502

    Oct 27, 2012
    Up your ass.
    So it connects automatically, but after some period of time connection is lost and it won't connect automatically again?
  5. GreenYogi, Jan 30, 2013
    Last edited: Jan 30, 2013

    GreenYogi thread starter macrumors newbie

    Jan 7, 2013
    Namaste The Bulge dude.

    Well no... it TRIES to connect automatically. Let's say I launch the MacApp store and it goes on connecting, declares 'authenticated', but only to disconnect immediately as it announces authentication. Weird behavior.
    Then I get the 'Authentication Failed' pop up.
    Same behavior when launching other apps requiring internet.

    So it does connect automatically indeed... but only to jump out immediately!

    Then I click on 'connect' in the menu bar and sure enough it authenticates fine.
    What can be causing the rejection of the :apple: automatic login? I can't grasp that.
    Hope someone sheds light... I am feeling this should be easy to solve.
  6. The Bulge macrumors 6502

    Oct 27, 2012
    Up your ass.
    What modem script are you using?
  7. GreenYogi thread starter macrumors newbie

    Jan 7, 2013
    No idea about scripts... if U are referring to the 'Terminal Script' box, under PPP, then it shows 'none' and there is no other option.

    Is there a script to add so that the modem will behave well? :D

    As a plus... while digging for solution I came across a suggestion to erase all entries for my ZTE network in Keychain Access.
    I did it and it caused the mac to ask me again for password before connect.
    At first it caused the manual connect to behave like the automatic connect... attempt to connect failing at authentication. Which hinted that the problem may come from the keychain access info (which I do not understand anyway).
    Then after deleting the existing configuration from the Network Prefs and re-creating a new network, it works just like before again... meaning the manual connect is fine but automatic won't authenticate.

    So there could be a fix with Keychain
  8. GreenYogi thread starter macrumors newbie

    Jan 7, 2013
    I still didn't find a solution... help !

    U mentioned a script... what was Ur idea?
  9. GreenYogi thread starter macrumors newbie

    Jan 7, 2013
    still looking for script

    I am still looking for a cure to my failing reconnection issue.
    I have been doing more research and I found my folder Modem Scripts and a unix executable file named ZTE USB MODEM which I assume is the modem script from my device installation. I copy/pasted that in a newly created Terminal Scripts folder - as it didn't exist. And it did show up in the tab for terminal script in Network Prefs panel, so I was all exited and sure it was going to fix it... well, it didn't.
    I am still thinking there is a script to add in this new folder that would do the work just fine.
    Please The Bulge if U still have any suggestion, I would be so grateful. I am just so ignorant regarding scripting...:(

Share This Page