Any way to completely disable substitutions?

Discussion in 'macOS' started by therealseebs, May 1, 2011.

  1. therealseebs macrumors 65816

    therealseebs

    Joined:
    Apr 14, 2010
    #1
    So, I find the text substitution feature annoying, and I've turned it off ALMOST completely.

    The only app I use that I know actually uses Snow Leopard's substitutions is Adium X. I don't have any other apps that I know to use these, so I can't test whether it's Adium or OS X doing this, but...

    When I type two hyphens, they get turned into an emdash. This might be a great feature in some strange parallel universe where an emdash was the decrement operator in C. It's not a great feature in this universe. However, I can't find this substitution in the language/text preference pane, nor can I find it in Adium's settings... I'm stumped.

    ETA: I created a substitution rule "--" to "--", and that's made it stop, but it does not sit well with me for OS X to have no way at all to disable this feature.
     
  2. therealseebs thread starter macrumors 65816

    therealseebs

    Joined:
    Apr 14, 2010
    #2
    Turns out I can right-click on the text field and disable "Smart Dashes". How I was supposed to know to right-click on a text field instead of using preferences, I can't guess. I also have no idea whether this will work in other apps. Whee.
     
  3. mysterytramp macrumors 65816

    mysterytramp

    Joined:
    Jul 17, 2008
    Location:
    Maryland
    #3
    Did you try turning them off via the Language and Text preference pane?

    mt
     

Share This Page