Any way to cut the lag in screen mirroring over AirPlay?

Discussion in 'Apple TV and Home Theater' started by mellofello, May 18, 2015.

  1. mellofello macrumors 65816

    Joined:
    Feb 1, 2011
    #1
    I finally got around to hardwiring everything on my network with gigabit ethernet. It has made no difference with the lag I experience while casting my screen through airplay.

    Brand new MBP---->asus Ac router---->Apple TV

    All hard wired

    Anything that can be done to improve the judder?
     
  2. wongster macrumors regular

    Joined:
    Sep 27, 2014
    #2
    i have no issues or lag when i airplay or mirror. is your mac and apple tv updated to the latest firmware?
     
  3. mellofello thread starter macrumors 65816

    Joined:
    Feb 1, 2011
    #3
    All my stuff is up to date.

    You can watch video without it being choppy? Doing things like dragging windows is really laggy and unpleasant. I was hoping Ethernet will solve it.

    I'm going to order a 30 foot hdmi and just use that.
     
  4. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #4
    Watching video and mirroring screen are 2 different processing chores, despite both being named AirPlay.
    For mirroring, you could:
    1) reduce (match) desktop resolution to "appleTV" size (effectively 1920x1080 or 1280x720 depending on your aTV settings)
    2) hope for a faster real-time H.264 encoder in future Intel CPU-s
    [​IMG]
     
  5. wongster macrumors regular

    Joined:
    Sep 27, 2014
    #5
    no issue at all. i've had my atv and macbook pro since 2013. i'm tying this while having a video playing on my tv as a extended desktop. my atv is plugged in through ethernet and on wifi for my macbook pro.

    how new is your atv? when my friend got a new one, she would have lag also and i told her to get a new one and that fixed the issue.
     
  6. mellofello thread starter macrumors 65816

    Joined:
    Feb 1, 2011
    #6
    Apple TV is from 2012 or so. Not the end of the world, but watching popcorn time, and flash based videos is still a thing for me. I will just plug in the hdmi.
     
  7. richwoodrocket macrumors 68020

    richwoodrocket

    Joined:
    Apr 7, 2014
    Location:
    Hamburg, NY
    #7
    No issues here, and I use mine on wifi. I think the issue lies in your router.
     
  8. Abazigal macrumors 604

    Abazigal

    Joined:
    Jul 18, 2011
    Location:
    Singapore
    #8
    The quality of airplay mirroring has nothing to do with your internet speed. I can be mirroring content through a router with a 1mbps dongle sticking out of it and quality can still be excellent if the wifi signal is strong enough. Rather, your Apple TV is constantly decoding the compressed signals from your MBP through and from your router, and this doesn't require any internet connection at all.

    If you are just watching movies, you may want to try just airplaying the video rather than mirroring everything, which takes up way more resources.

    I use an asus router at home with my 2012 ATV and airplay quality has been pretty stable. All I can say is that the issue is either with your laptop or your router. See if you can trouble the issue by either using a different router (a cheap TP-link router can be had for $20?) or mirroring another device like your iPhone or iPad and see if there is any lag streaming videos and stuff.

    The next best solution would be to get a 2013 Apple TV. It uses peer-to-peer airplay, which means that it connects to your laptop directly via bluetooth and wifi, completely cutting out your router as the middleman. This should significantly improve performance.
     
  9. mellofello thread starter macrumors 65816

    Joined:
    Feb 1, 2011
    #9
    Are you implying that wifi is faster then gigabit Ethernet?
     
  10. SNKETR macrumors newbie

    Joined:
    Oct 22, 2014
    #10
    I have the same issue right now. It lags whether i mirror or extend the display with airplay. I had a standard ATT arris router/modem so i upgraded to the ASUS RT-AC87U. That didn't solve anything. ATV was bought in 2015 MBPr is 2012. Hopefully you can come up with something i can try.
     
  11. TruBleu macrumors regular

    Joined:
    Sep 20, 2014
    Location:
    The Hague, Netherlands
    #11
    I had the same issue. Switching off bluetooth on my Apple TV solved the problem.
     
  12. Jakeblu macrumors regular

    Joined:
    Feb 20, 2008
    Location:
    UK
    #12
    I can't believe this is a hardware issue, I used to mirror content all the time on my macbook air 11in 2012 i5 from XBMC but now on my retina macbook 2014 it is unwatchable. They must have done something with the OS for that to be the case all the other hardware is the same inc router, Apple TV etc.
     
  13. Sylviamarkova, Sep 3, 2015
    Last edited: Sep 3, 2015

    Sylviamarkova macrumors newbie

    Joined:
    Sep 3, 2015
    Location:
    California
    #13
    Hi everyone,
    As per now,am not facing any issue over Airplay.But sometimes the lagging problem occurs when i mirror my screen to a Projector. Try it in a corporate wifi rather than your home router,for testing purpose.
    You can also upgrade your mac/Apple TV to the latest Firmware.

    I often give presentations at diff. environments and for me it was very essential to
    have perfect device.You can have look on Prijector,hope it can solve all
    your issues. I am totally satisfied with this device. Have a good day
     
  14. firewood macrumors 604

    Joined:
    Jul 29, 2003
    Location:
    Silicon Valley
    #14
    Unless Apple completely changes their graphics and Airplay architecture, there will always be several frames (16 mS each) of lag. Apple's A-series chips use (double or triple) buffered tile-based deferred rendering GPUs. That means that there will be about 2 frames of lag both on the i-device and repeated on the ATV. Then Airplay uses compressed data transmissions. So that will add the time to compress and decompress images to the total lag. So you get the sum of 5 lags, initial deferred-render, compress, transmit, decompress, ATV deferred-render, display time. The compression and decompression appears to be done using custom accelerators inside the chips, but even if that and the transmission time are close to zero, the double or triple buffered GPUs on both the i-device and the ATV will add a few frame times of lag.
     
  15. 960design macrumors 68000

    Joined:
    Apr 17, 2012
    Location:
    Destin, FL
    #15
    Try taking your router out of the loop.
    MBPr > System Preferences > Displays > AirDisplay > Select your AppleTV
     
  16. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #16
    Are you sure, this has any effect? AFAIK, this selection will just pick a AirDisplay, but the traffic will still go over your wireless infrastructure. Which normally is your wireless access point, connected to your local LAN segment. You may call it router, if you like.
     
  17. robinou macrumors newbie

    robinou

    Joined:
    Jul 25, 2016
    #17
    This is the solution guys! Thanks a lot!
     
  18. mmmpires macrumors newbie

    Joined:
    Sep 1, 2016
    #18
    Solved here also with this solution! Thanks!
     
  19. eclipse01 macrumors 68020

    eclipse01

    Joined:
    May 16, 2011
    Location:
    Eau Claire, WI
    #19
    But turning off Bluetooth kills the remote...
     
  20. TheMark macrumors newbie

    Joined:
    Nov 14, 2016
    #20
    HOW do people turn off bluetooth on the Apple TV, I see no way of doing this anywhere?
     
  21. Max E Verde, Nov 14, 2016
    Last edited: Nov 14, 2016

    Max E Verde macrumors regular

    Max E Verde

    Joined:
    Jan 12, 2005
    Location:
    New Jersey
    #21
    I have had this issue with AirPlay Mirroring/Dual Display on all my Macs and iOS devices since I had a 2nd gen Apple TV, but very recently since I upgraded to macOS 10.12.1/iOS 10.1/tvOS 10.1 everything has been going perfectly. Been testing it extensively recently and hope it has been fixed for good.

    Edit: I honestly just realized that I had tvOS 10.1 beta on my Apple TV. I assumed that my developer account expiring would prevent it from installing, but I still had the profile on my Apple TV. SO it could be tvOS 10.1 that fixes this.
     
  22. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #22
    It's for the ATV 2 and 3.
    And you don't turn it off entirely, but it stops trying to connect to keyboards etc. That can help the 2.4 Ghz Wifi band speed especially.
     
  23. Sweener88 macrumors 6502

    Sweener88

    Joined:
    Apr 27, 2006
    Location:
    Im EVERYWHERE!
    #23
    THANK YOU! Man, I've been searching for a solution for a long time and gave up. This is a game changer for me haha thank you again for posting this! This should be pinned for easier find!
     
  24. TruBleu macrumors regular

    Joined:
    Sep 20, 2014
    Location:
    The Hague, Netherlands
    #24
    You're welcome. Yeah, I am surprised at how many people have found this useful and quite very glad because when I came across the problem, it wasn't easy for me to find this solution after trying several permutations and combinations myself.
     
  25. clauzzz203 macrumors regular

    Joined:
    Sep 18, 2012
    #25
    I fixed it by buying an AirPort Express (not joking)
     

Share This Page