Any way to disable dedicated GPU?

Discussion in 'MacBook Pro' started by PePe93, Feb 15, 2015.

  1. PePe93 macrumors newbie

    Joined:
    May 19, 2014
    #1
    As the title says, is there any way to disable dedicated GPU permanently? I'm the owner of rMBP 15 late 2013, unfortunately my brother persuaded me to buy a macbook with second GPU but I'm a bit disappointed about that decision. Nvidia card switches every time I use MatLab, iPhoto, Parallels, and many others despite the fact of using GfxCardStatus (because they appear on the dependencies list so they force dedicated GPU to turn on and there is nothing to do in this case). Ded GPU heats up my mac significantly, drains A LOT (really A LOT) of battery and it does not give me as much benefits as I thought. It sucks even in not demanding gaming. I don't expect graphic fireworks, especially on newer games, but it holds 60FPS only in old games.

    I wish I had bought much cheaper mac with Intel HD only because second GPU only irritates me. Every task I do and every game I play the Intel HD Pro would hold perfectly.

    Any ideas?
     
  2. ron1004 macrumors 6502

    ron1004

    Joined:
    Feb 6, 2010
    Location:
    Louisville, KY
    #2
  3. PePe93 thread starter macrumors newbie

    Joined:
    May 19, 2014
    #3
  4. ron1004 macrumors 6502

    ron1004

    Joined:
    Feb 6, 2010
    Location:
    Louisville, KY
    #4
    Yes I did, and obviously you aren't using gfxCardStatus carefully.
     
  5. PePe93 thread starter macrumors newbie

    Joined:
    May 19, 2014
    #5
    I do but sometimes it uses ded GPU despite GfxCardStatus. If I am wrong, please explain me what I am doing wrong.
     
  6. ron1004 macrumors 6502

    ron1004

    Joined:
    Feb 6, 2010
    Location:
    Louisville, KY
    #6
    If you select it to show what can seen in the attached image, then it cannot switch GPU.
     

    Attached Files:

  7. PePe93 thread starter macrumors newbie

    Joined:
    May 19, 2014
    #7
    [​IMG]


    As I said before, some apps prevent integrated GPU and force dedicated GPU. It is even written on gfx website.
     
  8. thekev macrumors 604

    thekev

    Joined:
    Aug 5, 2010
    #8
    It can be a little buggy, so sometimes you have to hit it a couple times. It has to be launched before any of these apps, meaning that if an app is dependent on that and you don't have it disabled prior to launching the app, you won't be able to disable it. The point here is that you can't disable hardware in use. If these applications were truly dependent on it, they wouldn't be able to run on a number of machines. I don't think you'll be affected much by disabling it either. Matlab supports CUDA libraries, but you're unlikely to ever use them. Parallels is the only one that might have an issue. I am curious why your brother persuaded you to pay for one with a second gpu. Apple's markups don't really justify it unless you're also paying for the additional storage. Prior to the current cycle, a ram upgrade on its own was also $200, so it could have made sense for more people.
     
  9. PePe93 thread starter macrumors newbie

    Joined:
    May 19, 2014
    #9
    I launch these apps after clicking "i" on gfx (I know that sometimes I need to click it more than once) but it forces ded GPU anyway.
     
  10. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #10
    You cannot fully disable the dGPU, you can switch it over to the iGPU for most apps. If you use an external monitor, you'll be on the dGPU, as with Windows if you run that OS. On bootup, you initially start off with the dGPU as well. So while you can limit the use of the dGPU you cannot fully disable it.
     
  11. b0fh666 macrumors 6502a

    b0fh666

    Joined:
    Oct 12, 2012
    Location:
    south
    #11
    you need to force integrated-only mode BEFORE opening an app that will switch to dedicated.

    simple as that.

    and mind you, no external display when on integrated mode.

    cheers.
     
  12. PePe93 thread starter macrumors newbie

    Joined:
    May 19, 2014
    #12
    Okay guys, I worked it out!

    After booting up my mac, I need to click a couple of times the "i" on gfxCardStatus (as maflyn said, bootup forces ded GPU) and then I need to go into system preferences > energy saving. Here, instead of "allow automatic switching" I can now choose between better performance and better battery life (obviously, these options appear because of gfxcardstatus) so I tick better battery life in both sections (when on battery and plugged into AC) without logging out! and finally I can run all apps without ded GPU.
     
  13. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #13
    gfxcardstatus has a weird bug in which you must select Integrated twice before it kicks into integrated-only mode.

    It's been flawless for me and I always force my rMBP into Iris Pro only when on battery.
     
  14. Freyqq macrumors 68040

    Joined:
    Dec 13, 2004
    #14
    Yep, works for me too on the same computer as the OP. It only works when the igpu is already on. If you try it when the dgpu is on, it will cause an error.
     
  15. PePe93 thread starter macrumors newbie

    Joined:
    May 19, 2014
    #15
    As I said, the key to make it work is that after clicking "i" on gfx you have to go to system preferences > energy saving and choose better battery life in both sections, AC plugged and on battery, without relogging.
     

Share This Page