Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Ron21

macrumors 6502a
Original poster
Sep 6, 2007
936
671
Seems the option is gone from System Preferences.

*Edit* possible with this command:

This works for me:
Code:
defaults -currentHost write -g AppleFontSmoothing -int 0

You have to log out (perhaps even reboot) to see the changes across the entire desktop.

I used to disable font smoothing in System Preferences → General prior to Big Sur, which is not possible anymore. Disabling it would add this defaults key to the settings. Upgrading to Big Sur removes that defaults key from the settings and thereby re-enables font smoothing, but you can still disable it.

Thanks to @KALLT !
 
Last edited:
  • Like
Reactions: Mac2727 and nmeed

cmhsam

macrumors 6502
Jul 14, 2008
448
70
?...Prefer the font in BS vs Catalina...when connected to non retina display seems to be much sharper vs Catalina (YMMV)
 
  • Like
Reactions: asv56kx3088

Ron21

macrumors 6502a
Original poster
Sep 6, 2007
936
671
I prefer the look of fonts in Catalina, they looked less 'bold', at least to my eye. In terms of overall sharpness, i'd say it's about the same on my 27" 4K monitor.

This was easily set in all previous versions of MacOS with the font smoothing option, not sure why they removed it.
 
Last edited:

Ron21

macrumors 6502a
Original poster
Sep 6, 2007
936
671
I think it's still possible via terminal using this command:

Code:
defaults write -g CGFontRenderingFontSmoothingDisabled -bool NO

Requires a restart.

Edit - NVM, I don't think this command changes anything in Big Sur.
 
Last edited:

nmeed

macrumors 6502a
Dec 1, 2014
512
183
This sucks.

Edit:

Have you guys looked at Google? It looks so bad. I hate font smoothing, man. I swear it's killing my eyes too.
 
Last edited:
  • Like
Reactions: Ron21

Ron21

macrumors 6502a
Original poster
Sep 6, 2007
936
671
This sucks.

Edit:

Have you guys looked at Google? It looks so bad. I hate font smoothing, man. I swear it's killing my eyes too.
I haven't found any solution so far, guess just have to get use to it...
 

nmeed

macrumors 6502a
Dec 1, 2014
512
183
I haven't found any solution so far, guess just have to get use to it...
Sure seems like it. I think it's a lot more complicated then them just enabling font smoothing. For instance, the text on this website seems to be fine as far as I can tell, almost as if it's disabled. Whereas when you visit Google, it's an absolute train wreck. From what I can gather, they absolutely gutted the code behind whatever used to do the font smoothing. They're doing something new now. Oh well.
 

Ron21

macrumors 6502a
Original poster
Sep 6, 2007
936
671
Sure seems like it. I think it's a lot more complicated then them just enabling font smoothing. For instance, the text on this website seems to be fine as far as I can tell, almost as if it's disabled. Whereas when you visit Google, it's an absolute train wreck. From what I can gather, they absolutely gutted the code behind whatever used to do the font smoothing. They're doing something new now. Oh well.

Yep, I noticed that as well, it's not all fonts across the system.

Just certain areas and certain sites that stand out to my eyes, as far as I can tell.
 
  • Like
Reactions: BigBlur

bryan85

macrumors regular
Jun 18, 2010
240
3
I've always disabled font smoothing. It makes fonts on my 38" monitor look like complete trash. I tried enabling HiDPI, which does seem to help however, this totally f*cks my windows VM(scaling up and down).

I'm pretty upset I don't have a way to disable this.
 
  • Like
Reactions: Ron21

Ron21

macrumors 6502a
Original poster
Sep 6, 2007
936
671
I've always disabled font smoothing. It makes fonts on my 38" monitor look like complete trash. I tried enabling HiDPI, which does seem to help however, this totally f*cks my windows VM(scaling up and down).

I'm pretty upset I don't have a way to disable this.
Yeah, I also did so as well, fonts just don't look great on external non-retina monitors with font smoothing. Even though I have a 27" 4k 163DPI monitor..
 

KALLT

macrumors 603
Sep 23, 2008
5,282
3,316
This works for me:
defaults -currentHost write -g AppleFontSmoothing -int 0

You have to log out (perhaps even reboot) to see the changes across the entire desktop.

I used to disable font smoothing in System Preferences → General prior to Big Sur, which is not possible anymore. Disabling it would add this defaults key to the settings. Upgrading to Big Sur removes that defaults key from the settings and thereby re-enables font smoothing, but you can still disable it.
 

Mythos99

macrumors regular
May 24, 2016
140
429
This works for me:
defaults -currentHost write -g AppleFontSmoothing -int 0

You have to log out (perhaps even reboot) to see the changes across the entire desktop.

I used to disable font smoothing in System Preferences → General prior to Big Sur, which is not possible anymore. Disabling it would add this defaults key to my settings. Upgrading to Big Sur removes that defaults key from your settings and thereby re-enables font smoothing, but you can still disable it.

Thank you for this! On my MBP 15 2015 everything looked a bit blurry, but after using this command, it's much better, everything is sharp again.
 

Ron21

macrumors 6502a
Original poster
Sep 6, 2007
936
671
This works for me:
defaults -currentHost write -g AppleFontSmoothing -int 0

You have to log out (perhaps even reboot) to see the changes across the entire desktop.

I used to disable font smoothing in System Preferences → General prior to Big Sur, which is not possible anymore. Disabling it would add this defaults key to the settings. Upgrading to Big Sur removes that defaults key from the settings and thereby re-enables font smoothing, but you can still disable it.

I think that did it, fonts looks better, thank you!
 

danius

macrumors newbie
Oct 13, 2016
7
4
Dublin, Ireland
This works for me:
defaults -currentHost write -g AppleFontSmoothing -int 0

You have to log out (perhaps even reboot) to see the changes across the entire desktop.

I used to disable font smoothing in System Preferences → General prior to Big Sur, which is not possible anymore. Disabling it would add this defaults key to the settings. Upgrading to Big Sur removes that defaults key from the settings and thereby re-enables font smoothing, but you can still disable it.
that worked for me too!
cheers
 

bryan85

macrumors regular
Jun 18, 2010
240
3
This works for me:
defaults -currentHost write -g AppleFontSmoothing -int 0

You have to log out (perhaps even reboot) to see the changes across the entire desktop.

I used to disable font smoothing in System Preferences → General prior to Big Sur, which is not possible anymore. Disabling it would add this defaults key to the settings. Upgrading to Big Sur removes that defaults key from the settings and thereby re-enables font smoothing, but you can still disable it.
AH! Perfect!! Thank you! I searched for hours last night trying to find this. Fonts are back to normal now.
 

nmeed

macrumors 6502a
Dec 1, 2014
512
183
This works for me:
defaults -currentHost write -g AppleFontSmoothing -int 0

You have to log out (perhaps even reboot) to see the changes across the entire desktop.

I used to disable font smoothing in System Preferences → General prior to Big Sur, which is not possible anymore. Disabling it would add this defaults key to the settings. Upgrading to Big Sur removes that defaults key from the settings and thereby re-enables font smoothing, but you can still disable it.
IT WORKS! OMG. Wow. How in the heck anyone could prefer font smoothing is beyond me. I'm very curious, how did you figure that out??? Thank you!
 
  • Like
Reactions: Ron21

cmhsam

macrumors 6502
Jul 14, 2008
448
70
so does this make fonts better for non retina displays? For example if I am using my Dell u3419w which is 3440x1440?
 

Ron21

macrumors 6502a
Original poster
Sep 6, 2007
936
671
so does this make fonts better for non retina displays? For example if I am using my Dell u3419w which is 3440x1440?
Yes, but it depends on what you prefer. I don't like how font smoothing looks on non-retina displays and have always disabled that option.
 

k4assasinbro

macrumors newbie
Sep 21, 2017
5
0
This works for me:
defaults -currentHost write -g AppleFontSmoothing -int 0

You have to log out (perhaps even reboot) to see the changes across the entire desktop.

I used to disable font smoothing in System Preferences → General prior to Big Sur, which is not possible anymore. Disabling it would add this defaults key to the settings. Upgrading to Big Sur removes that defaults key from the settings and thereby re-enables font smoothing, but you can still disable it.
Thank you so much!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.