Any way to disable Intel HD? / igdkmd64.sys

Discussion in 'Windows, Linux & Others on the Mac' started by mrwigster, Apr 5, 2014.

  1. mrwigster macrumors newbie

    Joined:
    Dec 9, 2013
    #1
    So I've installed Windows 8.1 to an external harddrive (USB 3).
    Started by doing bootcamp method on my Macbook Pro Retina (256gb), then used winclone [app] to transfer the image directly to a external harddrive so I could then claim back the 20gb bootcamp partition.

    All of this above is fine, and the Windows side boots up fine in safe mode. However in normal mode windows will BSOD throwing an error about igdkmd64.sys.

    I think it's relating to Intel HD driver kicking in, as in device manager I see it suddenly appear everytime (in display category) just before the BSOD happens. However, the problem is I can't see the Intel HD anywhere in Safe Mode to disable it?

    Any ideas how to stop this happening, completely unusable atm?

    Help is appreciated :).
     
  2. Quackers, Apr 6, 2014
    Last edited: Apr 7, 2014

    Quackers macrumors 6502a

    Joined:
    Sep 18, 2013
    Location:
    Manchester, UK
    #2
    In safe mode try moving the igdkmd64.sys file from Windows/System32/drivers to your documents folder (or delete it entirely). It should then fire up the Microsoft Basic Display driver (though it may be necessary to uninstall the Intel HD device first in Device Manager).

    Then change your Windows Update settings to stop Windows updating automatically. Set it so it just notifies you of available updates and then you'll get to pick which updates are installed. Obviously don't install any Intel graphics drivers from there.

    I'm not sure how good an idea it is to clone from Bootcamp to a USB drive. This could cause problems. I'm not sure whether it's actually permitted.
     

Share This Page