any way to salvage this external hd?

Discussion in 'Mac Basics and Help' started by ayres, Aug 8, 2014.

  1. ayres macrumors regular

    Joined:
    Sep 27, 2010
    #1
    hi all, plugged in my external to my mba a few days ago... it mounted but then i couldn't access it. with each successive try, it didn't appear in finder/desktop. but it appears in disk utility. here's what i got:

    [​IMG]

    while i have most of the content saved elsewhere, i'd still like to get into it one more time. would software like diskwarrior or a trip to the apple store be of any use? cheers
     
  2. smithrh macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #2
    You can certainly try DiskWarrior, I've had it work some miracles and also not be able to help too much, so keep your expectations in check.

    My general rule of thumb is to totally discard a disk once it has run into a problem like this one. They're cheap these days... After running DW, take your frustrations out on it with a hammer.

    Apple store will likely not be able to help much.
     
  3. cube macrumors G5

    Joined:
    May 10, 2004
    #4
    You must not try with DiskUtility. You should go to DiskWarrior first.
     
  4. ayres thread starter macrumors regular

    Joined:
    Sep 27, 2010
    #5
    thanks all, i started diskwarrior this morning in an attempt to salvage any data possible.

    i started the rebuilding process and have left my computer alone. but in the past four hours, it's been stuck at step 5 (locating directory data) and beachballing.

    so to anyone with diskwarrior experience, after this long, shouldn't the rebuilding be completed?

    [​IMG]

    cheers
     
  5. ayres thread starter macrumors regular

    Joined:
    Sep 27, 2010
  6. Elbert C macrumors 6502

    Joined:
    Mar 23, 2008
    Location:
    AK, USA
    #7
    I've had a Disk Utility error that couldn't be repaired that DiskWarrior had no problem in repairing. It didn't take very long to rebuild the directory that time. I would let DW keep running and contact DW support to see what they'd have to say about this.
     
  7. ayres thread starter macrumors regular

    Joined:
    Sep 27, 2010
    #8
    K, thanks... I'll give it another try
     
  8. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #9
    If DiskWarrior won't work for you, I'll offer another solution.
    Take the advice that follows at your own risk, but this process worked for me when nothing else would.

    You'll need data recovery software such as
    - DataRescue3
    - Disk Drill
    - Stellar Phoenix Data Recovery

    Note about how these apps work:
    They all work the same way, that is:
    1. You download the app
    2. You "aim it at" your problem drive (usually using "Deep Scan" or something like that)
    3. The app will take some time scanning and scavenging to check each sector on the drive
    4. The app will present you with a list of files, but WILL ONLY LET YOU RECOVER ONE FILE (for test purposes)
    5. If at this point it looks like recovery is possible, you pay the registration, enter a code, and then the app goes to work on your drive and recovers the data.

    Also worth noting is that you WILL lose most or all folder hierarchies and file names. This is "par for the course" with data recovery apps. The consolation is that you get the data back.

    Try the data recovery app on the drive first, "as is".
    It may do the trick for you. It may not.

    IF the above isn't working, you can try this:
    - RE-initialize the problem drive into one partition (yes, you read that correctly)
    - Now, run the data recovery app on the newly-reinitialized drive (it may actually "find" data that couldn't be seen before).

    Again, the above process worked for me when nothing else would.

    Hope this helps....
     
  9. ayres thread starter macrumors regular

    Joined:
    Sep 27, 2010
    #10
    many thanks... i've been busy all week, so i'm just now looking at what you've outlined below... i'll update soon!

     

Share This Page