Anybody fixed 802.11n issues in 10.5.2?

Discussion in 'macOS' started by Michael CM1, Mar 10, 2008.

  1. Michael CM1 macrumors 603

    Joined:
    Feb 4, 2008
    #1
    I have seen this discussed before, so I wanted to check on a update and see if anybody has successfully fixed the major bug with 10.5.2 and 802.11n. Ever since the upgrade, I have been pretty much unable to play any video streaming from external HDDs connected to my AEBS. This was no problem before and works fine with an older iMac G5 with 802.11g and one of the new AppleTVs. It also works fine when I connect this MBP to the AEBS with an Ethernet cable, but not from the same two-foot distance using wireless.

    So anybody got a fix? I keep checking for Mac OS updates and they dad-burn don't show up every day. Until there's a fix, I shall be known as "Bangs Head on a Desk." :eek:
     
  2. Mlobo01 macrumors 6502

    Joined:
    Jan 23, 2003
    Location:
    Weehawken New Jersey
    #2
    check...

    if you check your router and its capable or changing the Preamble rate then switch it to "short" I read that its better for streaming and gaming elements. The long preamble is said to work better with legacy devices.
     
  3. Michael CM1 thread starter macrumors 603

    Joined:
    Feb 4, 2008
    #3
    Nope, don't see that (but I think I remember it from the LinkSys days). The options I have are:

    Radio Mode (changed it to 802.11n only, no improvement)
    Channel (automatic)
    Security (WPA2 Personal)
    Password (how dumb do you people think I am???? :))

    Multicast Rate (6Mbps)
    Transmit Power (100%)
    WPA Group Key Timeout (1 hour)
     
  4. Mlobo01 macrumors 6502

    Joined:
    Jan 23, 2003
    Location:
    Weehawken New Jersey
    #4
    recently...

    After the 10.5.2 update I was having connection issues after sleep/restart, I downloaded iStumbler to see the neighboring networks and sure enough all networks around my area where using channel 6, (the idea is that multiple networks using the same channel produces drop-outs and connectivity problems) so I switched to channel 8 and it seem promising except that my Pbook would not connect, after a couple of tries I landed on channel 2, it was stable for both my mini and powerbook, now Im not saying channel 2 is the best, but for some reason the Automatic channel feature does not function well in Leopard, it did well in Tiger and in 10.5.1 but not in 10.5.2. I suggest trying various channels, also in Locations (network>locations) the Automatic Location is very unstable, I made a second location and deleted the Automatic location, anything named "automatic" goes awry and has trouble connecting or remembering networks, another thing is the issues with 802.11N for most I read that it is still very unstable and prone to glitches. so I set mine to "various" or simply G. and its fast enough.
    read the following for better info:
    http://www.macosxhints.com/article.php?story=20080305053403936
    http://www.macfixit.com/index.php
     
  5. Mlobo01 macrumors 6502

    Joined:
    Jan 23, 2003
    Location:
    Weehawken New Jersey
    #5
    Also...

    I would try also disabling the WPA2 (just for troubleshooting purposes) turn off the firewall, then try it with WPA, etc, I had an issue with my mini not connecting to my Pbook, upon disabling the pbook's FW it had no trouble connecting, some bug regarding the Firewall and the keychain perhaps?
     
  6. Michael CM1 thread starter macrumors 603

    Joined:
    Feb 4, 2008
    #6
    The startup item I got from the first link solved it! It's kinda crappy how some random guy knows how to fix this problem yet Apple couldn't have included a patch by now for something so major. But it's fixed for now. GO TEAM!
     

Share This Page