Anybody having Netflix buffering issues on Apple TV

Discussion in 'Apple TV and Home Theater' started by saintforlife, Dec 26, 2011.

  1. saintforlife macrumors 65816

    Feb 25, 2011
    I recently updated to the latest firmware in my Apple TV2. But ever since the update, I'm having trouble streaming Netflix. The video stops every 2-3 mins and starts buffering. It is very annoying. Resetting the modem and router did not work. Anybody have this issue with Netflix? Is this related to the latest ATV2 firmware update? I'm on wifi btw. Always have been. Also the ATV2 is only about 2 feet away from the Apple Extreme router. Any tips to overcome this issue will be appreciated.
  2. DustinT macrumors 68000


    Feb 26, 2011
  3. This Guy macrumors newbie

    Dec 29, 2011
    Toronto, Ontario
    Same Problem

    I just bought ATV and the Netflix has not worked from the start... Buffering every other minute. Everything else works fine including streaming from iTunes. My ISP (Rogers) has told me that I have well over the required bandwidth to download HD content, but Netflix tells me that they can only see a 0.5mb download speed. Something is getting lost between my modem and ATV. Having the ethernet cable directly in doesn't resolve the problem either. I spent well over an hour with Apple Care last night and the guy there is stumped. He's had to escalate the problem, however I probably won't hear back from them for around a week due to the high volume of escalated cases over the holiday.

    Anyone resolve this issue? I'll update you when I hear back from Apple.
  4. ixthys macrumors newbie

    Oct 29, 2011
    A friend of mine had a buffering issue with his wireless setup of apple TV and Netflix.

    We went to my house and logged into his Netflix account via my apple TV, which is hard-wired (ethernet), and it worked just fine.

    The ultimate test of course would be to run an ethernet cable between his apple TV and computer, or try a repeater or booster, but haven't tried these solutions yet.
  5. Idgit macrumors 6502


    Mar 14, 2004
    Are you using OpenDNS or Google DNS servers on your router? If so, try disabling and just using your ISP's DNS servers.
  6. pwalsh1051 macrumors newbie

    Jul 28, 2011
    johnstown pa
    im also having the same problem with buffering and some of the stuff in my instant choices says 'netflix is not available at this time'. most of the stuff works but a few do this. any ideas?
  7. penguy macrumors 6502

    Feb 20, 2007
    I know this won't resolve your problem, but over wifi I was having similar issues...since hardwiring, no problems...

    from my computer to the ATV2, it will load the entire movie in a few seconds (white bar filled)...from netflix, there is no hesitation...though I don't see it actually load the entire movie.
  8. dezicartel macrumors newbie

    Jan 4, 2012
    i did the recent firmware update too, and it screwed up my netflix streaming....its definitely not a bandwith issue, because I can rent movies from itunes and stream HD no problem...the recent update screwed something up with netflix..and it sucks...anyone know how to revert back to the firmware before the recent update? thats the only fix at this point
  9. fpnc macrumors 68000

    Oct 30, 2002
    San Diego, CA
    I have the most recent firmware in my ATV2 and even over a 5Mbps DSL connection I have NO problems with Netflix. However, I'm using wired ethernet which runs through a switch to several other devices at my TV (haven't tried WiFi).
  10. pfarfour macrumors newbie

    Aug 31, 2010
    I'm having a terrible time with buffering on netflixs. Some shows work great others buffer about every 30 secs. I have always used wireless with the atv2 and have not seen any problems. Tinkered with my wifi last night but it didn't help at all. All my other devices are solid and no buffering on Netflix on computer, iPads, or iPhones. All diagnostics show wifi to be strong and healthy.

    Problems seem to have started with the recent firmware update to atv2.

  11. Russinator macrumors member

    Nov 4, 2011
    I had a terrible time with buffering on netflix, therefore, I quit netflex. Life's too short to put up with things like that.
  12. pdburstein macrumors newbie

    Jan 5, 2012
    Netflix woes

    I had the same issue. Suddenly started working! Did a soft reboot but not sure if that was the fix ad I had done it before. Tried several movies fro Netflix and it seems to have healed itself!
  13. WoodNUFC macrumors 6502a


    Apr 30, 2009
    A Library
    Last night I watched a Discovery channel show ~45 minutes long without buffering. Watched 2 episodes of Lost and each buffered every 20 seconds for about 5 minutes, would work fine for another 10, then start the buffering game again. Netflix was working perfectly up until last week. I'm still on 4.3.
  14. Batt macrumors 65816


    Dec 17, 2007
    Syracuse, NY
    I have two ATV2s, one ethernet and one wi-fi. After the last update, the wi-fi one did the "Unavailable" bit enough to make me crazy. I did a reset and everything returned to normal.
  15. charlien macrumors 6502

    Jul 3, 2006
    I've had the issue since Christmas. I assumed lots of people were using their new Netflix enabled toys.
  16. metfan macrumors newbie

    Mar 31, 2010
    Count me as one who can't currently use Netflix with my ATV 2. I'm wired via Ethernet and I buffer every minute or two when watching Netflix. My similarly connected Boxee Box and Xbox do not have this problem with Netflix.
  17. Jony Mac macrumors 6502

    Jony Mac

    Oct 27, 2010
    Pittsburgh, PA
    I use my AppleTV 2 on ethernet as well. Mine will buffer every now and then. It seems to happen on those days we watch a bunch of movies from Netflix right after another. My only fix is to unplug the power from AppleTV wait a few seconds and power it back on.
  18. ladymacintosh macrumors member


    Jan 25, 2011
    I have been having the same problem. My ATV2 on WIFI has been buffering a lot in Netflix and saying unavailable sometimes since the update and unplugging it/replugging doesn't work. I have tried resetting my modem, rebooting my router and nothing helps. I have a Roku2 XS and it works just fine using Netflix. It is also using WIFI. For now, I am not even bothering with the ATV2 and just using the Roku2 XS- since it actually works.

    Fix your ****, Apple!
  19. pfarfour macrumors newbie

    Aug 31, 2010
  20. blacktape242 macrumors 65816


    Dec 17, 2010
    Sacramento, CA
    Same thing is going on with my ATV3..... and I have a Roku as well which works great! Agreed, fix this apple!!!!!

Share This Page