Anybody used this Firewire/PCIe card?

Discussion in 'Mac Pro' started by rockinrocker, Sep 9, 2013.

  1. rockinrocker macrumors 65816

    rockinrocker

    Joined:
    Aug 21, 2006
    #1
  2. Studio K macrumors 6502

    Studio K

    Joined:
    Feb 17, 2013
    Location:
    United States
    #2
    There was no mention of OS X compatability/support for this card on the Newegg listing.

    Best to make sure it works with OS X.

    This card is only FW 400. You don't need 800?
     
  3. rockinrocker thread starter macrumors 65816

    rockinrocker

    Joined:
    Aug 21, 2006
    #3
    No, my interface is 400.

    It doesn't mention it, but there was a reviewer that said he used it with an '09.

    Just wondering if anybody else has tried it...
     
  4. Demigod Mac macrumors 6502a

    Joined:
    Apr 25, 2008
    #4
    I'd assume it would be plug 'n play if a reviewer already had success using it in a Mac Pro. Probably uses generic drivers.

    Newegg has a pretty good return policy, so there's low risk if it ends up not working.
     
  5. rockinrocker thread starter macrumors 65816

    rockinrocker

    Joined:
    Aug 21, 2006
    #5
    That's kind of what I was figuring.
     
  6. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #6
    They used to have a good return policy, but the new owners now charge a restocking fee.
     
  7. rockinrocker thread starter macrumors 65816

    rockinrocker

    Joined:
    Aug 21, 2006
    #7
    Well the card works fine.

    I went ahead and connected the molex power cable while I had the system out and open, so I don't know if it's required or not. I got a splitter and an extension- the fit was a little tight coming out of the drive bays but worked fine.

    So far so good.
     

Share This Page