Anybody's Internet Stop Working After Sleep?

Discussion in 'MacBook Air' started by astrorider, Dec 19, 2010.

  1. astrorider macrumors 6502

    Joined:
    Sep 25, 2008
    #1
    I'm having this odd problem where maybe 1/10 times I put my 2010 Macbook Air 13" to sleep I can't access the internet upon wake up. The Airport menu item continues to be full bars, and as far as I can tell everything looks normal inside the Network Preferences (I have an IP address, etc.).

    My girlfriend's laptop, sitting right next to me, continues to work so it's not the internet.

    I've tried clicking "renew dhcp" in Network Prefs, turning Airport off and back on, zapping PRAM, and repairing permissions. The only fix I've found is rebooting the computer.

    Anyone have this happening to them or have any other ideas of what I could try?
     
  2. gdeputy macrumors 6502a

    gdeputy

    Joined:
    Jul 23, 2008
    Location:
    New York
    #2
    yeah pretty sure i'm having a similar problem. every now and then when I wake my safari says no internet. takes like 5 seconds for it to kick on.
     
  3. astrorider thread starter macrumors 6502

    Joined:
    Sep 25, 2008
    #3
    I'd love it if it came back after 5 sec. Mine never picks up the internet connection again as far as I can tell. After 1-2 minutes I just reboot. I'm wondering if it has to do with the new low power sleep that the Air enters into, but I'm not sure how to disable that feature.
     
  4. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #4
    Did you try rebooting the modem and/or the router?
     
  5. astrorider thread starter macrumors 6502

    Joined:
    Sep 25, 2008
    #5
    No, but the other wireless machines on the network continue to have internet even when my Air wakes up and doesn't have access. If it would help to diagnose the problem I'd be happy to try next time it happens, but it seems to be a problem unique to my Air and not to the network as far as I can tell.
     
  6. det2004 macrumors 6502

    Joined:
    Aug 20, 2007
    #6
    I've had this happen a couple of times. What I did to reconnect to my wifi was disable Airport on my Air and then reenable it and it picked up my wireless network right away. It was kind of annoying but not really a big deal to me since I didn't have to reboot or anything.
     
  7. astrorider thread starter macrumors 6502

    Joined:
    Sep 25, 2008
    #7
    Yeah that wouldn't be too bad, but it doesn't seem to work for me when it happens on my Air. Even after turning Airport off and back on the Air still can't access the internet.
     
  8. JohnG84 macrumors newbie

    Joined:
    Jan 15, 2010
    #8
    I'm having the same problem. When I try to connect, I get a "connection timeout" error. It can be solved by restarting the router but it's still very annoying.
     
  9. double329 macrumors 6502

    Joined:
    Sep 10, 2008
    #9
    I don't have problem(at least for now). My MBA went to sleep and came back on and got online almost instantly. I am using D-Link 825 router.
     
  10. astrorider thread starter macrumors 6502

    Joined:
    Sep 25, 2008
    #10
    Yeah, 9/10 times it works fine for me too. I think it happens when I've been away from the computer for a long time and the Air goes into low power mode (deep sleep, or whatever it's called). Not necessarily every time it deep sleeps, but definitely more frequently. For now, I've turned off safe sleep (hibernatemode=0) and I'll see if I still get the problem over the next couple days.
     

Share This Page