Anyone else getting charged cell data when on wifi?

Discussion in 'iOS 8' started by dictoresno, Oct 24, 2014.

  1. dictoresno, Oct 24, 2014
    Last edited: Oct 24, 2014

    dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #1
    I've noticed recently that my cell data usage has increased a lot. I just checked the verizon breakdown on their website and it shows me using large amounts of data while I'm on wifi at home. I know there are tons of other threads regarding wifi and iOS 8, but i briefly browsed them and they appear to be just about slow wifi.

    Can anyone else check their usage and let me know if they are getting pegged for cellular data while they are on wifi?? This is BS! Or is it that the data usage timestamps are off and not actually the time of use?
     
  2. macenied macrumors 6502a

    macenied

    Joined:
    Aug 20, 2014
    #2
    Turn mobile data off when you are at home to verify the problem. If you have WIFI issues the phone might revert back to mobile data, which would explain why you get charged for it.
     
  3. RodThePlod macrumors 6502a

    RodThePlod

    Joined:
    Sep 7, 2005
    Location:
    London
    #3
    I'm also seeing this issue after upgrading to iOS 8. In fact, it first started happening with iOS 8.02 where, when I'm at home and on a good Wi-Fi network, the Wi-Fi connection on my 5S drops and the phone reverts back to a 3G connection.

    If you don't keep an eye on the status bar, you don't see it happening - and if you happen to be streaming YouTube video or the like, then you'll be doing all that over cellular. (As I've never had this problem before, it was easy to miss). I then have to go into settings and toggle Wi-Fi off and on again for it to reconnect.

    Now I'm now paranoid and am always checking the status bar when surfing at home.

    This never used to happen before - it's an issue that has started happening for me after upgrading to 8.02. As a result, my data usage has significantly increased this month.

    I thought Apple would fix this problem in 8.1, but unfortunately I still see it :(

    RTP.
     
  4. macenied macrumors 6502a

    macenied

    Joined:
    Aug 20, 2014
    #4
    For some people turning off Settings -> Privacy -> Location Services -> System Services ->WiFi Networking solves iOS 8.n WIFI problems.
     
  5. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #5
    known issue going back to iOS 6 for some people.
     
  6. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #6
    Yea I remember old threads from years ago with people having the same issue but it wasn't present for me on all iterations of iOS 7. Just started with iOS 8. Gonna beg verizon to see if there's any way they can get me on a better plan for nothing.
     
  7. melapple macrumors regular

    Joined:
    Aug 29, 2013
    #7
    If it's any consolation I'm having this issue where ios 8.1 is using cellular data even while on wifi. The funny thing is thay the cellular data counter would show no data usage increase but the carrier app shows data usage as if there is a data leak while on wifi.
    I'm on iphone 5 and have never experienced anything like this with all previous iOS versions. This really sucks big time as i have no intention to reset my phone and a new update doesn't seem on the horizon
     
  8. xraydoc macrumors 604

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #8
    Try a network settings reset. Doesn't wipe data from the phone, though you will need to reenter wifi passwords.
     
  9. melapple macrumors regular

    Joined:
    Aug 29, 2013
  10. Jeff Flowerday macrumors regular

    Joined:
    Aug 23, 2007
    Location:
    Calgary, AB
    #10
    Unless something was changed in iOS 8, "Always on WIFI" isn't an option on iOS like it is on Windows Phone or Android.

    iOS will drop the wifi connection when the device goes into sleep mode and start using cell data automatically. It will quickly reconnect to wifi when you interact with your phone again.

    Only way to force it to stay on wifi is to turn cell data off.

    So depending on how many notifications, emails etc you receive when the device is in sleep mode, they will come in on cellular data not wifi.
     
  11. melapple macrumors regular

    Joined:
    Aug 29, 2013
    #11
    I don't believe this is linked to how iOS 8 is suposed to work as up until 10 days ago i had no issue whatsoever even though I've installed iOS 8 the day it came out
     
  12. andyw715 macrumors 6502a

    Joined:
    Oct 25, 2013
    #12
    How much data are you talking about? A couple meg/or 100's?
     
  13. Jeff Flowerday macrumors regular

    Joined:
    Aug 23, 2007
    Location:
    Calgary, AB
    #13
    What app or change did you make 10 days ago that started using more cell data when the phone is asleep? It's not going to use cell data when the phone is awake and on wifi.
     
  14. melapple macrumors regular

    Joined:
    Aug 29, 2013
    #14
    I'm talking several MBs (5, 10, 20 at a time). I did not change any setting and no app that i downloaded has been active in the background if that's what you're asking. Also, I don't know if this happens while the phone is in standby or when I'm using it. All I know is that it's happening
     
  15. melapple macrumors regular

    Joined:
    Aug 29, 2013
    #15
    I've noticed that a lot of usage is under itunes account and software updates despite the fact that cellular data is disabled for music apps books and updates like it's always been. This time apple really screwed up
     
  16. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #16
    8.1 has improved my wifi greatly. But even then, I noticed my iPhone 6 dropped it's wifi-N connection during the night, but did connect to the G band. Was happening much more pre 8.1, and then, might not grab the G connection. No such issues on my iPad 3.

    Otherwise, not noticing any extra cellular usage, usual culprits of streaming audio, mail, Safari. GPS ("Time & Location" under "System") seems to be a bit of a hog, so, maybe disable GPS when at home.

    One thing to maybe help out: if your wifi is setup to not broadcast the SSID, reconfigure to broadcast the SSID. Lots of posts on the interwebs re: not broadcasting SSID isn't really protecting you, and can be a security hole.

    Back to point, with SSID broadcasting, I've noticed that my phone will connect up to wifi much quicker, so, can possibly have those moments when phone is sleeping and on cellular, when it wakes to do something in the background, better chance of getting onto wifi before all the phone's chores are done.
     

Share This Page