Anyone else have trouble typing "Theyre"? Always comes out as "Theyrr"?

Discussion in 'iPod touch' started by TheSpaz, Mar 10, 2008.

  1. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #1
    No matter what I do, I can't type the word "Theyre" on my iPod touch no matter how slowly I type it and how accurately I type it... it always comes out as "Theyrr". Of course the spell correction fixes it but, isn't that just weird? This happens on my girlfriend's iPod too.
     
  2. quicklook2 macrumors 6502

    quicklook2

    Joined:
    Dec 23, 2007
    Location:
    lakewood, ohio
    #2
    neither of those spellings, theyre or theyrr, are a word in the english language.
     
  3. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #3
    I just let the iPod put the apostrophe in the word "they're" so I don't bother putting it in. That DOESN'T explain the fact that you can't hit the e key after the r key.
     
  4. MacBoobsPro macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #4
    It seems the iPod learns from what you type for each session. After reading your post I tried typing 'They're' and it worked first time. Then I deleted it and tried again. This time it said 'Theyrr' and I couldn't no matter what I did press 'e' it was either 'w' or 'r'. I think because you erased 'They're' at some point in a session i.e. a single text message it assumes you dont want to type 'They're' and offers an alternative. I found if you hit the home button and start a fresh message and type 'They're' it will infact type 'They're' unless you then erase it and try typing it again. If you do it then offers the alternative 'Theyrr.'

    It is strange why the letter 'e' is no longer available though.

    I'm on the fence whether this is smart or dumb :D
     
  5. davidy macrumors 6502

    davidy

    Joined:
    Jan 28, 2008
    #5
    I didnt quite understand what you were experiencing so I tried it and you're right, it doubles the r instead of letting you type "re". You already know the solution, but others might not - just let it enter theyrr and when you hit the space it changes to they're. Either that or enter the apostophe yourself. I tried other words ending in "re" and the problem doesn't duplicate.

    This could be a security feature of the OS. Frequently programmers will enter a non-fatal code glitch to secure against those copying the code. If it appears that someone has copied the code, then this glitch will show up in the copied product. It's similar to mailing lilst copyrighters entering a fake name to protect against copiers, or map makers entering a non-existant road for the same reason.

    This glitch brings up the fact that when you're entering text and the touch enters a suggested prefill, if you accept what the touch is suggesting, just hit the space key and the suggested word is entered and you're ready to continue entering.

    It seems that many people today wouldn't encounter this particular anomoly since they incorrectly use "there" or "their" instead of "they're".
     
  6. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #6
    I was just wondering if it was on purpose or if it was a bug, but it seems to be both... weird. It's not a big deal though but, my girlfriend is really OCD about typing things correctly and so the spell corrector thing freaks her out because she's trying to spell correctly on her own but, it keeps popping up and she wants to hit backspace and delete it but, she has to fight her urges and it makes her kind of well... cranky.
     

Share This Page