anyone else have wifi calling issues?

Discussion in 'iOS 8' started by apple.snapple, Feb 4, 2015.

  1. apple.snapple macrumors regular

    Jun 3, 2014
    Phone: iPhone 6+, 16GB, Gold, bought midnight day 1, was bought locked to AT&T but paid off and carrier unlocked without a problem. iOS 8.1.3.
    Network: Apple Airport Extreme 802.11AC, bought just a month ago. Up to date firmware.

    Now I'm on Tmobile family plan, 2 lines unlimited "Simple Choice". Everything is going swimmingly except wifi calling...
    As soon as I got home, I factory reset the phone so I could start clean. I updated the carrier settings to 18.1. I enabled "Allow wifi calling" and updated my e911 settings without issue. I then saw "T-Mobile Wifi" at the top of the screen, which indicates I can make calls over wifi. However, putting the phone to sleep for more than a couple minutes seems to lose the "wifi" tag and I am no longer able to make wifi calls. Resetting the phone will regan the wifi tag, but putting the phone to sleep for a couple of minutes will lose the wifi calling feature.

    I've taken the issue to T-Mobile and they ended up sending me their T-Mobile "CellSpot" router, which is just a rebranded ASUS 802.11AC router. It didn't help. I called T-Mobile again and they said "it's an Apple problem, you'll just have to wait until they fix it with an update".

    So, does anyone here have the same issue that I'm having with wifi calling?
  2. CEmajr macrumors 601

    Dec 18, 2012
    Charlotte, NC
    I think it has to do with how the iPhone loses the Wi-Fi connection while it's asleep. I doubt Apple will change it since that's how it's always been with the iPhone.
  3. IrishVixen macrumors 68020


    Jun 20, 2010
    Well, it's definitely not "normal". I can leave my phone in sleep mode for hours, and as soon as I wake it back up, it says "T-Mobile Wifi" for the carrier. Really, it only drops back to cellular voice calling when it can't find a trusted wifi network. When I take it down to the local hospital, for example, it automatically switches to using wifi calling again as soon as I log in, and holds that setting until I leave the building again. Same at Starbucks. It's worked fine with a number of different routers.

    I'd probably do a wipe and setup as new, not from backup. If that doesn't fix the problem, it may be hardware, and I'd take it down to the Genius Bar and have them check it out. (But do the restore first, because frankly they're almost certain to require it before they'll consider swapping out the device.)

    iPhone 6, Apple Time Capsule (previous generation), on 8.1.2.
  4. xraydoc macrumors 604


    Oct 9, 2005
    OP, try resetting Network Settings and let us know if that helps.

Share This Page