iPhone Anyone else having major Auxo issues?

Discussion in 'Jailbreaks and iOS Hacks' started by chrf097, Feb 18, 2013.

  1. chrf097 macrumors 68040

    chrf097

    Joined:
    Dec 16, 2011
    #1
    I really REALLY love Auxo, but it doesn't love me.

    I've started to get daily crashes using it. Sometimes up to 3 times in a day. All my other tweaks work fine. I have installed:

    iFile
    PasswordPilot
    Nitrous
    Chromizer
    NoNewsIsGoodNews
    BrowserChanger
    iCleaner
    Winterboard
    PandoraSkips
    ResetAllKiller
    SwipeSelection
    CrashReporter

    Is there any known issue with Auxo and one of these tweaks. I really don't wanna remove Auxo as i've grown so used to it already.

    Also, in case it helps, i picked out the part from crash reporter showing the crash:
    Code:
    Hardware Model:      iPhone4,1
    Process:         SpringBoard [2128]
    Path:            /System/Library/CoreServices/SpringBoard.app/SpringBoard
    Identifier:      SpringBoard
    Version:         ??? (???)
    Code Type:       ARM (Native)
    Parent Process:  launchd [1]
    
    Date/Time:       2013-02-18 20:37:01.249 -0500
    OS Version:      iOS 6.1 (10B142)
    Report Version:  104
    
    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0xf1bbb001
    Crashed Thread:  0
    
    Thread 0 name:  Dispatch queue: com.apple.main-thread
    Thread 0 Crashed:
    0   libobjc.A.dylib               	0x390375b6 0x39034000 + 13750
    1   AuxoSwitcher.dylib            	0x0041823a 0x405000 + 78394
    2   AuxoSwitcher.dylib            	0x00418780 0x405000 + 79744
    3   AuxoSwitcher.dylib            	0x004068f0 0x405000 + 6384
    4   SpringBoard                   	0x000f0b1e 0xdb000 + 88862
    5   SpringBoard                   	0x000f10c8 0xdb000 + 90312
    6   SpringBoard                   	0x002788fc 0xdb000 + 1693948
    7   SpringBoard                   	0x00278478 0xdb000 + 1692792
    8   SpringBoard                   	0x000f1070 0xdb000 + 90224
    9   SpringBoard                   	0x000f01a2 0xdb000 + 86434
    10  SpringBoard                   	0x000f0272 0xdb000 + 86642
    11  SpringBoard                   	0x000f0294 0xdb000 + 86676
    12  SpringBoard                   	0x000eff14 0xdb000 + 85780
    13  SpringBoard                   	0x000eff30 0xdb000 + 85808
    14  SpringBoard                   	0x000e2b94 0xdb000 + 31636
    15  SpringBoard                   	0x000e39c4 0xdb000 + 35268
    16  SBAXServer                    	0x0521a606 0x5210000 + 42502
    17  UIKit                         	0x33127d54 0x33124000 + 15700
    18  UIKit                         	0x331276c8 0x33124000 + 14024
    19  UIKit                         	0x33127116 0x33124000 + 12566
    20  GraphicsServices              	0x34e3d5a0 0x34e37000 + 26016
    21  GraphicsServices              	0x34e3d1ce 0x34e37000 + 25038
    22  CoreFoundation                	0x312f4170 0x3125d000 + 618864
    23  CoreFoundation                	0x312f4112 0x3125d000 + 618770
    24  CoreFoundation                	0x312f2f94 0x3125d000 + 614292
    25  CoreFoundation                	0x31265eb8 0x3125d000 + 36536
    26  CoreFoundation                	0x31265d44 0x3125d000 + 36164
    27  GraphicsServices              	0x34e3c2e6 0x34e37000 + 21222
    28  UIKit                         	0x3317b2fc 0x33124000 + 357116
    29  SpringBoard                   	0x000de9e2 0xdb000 + 14818
    30  libdyld.dylib                 	0x39473b1c 0x39472000 + 6940
     
  2. iRetired macrumors 6502a

    iRetired

    Joined:
    Apr 21, 2012
    Location:
    WNY
    #2
    How often do you use iCleaner? Reason why I ask is that I was OCD when I first installed it and was using it 2 or 3 times a day. Then I was experiencing crashes of some stock apps and Auxo. Then I did a restore and installed all of my tweaks except iCleaner. That was a week ago and haven't had any crashes since.
     
  3. DerekRod macrumors 6502a

    DerekRod

    Joined:
    Jan 18, 2012
    Location:
    NY
  4. chrf097 thread starter macrumors 68040

    chrf097

    Joined:
    Dec 16, 2011
    #4
    Ok here's what I did:

    1. Switch Auxo to 4 toggles
    2. Uninstall Auxo
    3. Run iCleaner
    4. Reinstall Auxo
    5. Respring AFTER installing and repspringing the first time.

    SO FAR, I've yet to have issues. Lets hope it stays that way.
     
  5. MacDevil7334 macrumors 6502a

    MacDevil7334

    Joined:
    Oct 15, 2011
    Location:
    Austin TX
    #5
    There is a memory leak in the current version. According to their Twitter feed, the developers are aware of the issue and are working on it.
     
  6. headcase macrumors 6502

    headcase

    Joined:
    Jul 4, 2007
    Location:
    Raleigh, NC
    #6
    True, true... but memory leaks and crashes are two different things. I'm experiencing the memory leak, but have been very stable since the install over a week ago. Then again, I've not installed iCleaner either.

    Here's my current list of installed tweaks:

    AdBlocker
    AdBlockerNetworks
    Auxo
    CleverPin
    DietBulletin
    Dimmer
    FullForce
    MuteIcon
    MapsOpener
    Nitrous
    Not-So-Smart
    NowNow
    PandoraSkips
    PasswordPilot Pro
    ProTube 2
    SpringFlash
    Springtomize 2
    SwipeSelection
    UnrestrictPremium
    VolumeStep
    xCon
    YFiSelect 5.0+
     
  7. borgqueenx macrumors 65816

    Joined:
    Jul 16, 2010
    #7
    The memory leak will cause crashes. It just has not been spread over the ram enough if it doesnt crash. Its only a matter of time..begins with apps starting up slower and backgrounded apps closing faster.
     
  8. chrf097 thread starter macrumors 68040

    chrf097

    Joined:
    Dec 16, 2011
    #8
    I can say that doing following the steps above fixes the crashing so far. I've yet to have one.

    Seems the memory leak is linked to having 5 toggles?
     
  9. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #9
    This actually to seems to have worked. Switching between music and Pandora or Spotify etc would cause a crash every time. I just tried to crash the springboard after doing this and so far so good. :D
     
  10. borgqueenx macrumors 65816

    Joined:
    Jul 16, 2010
    #10
    I have no crashes and have 4 toggles. It does pump up my ram with zero's still....no chance in that.
     
  11. headcase macrumors 6502

    headcase

    Joined:
    Jul 4, 2007
    Location:
    Raleigh, NC
    #11
    Yeah, you're right. I've decided to remove Auxo, as it was overkill for my needs anyhow, and now I'm onto using NCSettings for toggles, and SwitcherCleaner for the switchboard. Trying to keep things light.
     
  12. Dorkington macrumors 6502a

    Joined:
    Apr 5, 2010
    #12
    I've had many crashes myself.

    I'll give the above steps a test.
     
  13. bLaZ3n macrumors regular

    Joined:
    Jul 9, 2010
    #13
    I also had to uninstall Auxo lastnight.. Too many crashing and rebooting for me.

    Don't think I will reinstall either, I'm currently using NC Settings and WeeKillBackground as a replacement.
     
  14. tygrubb macrumors regular

    Joined:
    Jun 23, 2010
    #14
    I'm still getting crashes with Auxo, both on the latest stable update and on the latest beta. :-/

    What's funny is that the second-to-last beta fixed the issue entirely for me. It was smooth, no lag, and perfectly stable. Then it went back to the previous suckage.

    iPhone 4S 6.1.2, ruled out all other tweaks and isolated to Auxo.

    Will email the dev, but just wanted to see if anyone else was still having problems.
     
  15. tekboi macrumors 6502a

    tekboi

    Joined:
    Aug 9, 2006
    Location:
    New Orleans ✈ WesŦward
    #15
    Auxo was causing too many problems with springboard for me... so I uninstalled it. Problem solved.
     
  16. Krauser macrumors regular

    Joined:
    Jan 19, 2009
    #16
    Same here. I'm on 6.1 on a 64GB 4S. I picked up Auxo the day after evasi0n was out for iOS 6 and it crashed consistently and I uninstalled it. I checked cydia again today and the changelog made note of the fact that there was a new version addressing the crashes people were having so I got excited and reinstalled it on my 4S. After not even 2 minutes of using my phone, and having simply the Facebook app being the only thing running, auxo crashed my springboard while trying to double click to bring up the multitasking pane, rebooting my phone.

    I don't know what they "fixed" but it's as bad as it ever was. Really disappointed, not only because I paid for it, but because if it was stable, it'd be an excellent application.
     
  17. Auxo macrumors 6502

    Joined:
    Mar 7, 2013
    Location:
    A³tweaks
    #17
    I haven't experienced any crashes but my springboard has a slight lag. it's barely noticeable.
     
  18. digzz macrumors newbie

    Joined:
    Mar 17, 2013
    #18
    I have crash and reboot issues Had the latest update..had to uninstall in the end.
     
  19. sagar4995 macrumors 6502a

    sagar4995

    Joined:
    Aug 11, 2012
    Location:
    Dubai, UAE
    #19
    i've read quite a bit of posts regarding auxo. would it be safe to say that it's only causing issues for ppl using i4 or i4s??
     
  20. Mrg02d macrumors 65816

    Joined:
    Jan 27, 2012
    #20
    Auxo causes me regular crashes throughout the day, every day. I got rid of it.
     
  21. Jakeblu macrumors regular

    Joined:
    Feb 20, 2008
    Location:
    UK
    #21
    Maybe not sure i think some iP5 users complaining. Personally i have not had a crash on my iP5 since the first few days of jailbrake
     
  22. tygrubb macrumors regular

    Joined:
    Jun 23, 2010
    #22
    My friend runs Auxo just fine on his iPhone 5. It does seem that the crashes appear to be trending on the mostly on the 4 and 4S, but not exclusively.
     
  23. sagar4995 macrumors 6502a

    sagar4995

    Joined:
    Aug 11, 2012
    Location:
    Dubai, UAE
    #23
    yeah i think so too. i've been running it on my 5 for a couple of weeks now, without any crashes. just wanted to check anyway if this issue is exclusive for i4/4s.
     
  24. Sracinas macrumors newbie

    Sracinas

    Joined:
    Apr 17, 2013
    #24
    I think I got it!

    I've had a lot of issues with auxo, reboot loops, springboard crashes and etc...

    A fix for me was to change the permissions of AuxoSwitcher.dylib in Library/MobileSubstrate/DynamicLibraries to:

    mobile
    staff

    and only user with Read,Write,Execute
    all the others left blank.

    Now no more issues and everything's working great.

    iPhone 5 iOS 6.1.2
     
  25. cjesse macrumors newbie

    Joined:
    Apr 24, 2013
    #25
    i did the same thing last night
     

Share This Page