Anyone else having this problem?

Discussion in 'Jailbreaks and iOS Hacks' started by KentuckyHouse, Aug 16, 2011.

  1. KentuckyHouse macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #1
    The last couple of days, when I respring using the respring function in SBSettings, my springboard icons are all jumbled up. Random icons are tossed out of folders and back onto the springboard in no particular order.

    I've narrowed it down to the respring option in SBSettings. If I actually turn the phone off and back on, this doesn't happen.

    FYI, 3GS running 4.0 without a hitch up until now. I'm just trouble shooting here to see if anyone else is experiencing this? It's pretty darn frustrating.
     
  2. jjk454ss macrumors 601

    jjk454ss

    Joined:
    Jul 10, 2008
    #2
    Strange. Do you have FolderEnhancer or anything like that installed?
     
  3. IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #3
    Not a clue on this one--SBSettings resprings work fine on both the phone (4.2.1) and the iPad (4.3.3) here.

    Before I'd even think about a restore though, I'd uninstall & reinstall SBSettings, along with anything like FolderEnhancer and Iconoclasm--basically anything that affects icons in folders. See if that changes anything.

    And what happens if you respring from Winterboard? Same thing?
     
  4. KentuckyHouse thread starter macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #4
    I've never gotten around to using FolderEnhancer. I'm still using Infinifolders. And that's a good question about a respring from WinterBoard. I'll change something in there, do a respring, and see what happens. I'll get back to you guys tomorrow with my results. It's kinda late here. LOL.

    Thanks for the replies!
     
  5. KentuckyHouse thread starter macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #5
    Ok, I went ahead and tried a respring from WinterBoard. It worked just fine and the problem didn't occur. Hmm, it looks like SBSettings is the culprit. How odd. Over a year of using it and I've never had one issue until now.

    Any ideas? And if I do uninstall it to reinstall, will I lose all the toggles I've downloaded, or will they show up again once it's reinstalled? That would be a pain to have to install all those again. =)
     
  6. KentuckyHouse thread starter macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #6
    Ok, nix that last comment. I just did a respring via WinterBoard and the stupid springboard came up all mixed up again! WTF is going on here???

    NOBODY else has experienced this? :mad:
     
  7. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #7
    never seen that sometimes on app update it moves from the folder it was in to the springboard

    there a cydia tweak i seen thats recent that fixes icon layout issues not sure if that would help you

    as far as your toggle question i dont believe removing sbsettings would, becasue once you install sbsettings again it should detect the toggels as they were installed seperately,
     
  8. IrishVixen, Aug 17, 2011
    Last edited: Aug 17, 2011

    IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #8
    Well, *******. Mine just did it. I was messing with Iconoclasm and the 5x4 layout, and two of my "folders in folders" went missing. Resprung using SBSettings, and now I have no folders at all, just a zillion apps spread out over multiple springboards.

    A reboot doesn't bring the folders back either. Ugh.

    Edit--well, some folders were simply buried in far off springboards, as it turned out. About thirty apps from the three nested folders were scattered across the phone. The regular folders were untouched. A subsequent respring went fine. Weird weird weird.

    (Using FolderEnhancer. Wonder what we updated in the last few days that would cause this?)

    The tweak iisforiphone refers to is called Bug Fix: Duplicate Icons. I have no idea if it will work, since I can't replicate the issue now. But it's worth a shot.
     
  9. KentuckyHouse thread starter macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #9
    Irish, I'm sorry if I brought the bad karma down upon your phone...lol. But I'm glad I'm at least not going crazy here!

    I'll give that tweak iisforiphone mentioned a try and see if that helps. I even tried going back to nothing but stock (unchecked everything in WinterBoard) and it still does it.

    I recently updated LockInfo, iFile, and something else (maybe libdisplaystack or however it's spelled?) I would think the last one might be the culprit, but I don't know enough about these things to know for sure.

    Hmm...
     
  10. IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #10
    iFile's the only one we have in common then. But I'd think it would affect the iPad the same way, and no sign of it there.

    I'd say try the tweak--if only so we know if it works. But yeah, might unfortunately be time for a restore. :(
     
  11. KentuckyHouse thread starter macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #11
    Geez! I found the tweak, installed it, and then resprung from Cydia. Guess what? Same freaking thing!!!

    This is really getting tiresome!

    And Irish, what you described is EXACTLY what I'm experiencing. While I don't have folders in folders, the "normal" folders are pretty much untouched. But it dumps a couple of folders out onto the springboard. One folder it keeps dumping every app but two. And the layout that is left after this dump is exactly the same every single time. In other words, the icons are always in the same spot on the springboard.

    I hope we can get this figured out. I'm really getting frustrated now! :mad:
     
  12. IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #12
    Unfortunately for you, I can't get it to happen again. I've been messing with icons tonight, and resprings aren't triggering it now, even though I did turn Iconoclasm back on and am using the 5x4 layout that *seemed* to trigger it the first time around. So I'm not much help on triage.

    But dang, I was hoping the tweak would work. Sounds like a restore is in order...how irritating!
     
  13. KentuckyHouse thread starter macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #13
    Yeah, I can't figure out what's going on. I had a brainstorm and thought I'd found a temporary fix. I remembered that I used to have BackBoard on my phone, but deleted it after not using it.

    So, I reinstalled BackBoard, got my springboard all set how I wanted it and saved the layout. I resprang the phone and nothing changed. Then, I thought, I'll change my wallpaper and see if anything changes. Of course it did...lol. App icons were everywhere, once again. So, thinking I'd found a fix, I opened BackBoard, tapped the layout I wanted, and it prompted me to respring. I did. Guess what?

    The stupid icons were scattered everywhere again! Dammit. So the BackBoard trick won't work. I assume the respring just overrides the layout.

    I'll probably do a restore this weekend and update to 4.2.1. I was hoping to avoid it, but I guess I can't. Hurry up iOS5! LOL. :D
     

Share This Page