Anyone else having wifi issues since the lastest update??

2010mini

macrumors 601
Original poster
Jun 19, 2013
4,437
4,313
my Apple TV 4 now constantly warns me that it is not connected to my network even though the signal strength is at max. Never had this problem before I updated it.

Thoughts?
 

2010mini

macrumors 601
Original poster
Jun 19, 2013
4,437
4,313
Let us know what they say. I have the exact same problem.
They had me Restart my model/router and check the ATV performance via Speedtest app. On my 50/50 network I was getting 9/11 after restarting the ATV it was back to 50/50.

That lasted about 10 mins before it was back down to 9/11. Something is just plain weird.
 

benjitek

macrumors 6502a
Sep 23, 2012
863
452
...That lasted about 10 mins before it was back down to 9/11. Something is just plain weird.
Does your router have an option to toggle WMM on/off? Back when I had a Roku the performance was terrible -- hadn't heard of WMM until Roku support suggested I turn it on, for some reason the default setting on my router was for it to be off. Was like a new router after that.

You might also try manually setting the router's radio channel number manually instead of having it autoselect. Not sure why, but everything on my 5-GHz band is trouble free when set to 161. A nifty little Mac app called WiFi Signal will suggest the channel number with the clearest signal after running in the background for a couple days.


WiFi.png
 
Last edited:

2010mini

macrumors 601
Original poster
Jun 19, 2013
4,437
4,313
Just took your suggestion. I googled and found many people having this issue with WMM. turned if of in my fios router. will report back during the day when I get a chance to test it out.
 

benjitek

macrumors 6502a
Sep 23, 2012
863
452
Just took your suggestion. I googled and found many people having this issue with WMM. turned if of in my fios router. will report back during the day when I get a chance to test it out.
If it's the Quantum Fios, it's the same as mine. I don't think turning it off will help, as I turned mine on to improve streaming. Maybe turning yours off and then back on will help. Is your ATV4 connecting via to the router via 5GHz or 2.4GHz...? If you haven't already, you should try setting up separate SSID's for 2.4 and 5 bands, and connect your ATV to 5, with WMM [ON].

Another issue I had was that my ATV4 wouldn't see the 5GHz band until I manually changed the channel to 161. 161 and above were the only numbers that would allow the ATV to 'see' the router. Same thing happened when I had a Roku4, and now the 2016 Streaming Stick. No idea whether that's an issue with the Quantum router or the ATV4, but in addition to the Roku devices, I'd also briefly tried the Amazon FireTV and it required channel 161 and above as well.
 
Last edited:

2010mini

macrumors 601
Original poster
Jun 19, 2013
4,437
4,313
If it's the Quantum Fios, it's the same as mine. I don't think turning it off will help, as I turned mine on to improve streaming. Maybe turning yours off and then back on will help. Is your ATV4 connecting via to the router via 5GHz or 2.4GHz...? If you haven't already, you should try setting up separate SSID's for 2.4 and 5 bands, and connect your ATV to 5, with WMM [ON].

Another issue I had was that my ATV4 wouldn't see the 5GHz band until I manually changed the channel to 161. 161 and above were the only numbers that would allow the ATV to 'see' the router. Same thing happened when I had a Roku4, and now the 2016 Streaming Stick. No idea whether that's an issue with the Quantum router or the ATV4, but in addition to the Roku devices, I'd also briefly tried the Amazon FireTV and it required channel 161 and above as well.
I don't have the quantum router. I only turned off WMM Powersave as suggested by a blogger who tried every other method to improve performance.
 

bigpoppamac31

macrumors 68020
Aug 16, 2007
2,290
335
Canada
Does your router have an option to toggle WMM on/off? Back when I had a Roku the performance was terrible -- hadn't heard of WMM until Roku support suggested I turn it on, for some reason the default setting on my router was for it to be off. Was like a new router after that.

You might also try manually setting the router's radio channel number manually instead of having it autoselect. Not sure why, but everything on my 5-GHz band is trouble free when set to 161. A nifty little Mac app called WiFi Signal will suggest the channel number with the clearest signal after running in the background for a couple days.


How do I change the channel on the Airport Extreme in the Airport Utility App on my Mac? Also how do I change my network name and password?
 

ABC5S

Suspended
Sep 10, 2013
3,395
1,646
Florida
My Airport Extreme, the latest model, does not have this issue at all. Is anyone having issues with an Apple Extreme and 5GHz setting and the updated firmware ?
 

benjitek

macrumors 6502a
Sep 23, 2012
863
452
Yeah I believe the WMM Powersave is a Microsoft Windows feature
Actually, it's not OS-specific. To get to this setting I access the admin screen through a web browser, it's the same whether from Windows or Mac (or iOS). It's not a device setting, it's a router setting.
[doublepost=1464567263][/doublepost]
How do I change the channel on the Airport Extreme in the Airport Utility App on my Mac? Also how do I change my network name and password?
Your best bet is to Google the question, or contact Apple Support -- as the OP and myself both have Verizon provided routers.
 

2010mini

macrumors 601
Original poster
Jun 19, 2013
4,437
4,313
So after disabling WMM Powersave on my fios router, the wireless issue on the Apple TV just got worst. Instead of randomly popping up a warning that it wasn't connected to the Internet. It constantly happened.

So I disabled WMM QoS. After that I watch a couple hours of content with no problems.
 

NeilHD

macrumors regular
Jul 24, 2014
204
285
So it's not just me!!

Mine has been doing that for a couple of weeks now. Continually telling me it's lost network and then instantly getting it back again with full strength. Sometimes it refuses to connect and I have to reboot it, then it's fine for a while.
 

2010mini

macrumors 601
Original poster
Jun 19, 2013
4,437
4,313
So it's not just me!!

Mine has been doing that for a couple of weeks now. Continually telling me it's lost network and then instantly getting it back again with full strength. Sometimes it refuses to connect and I have to reboot it, then it's fine for a while.
Yeah I'm thinking this is a bug in the latest OS update. Just enable or disable WMM (depends on your router) like folks here have done to solve this issue.

Hopefully Apple will address this in the next update.
 

bassanoclapper

macrumors 6502
Mar 4, 2008
271
34
London
My Airport Extreme, the latest model, does not have this issue at all. Is anyone having issues with an Apple Extreme and 5GHz setting and the updated firmware ?
Yup, 2.4 is much better than 5GHz in maintaining WiFi signal for me since software updates last week.
Mac & all iOS devices all fine
 

NeilHD

macrumors regular
Jul 24, 2014
204
285
Yeah I'm thinking this is a bug in the latest OS update. Just enable or disable WMM (depends on your router) like folks here have done to solve this issue.

Hopefully Apple will address this in the next update.
I'm using an Airport Express, not sure if I can do it on that.

The last couple of days have been a lot better actually... has there been another update does anyone know?
 

ABC5S

Suspended
Sep 10, 2013
3,395
1,646
Florida
Yup, 2.4 is much better than 5GHz in maintaining WiFi signal for me since software updates last week.
Mac & all iOS devices all fine
Gotcha Ya....I use the 5Ghz setting because its in the same room as the TV, about 20 feet away. 2.4 has a better distance signal than 5 Ghz.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.