Anyone else seeing terrible FPS with Cities: Skylines in OS X?

Discussion in 'Mac and PC Games' started by content, Jan 9, 2016.

  1. content macrumors member

    content

    Joined:
    Dec 22, 2015
    #1
    I have a 2015 MBP 15", Core i7 2.5GHz, and AMD Radeon R9 M370X Graphics. My FPS is 10-11 FPS zoomed out and, 7-8 FPS zommed in. I know, pretty pathetic. The city can be small or huge, doesn't matter. Bummed.

    I read the Mid 2014 MBP with NVIDIA GeForce GT 750M had low FPS initially because the integrated GPU was being used instead of the dedicated, but I'm not sure if I am experiencing the same thing. I forced the dedicated card only, but still my FPS is abysmal...

    Does anyone have this same issue?

    Thanks
     
  2. chino101 macrumors newbie

    chino101

    Joined:
    Dec 8, 2015
    #2
    I have a 2015 RMP 13 inch with Core i5 and Intel 6100, and I have had no issues with slow FPS.
    It's strange that you are having issues.
     
  3. content thread starter macrumors member

    content

    Joined:
    Dec 22, 2015
    #3
    That's curious... Hmm, that seems to tell me that if you have no dGPU the problem is somehow related to the dedicated AMD... What is your FPS in game? You can subscribe to FPS Display if using Steam and it'll show you your FPS in game.

    Thanks
     
  4. chino101 macrumors newbie

    chino101

    Joined:
    Dec 8, 2015
    #4
    Sorry, I forgot that Apple replaced my Macbook and I don't have Skylines on my 2015 model. I was playing it on my late 2013 model with Core i5 and Iris 5000 graphics.

    I don't play it anymore or use steam for it, so I can't give an accurate FPS figure. I just remember it being on high with no lag, just a lot of heat.
     
  5. Les Kern macrumors 68040

    Les Kern

    Joined:
    Apr 26, 2002
    Location:
    Alabama
    #5
    Maybe check your processes and see if anything is hogging cycles to try to narrow down the cause. If not, try reinstalling, maybe even in a temporary account.
     
  6. Mcmeowmers macrumors 6502

    Joined:
    Jun 1, 2015
    #6
    Try plugging your computer in. Also, check your resolution. If it's set to retina it can be quite demanding!
     
  7. utterer macrumors newbie

    Joined:
    Jan 14, 2016
    #7
    Disable the Steam Overlay from Steam Preferences. I have also had better performance by switching the game out of fullscreen and running it in Windowed mode instead.
     

Share This Page