Anyone else still having 2013 MBA wifi issues?

Discussion in 'MacBook Air' started by vgates, Sep 15, 2013.

  1. vgates macrumors newbie

    Sep 15, 2013
    Hi guys. Wie gehts?

    I recently bought a new MBA (11/128/4) and decided to double the RAM, so I bought another new MBA (11/128/8). I returned the first today, but experienced the same issues with it. Both systems are/were running 10.8.5 (so are/were up to date with patches, etc).

    My internet connection dies randomly. I don't get disconnected from my network, but for a few minutes I can't visit websites or `ping`. Requests just time out. I'd say it happens every forty minutes on average.

    I just chatted with Apple and ended up on the phone with a "wireless specialist" who was basically unhelpful. We ran wireless diagnostics and hardware diagnostics. Both reported no problems. We deleted some .plist files which cleared out my saved networks and created a new "location" in the Network tab of System Preferences, but I still get random disconnects. He also suggested changing the wireless channel (from 1 to 3 or 9) on my router. This hasn't helped either.

    I suppose it could be my router, though I also have a 2010 MBA (best computer ever) on the network which has been working fine.

    I know that there have been wifi issues with the new MBAs and a patch was released that supposedly fixed them. I just wonder if anyone else is still having similar problems. I was surprised to see no threads on the first page of the Macbook Air forum about this.

    Also, just a little bit of extra information: I get really awful results from ping. For example, if I ping on my new MBA:

    64 bytes from icmp_seq=8 ttl=52 time=40.071 ms
    64 bytes from icmp_seq=9 ttl=52 time=321.752 ms
    64 bytes from icmp_seq=10 ttl=52 time=128.838 ms
    64 bytes from icmp_seq=11 ttl=52 time=269.909 ms
    64 bytes from icmp_seq=12 ttl=52 time=267.283 ms
    64 bytes from icmp_seq=13 ttl=52 time=214.835 ms
    64 bytes from icmp_seq=14 ttl=52 time=128.317 ms
    64 bytes from icmp_seq=15 ttl=52 time=271.332 ms
    64 bytes from icmp_seq=16 ttl=52 time=211.670 ms
    64 bytes from icmp_seq=17 ttl=52 time=36.503 ms
    whereas on my 2010 MBA, on the same network, I get a reliable 40-50ms :rolleyes:
  2. Y So Jelly macrumors regular

    Sep 14, 2013
  3. calvol macrumors 6502a

    Feb 3, 2011
    Makes me want to keep my 2010 13" MBA, although I just ordered the base 2013 Air on the Best Buy student deal. I'll test it out on my Airport router when it comes, then make the decision. Which router(s) are showing issues?
  4. Y So Jelly macrumors regular

    Sep 14, 2013
    Anything over 5 years old. Mine is wireless g, so that's dated I guess. :(
  5. Miltz macrumors 6502a

    Sep 6, 2013
    New York
    I've had no wireless issues, actually my wireless speeds are amazing with the MBA 2013. I'm using the Router supplied by Verizon Fios. 802.11n mode. I'd try getting a new router and see if that helps.
  6. Lunfai macrumors 65816


    Nov 21, 2010
    No problems with mine using 2ghz band or 5ghz band. 100 Mbps using the 5ghz which is my advertised broadband speed (FIOS).
  7. m98custom1212 macrumors 6502

    Jul 20, 2013
    Toledo, Ohio
    I have no problems either. I have a asus ac66u
  8. checkitout macrumors member

    Nov 2, 2009
    Quite some specialist.
    (Never use a channel outside the set that is usual in your neighborhood, which for 2.4 GHz is 1, 6, 11 in most parts of the world.)

    I like that you are doing measurements to find out what's going on.
    May I suggest that, instead of (which factors in any delays in your Internet access, which may be sizable) you ping the router?

    What does alt-clicking the antenna symbol in the menu bar show?
    You should see something about RSSI (received signal strength indicator), transmit rate, and possibly MCS index.
  9. bp1000 macrumors 65816

    Jul 7, 2011
    Only info i can add to this is my 2011 MBA refused to reconnect to wifi but only when i used channel 12 or 13.

    Channel 11 and all was fine.

    Make sure your router also isn't in power saving mode for radio... only use 20mhz channel width on 2.4ghz. 40mhz only for 5ghz band.
  10. vgates thread starter macrumors newbie

    Sep 15, 2013
    Thanks for the advice. Here's what I see on my new Macbook Air:

    RSSI: -49
    Transmit Rate: 145
    MCS Index: 15
    I won't pretend to know what this all means.

    It also shows that I'm connected using 802.11n. I know my router isn't capable of 802.11ac and this is likely the culprit. I'd still hope that Apple would be able to provide some decent backwards compatibility -- it seems unreasonable to expect that everyone will upgrade their routers right away.

    If I ping the router instead, I see response times like this:

    64 bytes from icmp_seq=0 ttl=64 time=89.155 ms
    64 bytes from icmp_seq=1 ttl=64 time=214.625 ms
    64 bytes from icmp_seq=2 ttl=64 time=1.516 ms
    64 bytes from icmp_seq=3 ttl=64 time=57.907 ms
    64 bytes from icmp_seq=4 ttl=64 time=1.479 ms
    64 bytes from icmp_seq=5 ttl=64 time=307.696 ms
    For comparison, on my 2010 MBA I get steady 1-6ms response times, and see the following by option clicking on the antenna symbol.

    RSSI: -47
    Transmit Rate: 130
    MCS Index: 15
    I've basically accepted the weird behavior for now. I have faith that, eventually, it will be fixed. In the meantime, I just won't keep playing my hardcore character in Diablo3 :)
  11. checkitout macrumors member

    Nov 2, 2009
    Well, first of all an RSSI of -49 shows that you have a good path to the base station (and the antenna cable isn't loose). I'm curious about the transmit rate of 145 Mbit/s (at Modulation Coding Scheme 15), because that means the MBA is using a short guard interval (your old one seems to use a long guard interval and this would only get 130 Mbit/s at the same MCS).
    Maybe your access point (what make was that?) only works right with the long guard interval. Stabbing in the dark -- can you switch SGI off on that AP?
  12. Cole Slaw macrumors 6502a

    Cole Slaw

    Oct 6, 2006
    I don't believe I've ever had my 2013 Air drop a WiFi connection.
  13. DesignerOnMac macrumors 6502a


    Jul 23, 2007
    Your fortunate! Lose wifi everyday. I downloaded the patch with no improvement and problem has never gone away. Today lost internet for 6 hours.
  14. majkom macrumors 65816

    May 3, 2011
    actually, it is not routers fault, it is os x problem and air 13 problem - i do have haswell air, os x up to date and new airport extreme, everything works fine, but if i do surf in one room and then move to another, out of the blue i do experience same issue as OP, but only in case that I do start surfing in first room... if I do start surfing in the second, no problems occur.. strange I know, and I hope mavericks solves all issues:)
  15. jg321 macrumors 6502

    Aug 29, 2012
    Same experience here. 2013 MBA (my girlfriend's) has never had issues with the Wifi. Router is the Apple TV style Airport Express, using the 5Ghz N SSID.
  16. vgates thread starter macrumors newbie

    Sep 15, 2013
    It's a Westell/Netgear 7550.
    I'll look around in the settings. Thanks for the advice.
  17. Tinknock71 macrumors 6502


    Jan 18, 2008
    Westland Michigan
    Got new 2013 Macbook Air thursday 1.3 8-128 using first generation apple extreme 2007 no wifi drop outs yet been using for 6-8 hours each day since online, misc apps. router is in 2.4 auto channel. I was planning on upgrading to new extreme if I had problems like everyone else was having.
  18. ha1o2surfer macrumors 6502

    Sep 24, 2013
    Before I returned my Macbook Air 11inch 2013, I had a lot of WiFi issues with all sorts of routers.. I ran Windows 8 on a lot on my Air and it seemed to be much more stable. I still think it's a hardware issue. I would download a file on Google Chrome and the ETA would shoot up to a couple days then disappear. Then the music would stop streaming and all my network drives were lost. This sometimes took a couple seconds to come back or I'd have to turn WiFi off and On again.

    When people say they haven't lost internet or it's working fine.. you may not notice it if you are just browsing the web slowly, or watching the WiFi icon. If you were just connected to the access point and not doing anything network related, you wouldn't even know something was wrong...The ping starts to shoot up (sometimes up to 2 seconds) and might return to normal after a few moments or the connection drops. For me, watching YouTube was impossible...

    I hope they fix it for everyone!
  19. calvol macrumors 6502a

    Feb 3, 2011
  20. jacg macrumors 6502a


    Jan 16, 2003
    My friend has a new air. Works fine at home but is a complete nightmare at work. Simply won't connect to half the access points (802.11g). They all have the same name - is that likely to be an issue?
  21. gregpod9 macrumors regular

    Apr 27, 2007
    The 13" 2013 MBA (i7/8/256) that I received a few days ago had WiFi issues. It couldn't stay connected to my network, had long latency times when pinging to my router. This happened in OS X 10.8.4 and 10.8.5. I shipped it back to Apple and debating if I should try the new iMac or go back to a pure Windows PC.
  22. jacg macrumors 6502a


    Jan 16, 2003
    There must be a firmware update on the way. How could they keep selling them if there was a hardware problem?
  23. DesignerOnMac macrumors 6502a


    Jul 23, 2007
    Apple Senior WiFi Specialist

    I too have issues with wifi with my 2013 Air. Spoke to a Senior wifi specialist, who wasn't very special. After over an hour on the phone his recommendation
    was to buy an airport express and an ethernet cable...Dah No need to buy a new router, but recommended I update the firmware!

    In the end found out that the router was dying and ordered a refurbished router. Should be here today.

Share This Page