Anyone else's iMac take awhile to reboot?

Discussion in 'macOS Sierra (10.12)' started by dictoresno, Jan 31, 2017.

  1. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #1
    Everytime I reboot, once macOS logs out, the screen goes blank/black for like 30 seconds then finally reboots. Upon doing so, it goes to the blank/black screen again for like 10-15 seconds before the apple logo appears. I have a brand new SSD installed recently and don't recall this happening with the oem HDD. After the apple logo appears, boot up is only 20 seconds or so, which is good. It's just the blank/black screen for 30 seconds that confuses me. My MacBook doesn't appear to do this.
     
  2. Lunder89 macrumors regular

    Lunder89

    Joined:
    Oct 16, 2014
    Location:
    Denmark
    #2
    Have you set the default boot harddrive for your Mac?
    If not, that is most likely the problem.

    To set default boot harddrive, open System Preferences > Startup Disk, Unlock the settings panel by clicking the pad-lock, type your system password, click the harddrive you want as default boot, click the restart button in the preferences window to confirm, and to do restart and see if it works.
     
  3. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #3
    You know what, it was set as the internal HDD which was "Macintosh HD" but after the install of the SSD, which is a different name and was being used externally, I never changed it over to the new one. So I assume it's looking for the other drive, then defaulting to the new internal SSD?

    Makes sense. I'll change that in my settings and see if that helps.
     
  4. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #4
    ok i specified the internal SSD as the startup disk. beforehand, both it and the bootable clone external were greyed out. i assume that meant it took the computer extra time to determine which one it should boot from. now the blank black screen is only visible for 3-5 seconds on both restart and reboot. total time from when i click restart and I'm back into macOS and able to use apps is about 30 seconds. WOW!

    thanks for the tip!
     
  5. Lunder89 macrumors regular

    Lunder89

    Joined:
    Oct 16, 2014
    Location:
    Denmark

Share This Page