Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

saywhat13

macrumors newbie
Original poster
Feb 12, 2023
12
1
South Dakota, USA
Hi everyone!

MBP 2010 on Catalina with Dosdude1 patch here. Like the title says it wouldn't open now. Checking the crash logs in console.app, it seems again a codesign problem.

So I tried the traditional workaround:
Code:
sudo xattr -cr /path/to/onedrive
sudo codesign -f -s - /path/to/onedrive

But it doesn't work this time...

Any ideas about this? Kudos.
 

howdytom

macrumors member
Mar 29, 2020
53
21
Yes, Same issue here running macOS Catalina.

Tried to reinstall OneDrive to no avail. OneDrive is a terrible piece of software.

Any workaround?
 
Last edited:

howdytom

macrumors member
Mar 29, 2020
53
21
It looks like the recent auto update fails on MacOS Catalina. According to the user Thomas Hengstl , Version 23.054.0313.0003 seems to be compatible.

UPDATE: Here's a quick solution that worked for me.

1. Remove the latest OneDrive version from the Applications folder
2. Install Version 23.054.0313.0003. Download: https://go.microsoft.com/fwlink/?linkid=823060
3. Open Activity Monitor and search for OneDrive.
4. Open OpenDrive
5. Make sure to force quit when OneDrive Updater shows up in Activity Monitor. In my case the OneDrive Updater did not show up, though.
6. OneDrive preparing synchronization

I hope this helps.
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.