anyone ever brought back a USB port?

Discussion in 'MacBook Pro' started by stonewall777, Jan 17, 2014.

  1. stonewall777 macrumors newbie

    Joined:
    Feb 18, 2010
    #1
    anyone ever brought back a USB port?

    I keep getting an alert message saying that a USB port was
    drawing too much power, and it has been disabled.

    I decided to remove the logic board and clean it. So I did,
    I tried to wipe it down with alcohol and Q tips. And then I
    used a can of air to further blow out the dust and dry the
    alcohol.

    After plugging everything back in, it was completely dead. I
    rechecked everything and it turns out the keyboard cable
    wasn’t in correctly. So after sliding it in and latching it, I tried
    again. And nothing. So I was sitting there dumbstruck and
    after what seemed like forever, I heard the fan come on hard for
    about a second, then off. And then the bong and it started
    booting up. Yay!

    The memory seemed to be working fine. But I kept getting
    freezes forcing me to power off and reboot. Along with the
    USB port shutdown. I decided to check the iStat widget, and the
    fan was zero and the cpu was 70 degrees. So I think it was
    overheating and freezing the cursor. I unplugged the fan a
    couple of times and it was the same. I let it cool off and then
    tried an SMU reset. And this fixed the fan, which seems to have
    fixed the screen freezes.

    Now back to the USBs. I decided that I could live without one
    of the USBs. So I decided to try the unix command to shut off
    the error message. From the terminal, I tried this:

    sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.UserNotification

    and it didn’t work. My terminal rejected this command string.
    I was just entering this at my user prompt in the terminal. I’m
    not too familiar with unix, so maybe I was at the wrong prompt.
    Or something…

    So, I may troubleshoot the USBs if anyone has anything to try.


    Thanks.
     
  2. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #2
    I've seen the message, but the solution was to unplug the errant device and reboot. It worked fine after that.
     

Share This Page