Anyone get SCX-4100 scanning?

Discussion in 'Mac Accessories' started by Gentile, Feb 9, 2008.

  1. Gentile macrumors regular

    Gentile

    Joined:
    Apr 29, 2007
    Location:
    Ohio
    #1
    I have a Samsung SCX-4100 multifunctional printer. There is a mac printer driver, but no twain/scanner driver.

    Has anyone gotten this to scan under OS X?

    I tried Sane, but there is only an external Linux backend available.
     
  2. cdcastillo macrumors 6502a

    cdcastillo

    Joined:
    Dec 22, 2007
    Location:
    The cesspit of civilization
    #2
    You don't need a scanner driver. Just open "Image Capture" with the multifunctional hooked to the computer and there you go...
     
  3. Gentile thread starter macrumors regular

    Gentile

    Joined:
    Apr 29, 2007
    Location:
    Ohio
    #3
    I tried that, the iMac does says there is no scanner attached. I also tried to use Preview and "import image" and I get the same message.

    It appears the scanner function works only for Linux or Windows:(

    Anyone know any differently?
     
  4. jf8 macrumors regular

    Joined:
    Aug 8, 2007
  5. jf8 macrumors regular

    Joined:
    Aug 8, 2007
    #6
    I got it working!

    I got the scanner in my SCX-4100 working with the Samsung SCX-4500 scan driver (I also use the SCX-4500 print driver.)

    Steps:
    1. Download the driver. I used 20071224134136734_SCX-4500_OS_X_Scan.zip
    2. Unzip the package
    3. Open up MAC_TWAIN/SamsungSCX-4500Series.ds/Contents/Info.plist in your favorite text editor
    4. Find the product key in the IOUSBDevice section (line 43
    5. Change the value from 0x3426 to 0x3413
    6. Do the same for MAC_TWAIN/SamsungSCX-4500Series.ds/Contents/Resources/Info.plist
    7. Open up MAC_TWAIN/SamsungSCX-4500Series.ds/Contents/Resources/Defaults.plist
    8. Find the PID key (line 16)
    9. Change the value from 0x3426 to 0x3413
    10. Install the driver as normal

    The scanner works in Image Capture. To use it, I have to go to Devices->Browse Devices and then click on Use TWAIN UI. (Note that the scanner does not say it is connected on that screen - do TWAIN scanners normally act like this?)
     
  6. jf8 macrumors regular

    Joined:
    Aug 8, 2007
    #7
    After rebooting, the scanner now shows as "connected" in applications such as Image Capture.
     
  7. CampyCapybara macrumors newbie

    Joined:
    May 30, 2008
    #8
    Thank you soooooo much, jf8! :D

    Just prior to trying out your method, I called up my Samsung tech support, and all they could advise me was to check that the next printer I buy from them has Mac OS capability! Even when I asked them if they would contact me if they were to create drivers for the SCX-4100, they told me that the onus was on me to check the site regularly to see if they would update their drivers!:mad:

    Needless to say, short of junking my machine because I changed from a Windows platform to a Mac platform, I tried out your method. Not only was it easy as pie to do, the SCX-4100 worked perfectly and I'm only too happy that I don't have to get a new scanner!

    Thank you! Thank you! Thank you!:D
     
  8. bosweg macrumors newbie

    Joined:
    Oct 27, 2008
    Location:
    Velp Netherlands
    #9
    driver still available?

    JF8, I'm tring to get mt SCX 4100 to scan and found your solution. Samsung have removed the driver from their website. do you still have a copy of the driver? I would really appreciate a copy.
    Regars,
    Bosweg
     
  9. hizzle macrumors newbie

    Joined:
    Jan 19, 2009
    #10
    Here are the complete drivers for Mac (patched scan + print) for the SCX-4100. I uploaded it to 4 hosts, so hopefully 1 will be working/alive when someone needs it. :)

    Note: Thanks a lot to jf8 for that awesome hack. I no longer need to boot up Parallels to get in a scan :) I think I love you... :apple:

    http://rapidshare.com/files/186218941/Mac_-_SCX-4100.zip.html
    http://www.megaupload.com/?d=DSX4PO7M
    http://www.filefactory.com/file/a02af6e/n/Mac_-_SCX-4100_zip
    http://www.mediafire.com/?sharekey=ed469730f916532061d4646c62b381cbe04e75f6e8ebb871
     
  10. aalsayed89 macrumors newbie

    Joined:
    Sep 3, 2010
    #11
    Thank you..

    I registered in this forum just to thank jf8 and hizzle.
    Thanks guys.
     
  11. gfrog123 macrumors newbie

    Joined:
    Dec 10, 2010
    #12
    Thanks

    Thank you jf8 and hizzle !!!!! Finally my printer works correctly! I thought I had to buy a new one.
     
  12. ariaa macrumors newbie

    Joined:
    Apr 12, 2011
    #13
    Thank you!!!

    Just registered solely to say thanks for this. I can finally apply for my Phd!
     
  13. Tryria macrumors newbie

    Joined:
    Aug 30, 2011
    #14
    I also need this!

    I have just changed to a MacBook and I too have a MFP SCX-4100. I found all the instructions and have done the best to try and follow them. However, the four links that hizzle posted can't be accessed by my Safari.:mad: Very frustrating.

    Are these links still active? I see that ariaa was successful in April this year.

    Anyone of you who have been on this road able to give me some advise? Would so appreciate it.
    Tryria
     
  14. senorfrog97 macrumors regular

    Joined:
    Jan 19, 2008
    Location:
    Austin
    #15
    Are you running Lion? After upgrading to Lion it no longer works for me.
     
  15. ekantola macrumors newbie

    Joined:
    Oct 1, 2011
    #16
  16. speedo812003 macrumors newbie

    Joined:
    Jan 30, 2013
    #17
    Thanks!!

    Thanks guys! I had been searching for a solution to make my SCX-4100 printer work with my new Mac book pro for such a long time. I finally made it to work by following the steps detailed by jeff!!
    Cheers!
     
  17. spicymustard macrumors newbie

    Joined:
    Mar 20, 2013
    #18
    Hi all! Does anyone have a link to the drivers they could share? I've been trying to get my scx 4100 to work for months now! thank you much!
     
  18. mhauck7 macrumors newbie

    Joined:
    Apr 10, 2013
    #19
  19. Giuly macrumors 68040

    Giuly

    #20
    This thread (and the printer) is so old that it justifies looking at an AirPrint-compatible multifunction laser with fax like the Brother MFC7860DW instead.
    [​IMG]
     
  20. ReneR macrumors 6502

    Joined:
    Jun 18, 2008
    Location:
    Berlin, Germany
    #21
    This is a myth, of course driver are required for ImageCapture as well, without a driver it will not work magically by itself, ...
     
  21. MacTiger14 macrumors newbie

    Joined:
    Apr 17, 2014
    #22
    how scx-4100 scan works with OSX Mountain Lion

    I upgraded my MacBook Pro to OSX 10.8.5 (Mountain Lion).
    I followed all the steps described by jf8 on May 18, 2008 04:23 PM but ImageCapture did not recognize my SCX-4100.

    But with the following trick it worked:
    (the idea for that I got obviously from jf8's post - so thanks to him).

    On /Macintosh HD/Library/Image Capture/Devices/ there was a
    'Samsung Scanner.app' (dated from Feb. 11, 2010).

    So I opened the terminal.app and went to

    >>> cd /Library/Image\ Capture/Devices/Samsung\Scanner.app/Contents/Resources/

    There I changed "DeviceMatchingInfo.plist" and "deviceInfo.plist"
    (>>> e.g. sudo vi DeviceMatchingInfo.plist / deviceInfo.plist )

    I searched in both files for key/value entries

    <key>idProduct</key>
    <string>0x3426</string>


    which appear under some kinds of "Samsung SCX-4500" sections in these files.
    According to jf8 post I changed both these ids to "0x3413" and restarted my mac.

    Now the scan-option was available!
    (When opening the ImageCapture.app, the SCX-4100 was listed among devices as well as on
    "System preferences->print&scan->Samsung SCX-4100"
    now the "Scan" button appears.

    And the Scan works very fine for this Samsung model!
     
  22. Hans Spicar macrumors newbie

    Joined:
    Jun 30, 2015
    Location:
    Sweden
    #23
    Samsung SCX-4100 works with Mac OS X 10.10.4!

    Using the advice from jf8 and MacTiger14 i just got my fathers old Samsung printer/scanner working with OS X 10.10.4.

    I got the printer working by downloading and installing the printer driver from Samsung for SCX-4500. OS X "sees" the SCX-4100 printer but you have to assign the printer driver for SCX-4500 to it. This is done in system settings/printers.

    I also downloaded the scanner driver and software for SCX-4500 but only installed the driver. I am not confident with using the terminal and to edit the above mentioned files required root privileges. The easy solution is to copy the files, make the changes, save, erase the original files and replace them with the edited files (admin privileges needed). Filenames have to be identical.

    Pay attention to that App Store software update will suggest to install a newer Samsung printer driver but that will break scanning. You have to make the changes in the files again to make it work.

    I'm swedish so excuse my somewhat strange "accent".
     
  23. ama-ar-gi macrumors newbie

    Joined:
    Feb 28, 2015
    #24
    Any tricks for El Capitan?! It seems that the solution doesn't work on Mac OS X El Capitan... Thanks.
     
  24. Hans Spicar macrumors newbie

    Joined:
    Jun 30, 2015
    Location:
    Sweden
    #25
    With Vuescan you should be able to use the scanner.
     

Share This Page