Anyone getting graphical glitches?

Discussion in 'OS X Yosemite (10.10)' started by comatory, Nov 3, 2014.

  1. comatory macrumors 6502a

    comatory

    Joined:
    Apr 10, 2012
    #1
    I got a brand new (ok, refurbished) MBP 15" Retina (late 2013 hi-end model), installed clean OS X Yosemite and it's been running fine except I get graphical glitches.

    I don't know if these are OS based or if I should prepare myself for faulty GPU (GT 750M w/ 2GB VRAM). This sometimes happens randomly and switching between the desktops "cleans up" the mess.

    I had this happen quite often in Photoshop. Once I had it happen with quick view video playing (glitches in video) but checked in VLC if it's the file or not. I had one kernel panic when I switched to 3D Ray Tracing in After Effects and had bunch of other stuff open (I guess it could be not enough VRAM but I was just rotating extruded 3D text?). Restart fixed it.

    Premiere Pro is working flawlessly though. I have latest Nvidia CUDA driver installed.

    Then I tried playing X-Com (the new one :) ) with max details and max resolution, the computer handled it just fine. I'm kinda worried it might be faulty GPU... but would I be able to do screenshots of it if it was true (I'm no expert so idk).

    I have external 1080p display attached, I notice when switching apps I get this white blocky flickers in upper-right corner of menubar (using dark mode).

    These are the ones I caught today.

    [​IMG]
    [​IMG]
     
  2. gsahli macrumors 6502a

    gsahli

    Joined:
    Jun 1, 2007
    Location:
    Chicago
    #2
    Yes, I got glitches like that. Had to revert to Mavericks.
    (also had mouse cursor "trail" remaining on the screen.)
    I believe that these issues are actually due to a "bad install." - corrupted files being installed and the installer not being able to see/fix it.

    I'll be trying Yosemite again soon.

    I reported my issues to Apple using apple.com/feedback.
     
  3. comatory thread starter macrumors 6502a

    comatory

    Joined:
    Apr 10, 2012
    #3
    That's good to hear I was beginning to be worried that I had faulty GPU because it looks a lot like it.
     
  4. jonobin macrumors regular

    Joined:
    Sep 3, 2014
    #4
    seems the exact same glitches that I've had with intel gma x3100 in snow leopard, software updates fixed that
     

Share This Page