Anyone got a fix for Excel 2016's "Snap to cell" scrolling?

Discussion in 'Mac Apps and Mac App Store' started by dbrewer80221, Jul 17, 2015.

  1. dbrewer80221 macrumors regular

    Joined:
    Jun 16, 2009
    #1
    I haven't figured out how to change Excel 2016's scrolling behavior, I'm hoping someone in here might know.

    Current behavior is it snaps to the top left cell when scrolling through a spreadsheet. If I scroll to the right, it will snap to the next cell if you're more than 50% through the width your current cell. Problem is I can't see all the fields I want to see when it does this.
     
  2. Significant1 macrumors 6502

    Joined:
    Dec 20, 2014
    #2
    I don't fully understand your question. If you don't use the scrollbars but pans with 2 fingure gesture on trackpad, it is scrolling by pixels not cells. Otherwise cant you either zoom out or freeze column/row
     
  3. dabellinator macrumors newbie

    Joined:
    Sep 1, 2011
    #3
    I second the issue. I am too looking for a solution to the scrolling behaviour stated above. It is a hassle particularly when you have large cell sizes and are trying to scroll through the document.

    While I understand what is being said perfectly, I will try and elaborate on what dbrewer80221 is saying in another (not necessarily better) way. As you are scrolling through the document, when you let go other the scrolling (be it trackpad scrolling or a magic mouse scrolling), excel will then snap the view to ensure that the top left cell aligns perfectly with the top left of the view panel. To determine what cell to snap the view to when doing this, the program looks at how far the view is currently through the top left cell. If it is showing more than 50% of that cell (in the direction of the scroll), then it will snap the view with the entirety of that cell in view. If it is showing less than 50% of that cell, then it will snap the view with the next cell in view.

    This is extremely annoying particularly when you have larger cell sizes, as you can let go of the scroll and the document will suddenly snap the view and the document can "jump" considerably from what you were viewing when you let it go. It is slowing my productivity for what i am doing considerably and I am currently starting to wish I hadn't made the move to upgrade. If anyone has a solution to stop this snapping please let me know.
     
  4. JtheLemur macrumors 6502

    Joined:
    May 13, 2002
    #4
    I had the same question and ended up here. Whomever let this piece of **** out the door without at least the option to turn it off should be dragged out into the street and shot. There are UX designers out there that actually do good work and it's a shame Microsoft doesn't employ any of them, apparently.
     
  5. thekayman macrumors 6502

    Joined:
    Oct 23, 2014
    #5
    one of the most annoying things in office '16! add to that the inertial scrolling / cursor move
     
  6. vkd macrumors 6502a

    vkd

    Joined:
    Sep 10, 2012
    #6
    Quick fix: Eliminate Excel from your computer and use Apple Numbers.
     
  7. JCMiller23 macrumors newbie

    Joined:
    Jan 4, 2016

Share This Page