Anyone had problem UNLOCKING 2.2 on the 2G iPhone?

Discussion in 'Jailbreaks and iOS Hacks' started by Gigamaster89, Nov 26, 2008.

  1. Gigamaster89 macrumors member

    Joined:
    Oct 1, 2008
    #1
    Title, anyone had any problems unlocking their first gen? (specifically, for TMO)
     
  2. brenmcg macrumors newbie

    Joined:
    Nov 27, 2008
    #3
    I've had trouble,

    I updated my 2g iPhone to 2.2 using iTunes and then used QuickPwn to jailbreak it. Ever since I can't get any signal... even the carrier tab in settings is missing!

    Any suggestions would be much appreciated...
     
  3. lavrishevo macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
  4. Four20 macrumors 6502a

    Four20

    Joined:
    Sep 22, 2007
    #6
    not me. mine jailbroke and unlocked flawlessly
     
  5. Gigamaster89 thread starter macrumors member

    Joined:
    Oct 1, 2008
    #7
    So that means it's not suppose to have any problem?

    Anyone else having signal problems?
     
  6. rtztgue macrumors regular

    Joined:
    Aug 9, 2008
    #8
    major problems... my 2g got stuck in recovery mode. The only way to get it out is to do a full restore, and then re-jailbreak(with unlock). But it gets stuck in recovery mode again. I get to the last screen of quickpwn and it just cannot seem to finish the job.
     
  7. tjobeid macrumors member

    Joined:
    Jul 20, 2008
    #9
    FLawless , i love it . i have a 2g iphone with 2.1 unlocked and JB . All i did was download 2.2 ipsw then go to itunes hit update. It did its thing then just open up 2.2 quickpwn and jailbreak it and choose unlock also let it do its thing and put it in DFU mode.
     
  8. CocoaPuffs macrumors 68010

    Joined:
    Aug 23, 2008
    #10
    There is no signal problem. The phone is not activated, thus appears to have no signal.
     
  9. benflick macrumors 68020

    benflick

    Joined:
    Jul 11, 2008
    Location:
    Cincinnati, Ohio
    #11
    Unlocked 2.2, not Jailbroken though. I have used Quickpwn, Winpwn, Pwnage Tool, and I've never had a problem. All you need to do is find a nice tutorial (iClarified) and follow it exactly. No worries.:)
     
  10. bier-meister macrumors regular

    Joined:
    Nov 25, 2008
    Location:
    Hamburg, Germany
    #12
    I had a few minor problems with a new macbook. pwngetool would fail to build, error message, "I haz failed", but the dev team released a new version (2.2.1) a few days ago which solved this problem. When I put the phone in DFU mode iTunes would throw up an error 21 message so I had to restart the phone and do the update from itunes using restore mode. No problems once it was updated.
     
  11. Quillz macrumors 65816

    Quillz

    Joined:
    Jan 6, 2006
    Location:
    Los Angeles, CA
    #13
    I just helped a friend who has T-Mobile, an iPhone and Windows Vista. I told him to upgrade to 2.2 via iTunes, which he did, and then run QuickPwn. He selected all the options, including the one to unlock, and everything worked just fine.

    If it didn't work for you, I recommend restoring to a fresh 2.2 firmware, and then running QuickPwn again.
     
  12. thesoze macrumors newbie

    Joined:
    Nov 25, 2008
    #14
    i've had problems - mentioned in other thread - wifi does not work anymore and battery usage was high, that was fixed by forcing close of safari

    don't know what happened this time - but my unlocks worked flawlessly
     

Share This Page