Anyone have displayutil and Apple TV 3.0 working?

Discussion in 'Apple TV and Home Theater' started by colinmack, Oct 31, 2009.

  1. colinmack macrumors regular

    Joined:
    Feb 25, 2006
    #1
    I've been using AppleScript to automate aspect ratio stretches in my TV/movie content, and would love to be able to stop doing it - I've tried for hours to get displayutil working, but can't (either with 2.4 or 3.0). Has anyone had any luck making it work with 3.0, and if so how?

    My process has been based on the atvusb-creator patchstick (only with ssh installed). I have two Apple TVs, one connected to a larger TV over component, and the second over composite using the TVComposite.kext patch (which works fine).

    When I run displayutil using every possible combination/variation of commands and delay times (and have tried running it during Music playing as was suggested in other forums), it does kick in, taunts me with a second or two of the properly-stretched Apple logo, and then kicks up the TV Resolution menu (with, of course, no appropriate setting), I'm then forced to pick one and revert back to standard stretched 480i. I even tried forcing a reboot as soon as I saw the unstretched logo, and was teased after it restarted with a properly letterboxed intro video... at which point it popped up the TV Resolution screen again, forcing me to pick one of the standards.

    The only option I've seen that avoids displayutil requires the composite HDMI adapter trick, but given the quality difference I'm not willing to give up component video on the larger set.

    Would love to hear from someone who has this working and can offer a solution that works for both component and composite, and ideally something that works under the atvusb-creator patchstick, given that I already have it loaded.

    Thanks!
     
  2. colinmack thread starter macrumors regular

    Joined:
    Feb 25, 2006
    #2
    As an update, I've now tried this on a second fresh Apple TV without the TVComposite.kext patch, just patchsticked to enable ssh and tried to run displayutil.

    Still no luck, can't seem to make displayutil work under 3.0... anyone else have any success?
     

Share This Page