Anyone having trouble with App Store updates in Mavericks?

Discussion in 'OS X Mavericks (10.9)' started by someone28624, Oct 24, 2013.

  1. someone28624 macrumors 6502a

    Joined:
    Aug 15, 2007
    Location:
    Buffalo
    #1
    Since updating to Mavericks the App Store shows I have 7 updates, including the three iWorks program, iMovie, Busy Cal 2 ,Voila, and Home Inventory. I have done all of these updates more than once now. The apps show the current version. The updates show as done in the "Updates Installed in the Last 30 Days" section. I cannot open any of my iWork programs because I get an error message saying they are being updated. I have tried restarting to no avail.
     
  2. 53kyle macrumors 65816

    53kyle

    Joined:
    Mar 27, 2012
    Location:
    Sebastopol, CA
    #2
    Mine is worse, it shows a few updates but when I click on the updates tab, I get a blank "shiny" white bar where my updates should be.
     
  3. serieuxchat macrumors newbie

    Joined:
    Oct 26, 2013
    #3
    Same problem

    I also have a problem with the 'shiny white bar'. Has anyone found a solution yet?
     
  4. Designed4Mac macrumors 6502

    Designed4Mac

    Joined:
    Jan 6, 2013
    Location:
    I Wish I Knew
    #4
    This a bit extreme i know but i was having the same problem and tried just about everything. In the end i reinstalled Mavericks (a fresh copy not clean install) and everything is working fine now.
     
  5. Mr. McMac Suspended

    Mr. McMac

    Joined:
    Dec 21, 2009
    Location:
    Far away from liberals
    #5
    Mine asked me for my Apple ID password for each and every update I did. Also, Keynote updated twice and shows 2 of the same version in the 30 day history.
     

    Attached Files:

Share This Page