Anyone here use a Pebble Watch with iOS 8?

Discussion in 'iOS 8' started by DDustiNN, Jun 2, 2014.

  1. DDustiNN macrumors 68000

    DDustiNN

    Joined:
    Jan 27, 2011
    #1
    My watch connects fine, I can get apps and such, and even control Pandora, but I am not receiving my text/email notifications on my Pebble anymore.

    I've restarted the watch and phone but still the same issue. Just wondering if I missed some setting somewhere, or need to change something, or if I just chalk it up to the beta.

    Yes... "It's a beta" I know :D
     
  2. billchase2 macrumors 68000

    billchase2

    Joined:
    Feb 28, 2006
    Location:
    Ann Arbor
    #2
    I had the same issue but after restarting my iPhone, the notifications now work properly.
     
  3. DDustiNN thread starter macrumors 68000

    DDustiNN

    Joined:
    Jan 27, 2011
    #3
    Really? Huh, I'll have to try again I guess. Thanks.

    ----------

    Ha... Okay, this time after restarting, I sent a test email from a different account, got the notification on my phone, but still not on my watch... But something new came up. My Touch ID turned off by itself, and it erased all my fingerprints, so I need to re-input them. Lame. Back to 7.1.1 I guess :(
     
  4. aziatiklover macrumors 68030

    aziatiklover

    Joined:
    Jul 12, 2011
    Location:
    8.8.8.8 and 8.8.4.4
    #4
    That's because the bluetooth LE is not connected. I just put my pebble on the side until they update their app to get the LE connection working.
     
  5. jwilson25 macrumors regular

    jwilson25

    Joined:
    Aug 25, 2009
    #5
    Thanks for posting this up, Pebble not working would be a deal breaker, so I think I'll have to sit this beta round out.
     
  6. DDustiNN thread starter macrumors 68000

    DDustiNN

    Joined:
    Jan 27, 2011
    #6
    Yep, that was my reason for switching back to 7.1.1 for now. That and my Touch ID settings randomly disappearing after a restart.
     
  7. Joeyfraser1978 macrumors newbie

    Joined:
    Jun 3, 2014
    #7
    Hi,
    Under bluetooth settings, select the non LE Pebble watch and activate the notifications!
    It was disabled by default.
    Thanks
     
  8. cwosigns macrumors 68000

    cwosigns

    Joined:
    Jul 8, 2008
    Location:
    Columbus,OH
    #8
    Can someone confirm that this solves the issue? I have two iPhones (5c and 5s) and the 5c is running the beta, but the 5s is what I use my Pebble with. I am loving the beta so far on the 5c and would install on the 5s, but I don't want it to break the Pebble functionality.
     
  9. Joeyfraser1978 macrumors newbie

    Joined:
    Jun 3, 2014
    #9
    I confirm that I was lucky for a couple of hours. There is issues with LE Bluetooth connection.
    I receive some notifications (sms) but not my emails....
     
  10. cwosigns macrumors 68000

    cwosigns

    Joined:
    Jul 8, 2008
    Location:
    Columbus,OH
    #10
    Did you try going into Notification Center and toggling "Show in Notification Center" for email yet?
     
  11. DDustiNN thread starter macrumors 68000

    DDustiNN

    Joined:
    Jan 27, 2011
    #11
    This is good to know, thanks! I was still having issues after switching back to 7.1.1 and even after "forgetting" and re-pairing. Checked on the notification thing in Bluetooth settings and it works now. Although the toggle was under the regular device listing, nothing under the LE one for me.

    Will keep this in mind when I try out beta 2!
     
  12. Kubus macrumors regular

    Joined:
    Jun 8, 2011
    Location:
    Montreal, QC
    #12
    Im getting call notifications but my texts and emails are also not coming in. Notification test in support menu works but otherwise Im not receiving notifications.

    There has to be some sort of bluetooth issues. My Knock to Unlock doesn't work with Yosemite and it takes 2-5 minutes for my Bluetooth to pair in my car while it used to take under 10 seconds... A bit frustrating but its a beta.
     
  13. Joeyfraser1978 macrumors newbie

    Joined:
    Jun 3, 2014
    #13
    I receive only my text and call notifications! I did not change any settings in my notification Center. The LE bluetooth issue is probably related to the notifications issues! :/
     
  14. Kubus macrumors regular

    Joined:
    Jun 8, 2011
    Location:
    Montreal, QC
    #14
    My pebble just received an update

    ----------

    LE connected
     
  15. Kubus macrumors regular

    Joined:
    Jun 8, 2011
    Location:
    Montreal, QC
  16. cschmelz macrumors 6502

    Joined:
    Jun 6, 2007
    #16
    Works for me too... It requires a bit of the old 'finger dance'. For me I had to manually connect the LE connection and then manually turn notification toggle on with the regular bluetooth connection.
     
  17. Kubus macrumors regular

    Joined:
    Jun 8, 2011
    Location:
    Montreal, QC
    #17
    It's still being a bit on and off. Rather unpredictable. Reconnecting it makes it stay connected for like an hour and then it disconnects again.
     
  18. matthew2926 macrumors 6502

    Joined:
    Sep 13, 2013
    Location:
    Michigan
    #18
    Yea, I'm having the same problems that all of you have described: sometimes notifications, sometimes not. I have given up on my Pebble via bluetooth connection with my iPhone until iOS 8 is released to the public and the notifications actually work. I just wear it as a regular watch for now.
     
  19. Kubus macrumors regular

    Joined:
    Jun 8, 2011
    Location:
    Montreal, QC
    #19
    Seems like beta 2 fixed my issues but I had to delete the pairing in bluetooth menu and re-pair
     
  20. Southern Dad macrumors 65816

    Southern Dad

    Joined:
    May 23, 2010
    Location:
    Shady Dale, Georgia
    #20
    Me, too.
     
  21. Cinder6 macrumors 6502

    Cinder6

    Joined:
    Jul 9, 2009
    #21
    Very, very spotty for me (5s). I can get notifications running about 10% of the time, maybe less. If it gets disconnected, then I have to do the finger dance again, which sometimes takes a few tries. I decided just to shelve my Pebble for now.
     
  22. mxidis88 macrumors member

    mxidis88

    Joined:
    Jul 8, 2013
    Location:
    SLC, UT
    #22
    I had to...

    ...completely reset my pebble and then reinitiate the connection. notifications are working for me know with beta2
     
  23. shandyman Suspended

    Joined:
    Apr 24, 2010
    Location:
    Dublin, Ireland
    #23

    I had to do this. Working fine now.
     
  24. matthew2926 macrumors 6502

    Joined:
    Sep 13, 2013
    Location:
    Michigan
    #24
    Today I restored back to 7.1.1 just because of the fact that I was unable to continue on without full Pebble function. I cannot live without my Pebble. Driving is nearly impossible and I never feel my iPhone vibrate in my pocket (I can't turn on the ringer because of disturbing other people that are very easily agitated :p).
     
  25. BrettDS macrumors 65816

    Joined:
    Nov 14, 2012
    Location:
    Orlando
    #25
    Might be a little late now, but I was able to get the pebble to work reasonably reliably under iOS 8 by not using the bluetooth LE connection and using the old 'finger dance' style of setting up notifications.

    It's certainly not perfect and the finger dance is a pain, but it's working well enough for me that I'm happy while I wait for Apple and/or Pebble to resolve the issues with iOS 8. You can see more details here...

    https://forums.getpebble.com/discus...ing-notifications-to-work-with-the-ios-8-beta
     

Share This Page