Anyone install Linux(any flavor) on a 2011 mini yet?

Discussion in 'Mac mini' started by vert18, Aug 17, 2011.

  1. vert18 macrumors member

    Joined:
    Oct 4, 2010
    #1
    Anyone install Linux(any flavor) on a 2011 mini yet?

    Currently trying builds in testing of Debian flavor. It gets through the install just fine, except the keyboard keymap.. (which you have to pick the kernel keymap instead of the default).

    But I am having problems with grub ;)

    See whats really bugging me is that.. my 2011 switches drives on me..
    WHAT? yeah really!! my disk0 switches with disk1 all the time..

    What mini 2011 do I have? 5,2 with i7core, 8gig ram, 256gb SD drive and 750gb 7200 speed HD and the amd radeon hd 6630M

    where am I attempting to install? on the 750gb hd...

    Put grub on the /dev/disk1s3 drive.. (not on the EFI on s1, nor the grubbios on s2...) reboot to refit and get Missing Operating system and if i try to boot my win7 on the same drive..it will get missing operating system as well)

    Not only that..because it likes to switch around my drives..???!!! it seems to screw with my SSD where OS X is(all alone) and refit starts showing EFI boot and a legacy drive...

    So anyone have any luck yet? ;)
    Nutshell: want to tripple boot, OSX alone on first drive and win7 and linux(debian hopefully) on the seondary drive..

    Running just fine with OSX(on first drive) and BOOTCAMP on end of second drive right now. Thinking Virtualbox just for linux ;)
     
  2. vert18 thread starter macrumors member

    Joined:
    Oct 4, 2010
    #2
    Guess Ill dig deeper into hybrid MBRs...

    I had zero problems when triple booting (OS X(snow leopard), debian, win7) on my macbook pro duo core... but that only had one HD.

    .. any help?

    reading on Hybrid MBRs.. an fdisk thing and gptsync tool...
     
  3. parapup macrumors 65816

    parapup

    Joined:
    Oct 31, 2006
    #3
    Tried refit? It's progress even that it installed. Also after installing refit - do not boot EFI Linux, boot the regular BIOS emulated one.
     
  4. vert18, Aug 17, 2011
    Last edited: Aug 17, 2011

    vert18 thread starter macrumors member

    Joined:
    Oct 4, 2010
    #4
    yeah I have refit...

    I ran refit on the macbook pro as well(ran fine and worked)

    Isnt helping me at this point..
    reading on a gptsync tool for os x at moment..
    &
    your link...


    --
    blah blah.. looking at something that says if i mess with the linux partition tool:

    if you make changes using any of the Linux partitioning tools (even just the type of a partition) and are using GPT you need to reboot and use gptsync or "Partition Tool" from rEFIt to resync GPT/MBR tables and then re-run the installer. If you forget to do this, installing the boot loader will fail.

    blah blah.. rEFIt seems to only work once.. (its partition tool) any time i have tried again, it doesn't make any changes...
     
  5. vert18, Aug 17, 2011
    Last edited: Aug 17, 2011

    vert18 thread starter macrumors member

    Joined:
    Oct 4, 2010
    #5
    think ill give it a night and go play some civ 5 on my mini @ 1080p ;)

    your progress link is an interesting read...
    least im getting passed the install to the last thing the BOOT LOADER ... LOL what a nightmare..

    word of warning, I am attempting to install linux to the "supposed" second drive of my 11 mac mini..

    It makes my win7 bootcamp..unreachable.(and no I am not telling grub to install to the mbr)

    I have such ugliness that I resort to booting to my linux disk just to repartion the whole mess just to get rid of the offending problems & to NET install Lion (wifi) from scratch. (done this a total of 4 times now) after several very long nights of monkeying around with linux's grub..

    It's ugliness described:
    1) rEFIt menu is showing OSX, Win7 and Linux at first reboot from linux install, but then it goes downhill fast.. win7 will then be a missing operating system as well as linux.
    2) on a power down and ON and alt key hold down will show EFI boots and legacy boots and no CD romdrive.. *rips hair out* anyone know how to edit the alt key menu to get rid of that crap? would save me from reinstalling os x :) ... I have to boot to OS X and reboot to see my CD rom drive while holding alt key @ boot
    3) rEFIt's partition tool doesnt like to do anything after my first attempt at installing linux, it seems to figure out something is different after the first attempt at linux install..cant really make heads or tails of its display... even a resisntall if rEFIt doesnt do anything..
    4) am I boring you yet ;) ?

    civ 5 here i come

    if I can figure out gptsyc tool and installing linux on a secondary hd.. and install GRUB, ill have a working Debian Linux ;)
     
  6. vert18 thread starter macrumors member

    Joined:
    Oct 4, 2010
    #6
    Installed Debian Linux running 3.0.0-1-amd64 in a virtual box on my 11mini

    Running fine..

    [​IMG]

    ill monkey with putting it on without virtual disk a few months down the line
     
  7. danny0085 macrumors newbie

    Joined:
    Jan 29, 2011
    #7
    install linux

    Here is a video tutorial how to install linux ubuntu step by step
     
  8. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #8
    Does a VM count? I've got a Ubuntu 11 virtual machine in Parallels 6. Seems to run pretty well.
     
  9. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #9
    I've installed ubuntu using vmware fusion. Runs perfectly.
     
  10. vert18, Aug 23, 2011
    Last edited: Aug 23, 2011

    vert18 thread starter macrumors member

    Joined:
    Oct 4, 2010
    #10
    Wrong. I don't have a pc, I have a mac, a mac mini 2011 to be exact(5,2).

    I have linux running just fine in a VM.. Virtual Box in fact. Debian GNU/Linux wheezy/sid 3.0.0-1 kernel
    I have BOOTCAMP(win7) running just fine on my second HD at the end of the drive.

    However, I could not figure out how to get grub working with the new machine specially on my second HD(where I had linux installed (along with bootcamp)... with rEFIt as well...
     

Share This Page