Anyone know how to stop Bridge CS3 vanishing?

Discussion in 'Mac Basics and Help' started by angryhive, Jun 20, 2008.

  1. angryhive macrumors newbie

    Joined:
    Jun 1, 2008
    #1
    Hello, does anyone know why Adobe Bridge would just disappear when performing operations like, moving the mouse or clicking a picture? It just literally disappears sometimes, four times today already and i've only been awake a few hours. This thing i'm typing on is an intel macbook. I saw somewhere that this, in conjunction with the absense of some obscure japanese font which bridge uses for it's star ratings or something, might cause bridge to crash or disappear. I found a bridge cs3 crash log, which reports this error: KERN_INVALID_ADDRESS (0x0001) at 0x2c48fe2c.

    Can anyone help me with this so i can get the hell off my ladyfriend's mac and back to my beloved linux, and even, god forgive me, windows XP?
     
  2. blogfooyung macrumors newbie

    Joined:
    Jun 20, 2008
    #2
    I would try the steps outlined here first.

    Could be a font, corrupted cache or image, or just a plain Bridge bug. The full crash log might help narrow it down.
     
  3. angryhive thread starter macrumors newbie

    Joined:
    Jun 1, 2008
    #3
    Yeah, that guide was the first thing i did. Also, this operating system has been freshly installed, so surely even i haven't messed up the filesystem yet, maybe. A quick google reveals a lot of peed off mac users whenever adobe updates bridge, so is this a regular occurance? Have they just recently released a shoddy update?

    I have noticed that bridge seems to crash more often when it has just tried to open an avi with quicktime or whatever, or even just when an avi is viewed. However, this is not the only time it happens. So bridge crashes when a file is corrupted sometimes? That's not very impressive! Why doesn't it display a message like "this image is corrupt, sorry"? Even windows preview manages this!!!

    anyway, as suggested, here is most of the log:

    OS Version: 10.4.11 (Build 8S2167)

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_INVALID_ADDRESS (0x0001) at 0xb9909078

    Thread 0:
    0 libSystem.B.dylib 0x90009cd7 mach_msg_trap + 7
    1 com.apple.CoreFoundation 0x9082d227 CFRunLoopRunSpecific + 2014
    2 com.apple.CoreFoundation 0x9082ca42 CFRunLoopRunInMode + 61
    3 com.apple.HIToolbox 0x92df1878 RunCurrentEventLoopInMode + 285
    4 com.apple.HIToolbox 0x92df0f82 ReceiveNextEventCommon + 385
    5 com.apple.HIToolbox 0x92f0799c ReceiveNextEvent + 58
    6 com.adobe.bridge2 0x002f011a Mondo::CProcess::Execute(Mondo::CFlags<unsigned long>) + 614
    7 com.adobe.bridge2 0x002e424a Mondo::CExecutable::RunExecute() + 78
    8 com.adobe.bridge2 0x002e42cb Mondo::CExecutable::Run() + 39
    9 com.adobe.bridge2 0x003b637a Mondo::CApplication::Main() + 58
    10 com.adobe.bridge2 0x003b6936 main + 84
    11 com.adobe.bridge2 0x000036d2 start + 258
    12 com.adobe.bridge2 0x000035f9 start + 41

    Thread 1:
    0 libSystem.B.dylib 0x900248c7 semaphore_wait_signal_trap + 7
    1 ...ple.CoreServices.CarbonCore 0x90cb8e0d MPWaitOnQueue + 198
    2 AdobeACE 0x02107743 0x20d7000 + 198467
    3 AdobeACE 0x02106f71 0x20d7000 + 196465
    4 ...ple.CoreServices.CarbonCore 0x90cb8c68 PrivateMPEntryPoint + 51
    5 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 2:
    0 libSystem.B.dylib 0x901101bf semaphore_timedwait_trap + 7
    1 MultiProcessor Support 0x17a4e06b ThreadFunction(void*) + 77
    2 ...ple.CoreServices.CarbonCore 0x90cb8c68 PrivateMPEntryPoint + 51
    3 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 3:
    0 libSystem.B.dylib 0x900248c7 semaphore_wait_signal_trap + 7
    1 ...ple.CoreServices.CarbonCore 0x90cb8e0d MPWaitOnQueue + 198
    2 com.adobe.CameraRaw 0x18fad89b 0x18e27000 + 1599643
    3 com.adobe.CameraRaw 0x18fad0ab 0x18e27000 + 1597611
    4 ...ple.CoreServices.CarbonCore 0x90cb8c68 PrivateMPEntryPoint + 51
    5 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 4:
    0 libSystem.B.dylib 0x900248c7 semaphore_wait_signal_trap + 7
    1 com.adobe.CameraRaw 0x18e66527 0x18e27000 + 259367
    2 com.adobe.CameraRaw 0x192d893b 0x18e27000 + 4921659
    3 com.adobe.CameraRaw 0x18ef1fd3 0x18e27000 + 831443
    4 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 5:
    0 libSystem.B.dylib 0x900248c7 semaphore_wait_signal_trap + 7
    1 com.apple.Foundation 0x9284f2fc -[NSConditionLock lockWhenCondition:] + 39
    2 com.adobe.bridge2 0x008d3d11 devtech_private::ZString::BackDoorGetUnicode(unsigned short*, unsigned long, bool) const + 633
    3 com.adobe.bridge2 0x008c60c5 devtech::ZString::GetInternalData(unsigned short const**, unsigned long*) const + 3023
    4 com.adobe.bridge2 0x008d182c devtech::ZString::GetInternalData(unsigned short const**, unsigned long*) const + 49974
    5 com.apple.Foundation 0x927f939c forkThreadForFunction + 123
    6 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 6:
    0 libSystem.B.dylib 0x90009cd7 mach_msg_trap + 7
    1 ...ple.CoreServices.CarbonCore 0x90c9cbf0 TS_exception_listener_thread + 168
    2 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 7:
    0 libSystem.B.dylib 0x90037b57 mach_wait_until + 7
    1 com.adobe.bridge2 0x002c54eb VCUI_Terminate + 833205
    2 com.adobe.bridge2 0x002a8819 VCUI_Terminate + 715235
    3 com.adobe.bridge2 0x002c55d5 VCUI_Terminate + 833439
    4 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 8:
    0 libSystem.B.dylib 0x900248c7 semaphore_wait_signal_trap + 7
    1 com.adobe.bridge2 0x00523105 vio_timeout + 117699
    2 com.adobe.bridge2 0x00adab02 st_tz_names_entry::st_tz_names_entry[in-charge]() + 1986
    3 com.adobe.bridge2 0x00507b82 vio_timeout + 5696
    4 com.adobe.bridge2 0x003c5704 Mondo::CThread::EntryProc() + 18
    5 ...ple.CoreServices.CarbonCore 0x90cb8c68 PrivateMPEntryPoint + 51
    6 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 9:
    0 libSystem.B.dylib 0x900248c7 semaphore_wait_signal_trap + 7
    1 com.adobe.bridge2 0x00523105 vio_timeout + 117699
    2 com.adobe.bridge2 0x00523618 vio_timeout + 118998
    3 com.adobe.bridge2 0x00523672 vio_timeout + 119088
    4 com.adobe.bridge2 0x003c5704 Mondo::CThread::EntryProc() + 18
    5 ...ple.CoreServices.CarbonCore 0x90cb8c68 PrivateMPEntryPoint + 51
    6 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 10:
    0 libSystem.B.dylib 0x90047dd7 semaphore_timedwait_signal_trap + 7
    1 ...ple.CoreServices.CarbonCore 0x90ce1da5 TSWaitOnSemaphoreCommon + 163
    2 ...ickTimeComponents.component 0x98171bb6 ReadSchedulerThreadEntryPoint + 4723
    3 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 11:
    0 libSystem.B.dylib 0x90047dd7 semaphore_timedwait_signal_trap + 7
    1 ...ple.CoreServices.CarbonCore 0x90ce1da5 TSWaitOnSemaphoreCommon + 163
    2 ...ple.CoreServices.CarbonCore 0x90cebcd8 AIOFileThread(void*) + 1068
    3 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 12:
    0 libSystem.B.dylib 0x90009cd7 mach_msg_trap + 7
    1 com.apple.CoreFoundation 0x9082d227 CFRunLoopRunSpecific + 2014
    2 com.apple.CoreFoundation 0x9082ca42 CFRunLoopRunInMode + 61
    3 com.apple.audio.CoreAudio 0x91469356 HALRunLoop::OwnThread(void*) + 158
    4 com.apple.audio.CoreAudio 0x91469171 CAPThread::Entry(CAPThread*) + 93
    5 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 13:
    0 libSystem.B.dylib 0x900248c7 semaphore_wait_signal_trap + 7
    1 ...ickTimeComponents.component 0x982de2ff jpegdecompress_MPLoop + 79
    2 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 14:
    0 libSystem.B.dylib 0x90047dd7 semaphore_timedwait_signal_trap + 7
    1 com.apple.audio.CoreAudio 0x914765a4 CAGuard::WaitFor(unsigned long long) + 212
    2 com.apple.audio.CoreAudio 0x914764c6 CAGuard::WaitUntil(unsigned long long) + 66
    3 com.apple.audio.CoreAudio 0x91474e42 HP_IOThread::WorkLoop() + 690
    4 com.apple.audio.CoreAudio 0x91474b8b HP_IOThread::ThreadEntry(HP_IOThread*) + 17
    5 com.apple.audio.CoreAudio 0x91469171 CAPThread::Entry(CAPThread*) + 93
    6 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 15 Crashed:
    0 <<00000000>> 0xb9909078 0 + -1181708168
    1 com.apple.CoreVideo 0x940e611a CVPixelBufferTextureBacking::initWithPixelBackingContext(CVPixelBufferBacking*, CVOpenGLContext*, __CFDictionary const*, CVImageBuffer*, int*) + 386
    2 com.apple.CoreVideo 0x940e455a CVPixelBufferBacking::createTextureBackingForContext(__CFAllocator const*, CVOpenGLContext*, __CFDictionary const*, CVImageBuffer*, int*) + 104
    3 com.apple.CoreVideo 0x940e2ac9 CVOpenGLTextureCache::createTextureFromImage(__CFAllocator const*, CVImageBuffer*, int*) + 141
    4 com.apple.CoreVideo 0x940e2734 CVOpenGLTextureCacheCreateTextureFromImage + 120
    5 ...ickTimeComponents.component 0x99001f99 OpenGLTVC_CopyImageForTime + 286
    6 ...ple.CoreServices.CarbonCore 0x90cd0a4f CallComponentFunctionCommon + 513
    7 ...ickTimeComponents.component 0x99002831 OpenGLTVC_ComponentDispatch + 163
    8 ...ple.CoreServices.CarbonCore 0x90cd0734 CallComponentDispatch + 34
    9 com.apple.QuickTime 0x9441696a QTVCCopyImageForTime + 55
    10 com.apple.QuickTime 0x94416869 QTVisualContextCopyImageForTime + 92
    11 com.adobe.bridge2 0x001eb6dc start + 1999116
    12 com.adobe.bridge2 0x001eb81a start + 1999434
    13 com.apple.CoreVideo 0x940ea322 CVDisplayLink::performIO(CVTimeStamp*) + 428
    14 com.apple.CoreVideo 0x940ea974 CVDisplayLink::runIOThread() + 1032
    15 libSystem.B.dylib 0x90024227 _pthread_body + 84

    Thread 15 crashed with X86 Thread State (32-bit):
    eax: 0x1c1d014f ebx: 0x940e5fa6 ecx: 0xa0813d04 edx: 0x052e1010
    edi: 0x1d57cab0 esi: 0x1c2cea80 ebp: 0xb061d7f8 esp: 0xb061d7cc
    ss: 0x0000001f efl: 0x00010282 eip: 0xb9909078 cs: 0x00000017
    ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037

    I left out the bit at the end, so tell me if this is useful. If anyone can see what the problem might be, i would greatly appreciate the help.
     
  4. blogfooyung macrumors newbie

    Joined:
    Jun 20, 2008
    #4
    Looks like it's crashing in Quicktime. Probably having a problem decoding an image or video. Check to see if there are any videos in Bridge and remove them and see if the problem goes away. Also make sure you have the latest version of Quicktime as there could have been some bug fixes that could resolve this.

     
  5. angryhive thread starter macrumors newbie

    Joined:
    Jun 1, 2008
    #5
    Thanks for looking over that for me. So, should there not be any video files in the bridge library at all? Or is this just because the file might have been corrupted or quicktime might be buggy?

    Anyway, i'll give it a go. Thanks again for your help!
     

Share This Page