Anyone know where the energy saver plist file is?

Discussion in 'Mac OS X Lion (10.7)' started by brodie, Jan 12, 2012.

  1. brodie macrumors member

    Joined:
    Mar 17, 2007
    #1
    Since updating to lion my mac pro won't stay asleep. It appears to wake at all the times i have ever set it to sleep and wake in the past, even though it is set to no longer sleep or wake in system prefs.

    I have tried everything and i'm left with trying to locate the power management plist and delete it. I have searched the web (and my OS) and can't find its location - beyond my home library plist which has been deleted time and time again.

    Any help please?
     
  2. prisstratton macrumors 6502

    prisstratton

    Joined:
    Dec 20, 2011
    Location:
    Winnipeg
  3. brodie thread starter macrumors member

    Joined:
    Mar 17, 2007
    #4
    Thank you both ^^ I have some tinkering to do...

    :)
     
  4. brodie thread starter macrumors member

    Joined:
    Mar 17, 2007
    #5
    Thought i would post my solution for others.

    I opened up the com.PowerManagement.plist and figured the values 1 and 0 correspond to a yes and no. The only yes values I had were 'sleep on power button' and 'TTYSPreventSleep', which sounded like a good candidate.

    I changed it to a zero and now my mac pro sleeps like a baby!

    Thanks for the pointers prisstratton and GGJstudios
     
  5. Robz macrumors newbie

    Joined:
    Aug 15, 2004
    Location:
    Cape Town
    #6
    Hi Brodie,
    do you just double click the PM.plist file and change the 'TTYSPreventSleep' to 0? i did this and it asked me to duplicate the file first, which i did, after duplicating it, i change the 'TTYSPreventSleep' to 0 and saved the file in the System Configuration folder. My computer still doesn't go to sleep on its own and when i try to manually put it to sleep the computer doesn't respond, even when i press the power button (have ticked the option in the Energy Saver prefs).
    Do you have any tips?
     
  6. brodie thread starter macrumors member

    Joined:
    Mar 17, 2007
    #7
    Yes duplicate it to your desktop and then replace or rename the original. You'll need admin privileges.

    I should add that though this worked for a while, the issue has come back, and the integer is still 0! I think it may have something to do with my new RAM, as that's all that's changed.

    Re sending it to sleep, I would delete both com.apple.PowerManagement.plist & com.apple.AutoWake.plist, and ~/preferences/byhost folder. See if that helps.
    I know that my Mac Pro won't let me set it to sleep if it's gone to screensaver, I have to double press.

    You can also try and reset the PRAM - restart holding :apple: option P+R until it chimes up again.

    All these things are basic goto's for Mac anomilies!
     

Share This Page