Anyone Noticing Safari in ML is slower compared to Lion?

Discussion in 'OS X Mountain Lion (10.8)' started by rg1980, Jul 10, 2012.

  1. rg1980 macrumors newbie

    Joined:
    Dec 8, 2011
    #1
    Anyone noticing that Safari is slower in ML compared to Lion. I installed ML GM without doing a clean install and I'm wondering if that may be the culprit.
     
  2. kingy04 macrumors newbie

    Joined:
    Jul 13, 2010
    #2
    Safari 6 is lightning fast for me :p did a fresh install tho

    cant open vuze when i download it tho it says installer corrupt.. anyone else getting this?
     
  3. SR71 macrumors 68000

    Joined:
    Jan 12, 2011
    Location:
    Boston, MA
    #3
    I thought it was considerably faster. What is the year and model of your Mac?
     
  4. cecoleman macrumors regular

    Joined:
    Nov 13, 2007
    #4
    I noticed it doesn't pick up where I left off once I close it and reopen it? Anyone else notice this? It always opens on my main start page ...never with any of my previously open tabs.
     
  5. rg1980 thread starter macrumors newbie

    Joined:
    Dec 8, 2011
    #5
    Early 2011 13 inch Macbook Pro - MC724xx/A
     
  6. mikegoldnj macrumors regular

    Joined:
    Apr 27, 2005
  7. jnl1211 macrumors 6502

    jnl1211

    Joined:
    Jan 29, 2011
    Location:
    NWIndiana
    #7
    I dont use it but my system overall has seemed slower.
     
  8. austinguy23 macrumors 6502a

    Joined:
    Oct 8, 2008
    #8
    Wirelessly posted

    Has anyone benchmarked Safari 6 on ML yet to see if it's faster than Chrome's latest offering for ML?
     
  9. Jelite macrumors 6502a

    Joined:
    Feb 16, 2008
    Location:
    UK
    #9
    Same here.
     
  10. XandeR803 macrumors member

    Joined:
    Jul 25, 2008
  11. Comeagain? macrumors 68020

    Comeagain?

    Joined:
    Feb 17, 2011
    Location:
    Spokane, WA
  12. Mosco macrumors regular

    Joined:
    May 26, 2002
    #12
    Seems fine to me.

    I just noticed that it now supports HTML5 notification API. Gmail email now shows up in notification center if you have safari open. About time.
     
  13. Takuro macrumors 6502

    Takuro

    Joined:
    Jun 15, 2009
    #13
    It should be faster, if your referring to the speed the browser renders pages. Try disabling extensions and see if this helps. If so, try to disable extensions individually in case one is the culprit. If not, try flushing the Safari cache or maybe even try the "Reset Safari" option.
     
  14. JohnDoe98 macrumors 68020

    Joined:
    May 1, 2009
    #14
    Safari on ML is insanely fast for me on my base RMBP and on a 25mbps fiber optic connection. Not stating stats to be pompous and brag but to point out it isn't Safari that's the problem.
     
  15. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #15
    It works if you turn off Gatekeeper. Having said that, Gatekeeper shouldn't be reporting that it's corrupt!
     
  16. Mike07335i macrumors member

    Joined:
    Jan 10, 2009
  17. chrf097 macrumors 68040

    chrf097

    Joined:
    Dec 16, 2011
    #17
    Safari is MUCH MUCH faster for me. I was going to switch to Chrome but DANG Safari got so much better. Only issue I have is the pinch to see tabs is super laggy for me.
     
  18. doh123 macrumors 65816

    Joined:
    Dec 28, 2009
    #18
    Gatekeeper does this a lot actually... it will tell you there is something wrong with the app and it needs to be deleted and give you the option to delete... turn off Gatekeeper (or use Right click and "open") and the app runs fine.
     
  19. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #19
    Right-click and Open didn't work, at least for Vuze. I turned off Gatekeeper in a previous build when trying to run an older app and never turned it back on, so I wasn't aware that it was causing trouble with so many apps.
     
  20. doh123 macrumors 65816

    Joined:
    Dec 28, 2009
    #20
    you never know whats gong to happen. Sometimes I've gotten the "you downloaded this from the internet" message just like 10.7 gets... on completely unsigned software ( I know was unsigned because it was mine)... so who knows what will happen, I find the whole thing very buggy.
     

Share This Page