anyone recovered a lost partition after defragging?

Discussion in 'Mac Basics and Help' started by immanence, Sep 3, 2009.

  1. immanence macrumors newbie

    Joined:
    Nov 12, 2008
    #1
    Okay people, horror story #xx.xxxx.xxxxxx/x:

    I had an external drive that I wanted to repartition. More precisely, I wanted to resize the partitions. I used Drive Genius 2. It claims to be able to safely do this. Wrong.

    The problem came when I tried to "shift" one partition on the disk, to open space that could be reclaimed by this same partition. Drive Genius has a way of doing this, but in shifting this involves defragging.

    It appears that this process, which was reported successful, destroyed all directory data on that partition. The first result was that the partition wouldn't mount. It is recognized as being there, but can't be mounted.

    Disk Utility can't repair it.

    Next I went to FileSalvage. It initially found files, but not the files that were actually on that partition.

    Next I went to Data Rescue II. Same story.

    What is being found is very old data and files long since deleted, but nothing from what was there before Drive Genius did its defragging / shifting of the partition.

    DiskWarrior tried but finds nothing.

    Applesoft File Recovery for Mac also comes up blank.

    Stellar Phoenix Data Recoverer is the same.

    I have lost about 50GB of data that I don't have backed up, but it's not so much of a disaster, because I can get it again, but still:

    My question is: Has anyone faced this specific kind of horror story with Drive Genius before and recovered their data?

    Lesson learned, of course: DO NOT THINK YOU CAN SAFELY REPARTITION A DRIVE ON THE FLY, EVER. Back it up and start over again.

    Still, any suggestions most welcome before I abandon this debacle.

    My two cents: Drive Genius is a piece of cr*p.
     
  2. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #2
    5 different tools can't get your data back. Move on.
     

Share This Page