Anyone return their 3GS for Wifi issues?

Discussion in 'iPhone' started by xolan99, Jul 9, 2009.

  1. xolan99 macrumors regular

    Joined:
    Oct 21, 2007
    #1
    So I read some articles that people have swapped out their 3GS because of Wifi issues...

    I've noticed that I'm consistently getting 1 or 2 bars of Wifi access on any network, even in my tiny studio apartment where I used to get full bars on my old 3G.

    Has anyone successfully swapped their 3GS to get one that has consistent strong Wifi signals? Or is this a software issue with 3.0 and should I wait for the next software update?

    Any input appreciated.
     
  2. WishIWasHere macrumors regular

    Joined:
    May 26, 2008
    #2
    I've kind of been wondering about this wifi issue also. I was actually relieved to find out that it wasn't just me with the problem. I'm hoping its just a software issue that will be fixed soon, but really have no idea so I'm just keeping an eye out for any news.
     
  3. petemwah macrumors regular

    Joined:
    Feb 10, 2009
    #3
    i've got this issue too, it's a real pain! i would return mine but it's running 3.1 beta software at the moment so not too sure if it would be covered until 3.1 GM is on it, either way i'll wait and see if 3.1 GM sorts it...
     
  4. thor79 macrumors 6502

    thor79

    Joined:
    Jun 8, 2008
    Location:
    Chicago, IL
    #4
    There's some sort of funkiness...

    I just turned my wifi back on a bit ago after seeing this thread (wanted to do some stuff specifically on 3G)...it wouldn't find any of the 3 Wireless-G networks (all on different channels) we have in our house (we have a complex network). It took a reboot for it to see them. Now turning off wifi and turning it on again results in it able to see them all without issue.
     
  5. xolan99 thread starter macrumors regular

    Joined:
    Oct 21, 2007
    #5
    So has anyone swapped their phone successfully for one that solved their Wifi issue?
     
  6. Mademan12321 macrumors 6502

    Joined:
    Jun 29, 2009
    #6
    No good for me

    I tried two exchanges with no luck. My friend who was over here had an iphone 3GS and his did the exact same thing. Yet his son has a ipod touch with 2.2.1 firmware and had excellent wifi the whole time over here. I don't think returns are going to help unless you have a bad screen or physical damage. I received an email from one of the reps to run a log of my wifi and send it to him so hopefully this will be ironed out on 3.1 official as 3.1 beta still has issues from my use. :mad:
     
  7. veritech137 macrumors newbie

    Joined:
    Jun 11, 2009
    #7
    yes, i have had issues with wifi as well. I was about to exchange my phone last weekend because of it.
     
  8. xxshawnxx macrumors member

    Joined:
    Aug 16, 2008
    Location:
    San Diego, California
    #8
    Same issue here. I don't think there's a point in exchanging the phone because even the replacements have the same issue. :confused:
     
  9. xolan99 thread starter macrumors regular

    Joined:
    Oct 21, 2007
    #9
    Well that's what I'm wondering...it seems some have said that swapping didn't help but I'm wondering if anyone has swapped and gotten one that didn't produce the same issue in the same environment?
     
  10. rjohnstone macrumors 68040

    rjohnstone

    Joined:
    Dec 28, 2007
    Location:
    PHX, AZ.
    #10
    The problem is not the hardware, it's the 3.0 software.
    I never had a WiFi issue on my 2G phone until I loaded the 3.0 software.
    My 3GS is the exact same way. The WiFi software is hosed.
     
  11. RumorHasIt.... macrumors member

    Joined:
    Jun 16, 2008
    Location:
    Minneapolis, MN
    #11
    3.0 needs to go!

    My experience, as well.
     
  12. Forko macrumors newbie

    Joined:
    Jun 19, 2009
    #12
    Same experience here....... Every morning I stream radio and need to restart it every 5 to 10 minutes. I have even tried multiple streaming apps.
     
  13. cWeems macrumors 6502a

    cWeems

    Joined:
    Jun 8, 2008
    Location:
    FLORIDA, USA
    #13
    no problems here....
     

    Attached Files:

  14. Forko macrumors newbie

    Joined:
    Jun 19, 2009
    #14
    My speeds are great, it just disconnects randomly and reconnects. This never happened on my 2g before I sold it until it had 3.0, now it the same for my 3GS.
     
  15. karenmb macrumors newbie

    Joined:
    Aug 14, 2007
    #15
    I have both a 2G and a 3Gs both with 3.0 software. The wifi on the 2G stays strong all the time. The 3G varies. So I don't think it's the software.
     
  16. tico24 macrumors 6502

    tico24

    Joined:
    Jun 17, 2007
    Location:
    Eastleigh, UK
    #16
    I swapped my 3GS for the wifi issue (and also a dire battery issue too).

    The new one works like my old iPhone 3G.
     

Share This Page